FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
5347 Discussions

Need help with control panel application for Cyclone II Starter Kit (DE1)

Altera_Forum
Honored Contributor II
849 Views

I installed the Cyclone II Starter Kit CD on my Windows/XP machine. I'm able to use Quartus II 7.1 (web) to compile and then download projects to the board. This works fine. 

 

However, I cannot get the "Control Panel - Starter II Kit" application to work. I launch it, and the application window comes up. It appears to work fine -- I can 'open USB' connection to my board, then click on the various tabs (sram, sdram, led, etc.) and toggle the controls. However, when I click 'set' on anything, nothing happens. I see the blue-light on my Kit board flicker momentarily, so it's getting some kind of traffic from the PC. But otherwise, nothing happens. 

 

For example, I tried the 'SRAM' tab, and wrote several unique values (0x0123, 0x4567) to the SRAM at address 0x00 and 0x01. But, when I read them back, they always come back 0x0000. The Control Panel's built-in self-test also fails on the sdram, sram, and flash. 

 

What am I doing wrong? I tried toggling the RUN/PROG switch (SW12) back and forth, then cycling power to the board. With either position, Control Panel applet still doesn't work. 

 

<<UPDATE>> 

 

Ok, I figured it out. It turns out, you have to download a different bitstream file "DE1_USB_API.pof DE1_USB_API.sof" to the FPGA-board. My board came with a different preloaded bitstream, and that one wouldn't talk to the Control Panel applet at all. 

 

For whatever reason, the CD didn't install that automatically, I had to download the latest CD-image from www.terasic.com, and extract the bitstreams from "DE1_control_panel\"
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
109 Views

Can you please be more specific about where you actually found the file the fixes your problem? Thanks.

Reply