Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
412 Views

On-board blaster recognition problem on CentOS 7

Hello.​

On-board blaster not detected. My FPGA board is Stratix 10 MX FPGA Development Kit, and OS is CentOS 7. The board and the PC are directly connected to each other through Micro USB Cable. I am using Quartus II version 19.1.

 

To use the usb blaster, the file 51-usbblaster.rules was created as shown in the link below. The udevadm control --reload-rules command was used to reload the rule.

 

https://www.intel.com/content/www/us/en/programmable/support/support-resources/download/drivers/dri-...

 

The system seems to be recognizable with lsusb command, but when I run BoardTestSytem.sh, the board was not recognized, and PC display a warning message.

 

lsusb1.png

 bts1.png

 

dmesg.png

 

warning1.png

 

I hope an expert will help me with this problem.

Tags (1)
0 Kudos
5 Replies
Highlighted
Employee
7 Views

Hi Sang, As per your explanation, you are able to detect the usb and program the development kit. That means the JTAG connection is established. Meanwhile for Board Test System, can you try to change the TCK frequency to 6MHz, use Quartus v18.0.1 and follow the steps as shown below: https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/ug-intel-s10-mx-devl-kit... (Page 65) Regards, YL
Highlighted
Beginner
7 Views

Hello SooYL,

Thank you so much for your reply.

I tried to configure TCK frequency. I used "jtagconfigure" commmand and my PC found the FPGA Development Kit.

new_usb.png

 

and then, I tried to execute BoardTestSystem.sh. but I faced java problem.

java_problem.png

How can I solve this problem?

 

Thanks.

0 Kudos
Highlighted
Employee
7 Views

Hi Sang,

 

Just would like to confirm, have you use Quartus v18.0.1 and follow the steps as shown below:

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/ug-intel-s10-mx-devl-kit... (Page 65)

 

Regards,

YL

0 Kudos
Highlighted
Beginner
7 Views

Hello YL,

Thank you for your reply.

I installed Quartus v18.0.1. I can execute the BTS.

But I can't configure fpga design.

I executed "configure with *** Design" in Board Test System.

However, the BTS has not changed.

 

I attach the teminal log file(log.txt) and screenshots.

 

Thanks,

 

bts_window.pnglog.png

0 Kudos
Highlighted
Employee
7 Views

Hi Sang,

 

From the error message, seems like you are using the wrong programming file. In the installation kit, it has programming file for both ES and production. If you development kit is production version, you will need to select production programming file. Vice versa for ES.

 

Regards,

YL

0 Kudos