Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
769 Views

Problems using Cyclone III Dev Board and Bitec DVI daughter card

Hi, 

 

 

I'm working with Cyclone III Development Board and the Bitec HSMC DVI daughter card. 

 

I'm trying to get the loop through example from the Bitec website working - but it wouldn't. DVI-In is connected to a PC and DVI-out is connected to a flatscreen. 

 

In the example there is the following design flow: 

clocked video in -> trippe frame buffer -> tripple frame buffer -> clocked video out 

 

They argument for using two frame buffers that the users application should be placed between the two frame buffers. 

 

When testing the loop through example, there is still a very strong flickering and there are still some repetitions of the displayed image on the screen. 

 

BUT - If I REMOVE the top-bank-buffer of their example and only use the bot-bank-buffer - it works?! 

When using only the top bank instead of the bottom bank it doesn't work. There's still a flickering and there are still some 

repetitions of the displayed image... 

 

Ok... Does it mean, that my hardware is probably damaged or could this 

behavior be the result of another problem? 

 

Is there any easy possibility of testing the top bank. Or are there 

probably wrong settings? 

 

What could be the problem? Does anyone has any idea? 

 

 

Thanks for your assistance! 

 

Best regards, 

dbdeset
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
50 Views

EDIT: 

Did you ONLY remove the output pins from the schematic? 

opne the SOPC builder and remove one frame buffer only, it should not flicker. 

They suggest two frame buffers to peform clock crossing between your custom block and pixel in-out clock.
Altera_Forum
Honored Contributor I
50 Views

Hi phate, 

 

Thanks for your answer... 

 

No, I removed the frame buffer in the SOPC builder in each case. 

When only using the bot-bank-buffer in SOPC builder everything works. 

When only using the top-bank-buffer in SOPC builder there is the flickering... 

 

Best regards, 

dbdeset
Reply