FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
5416 Discussions

Quartus (21.1 Lite) can no longer see my USB Blasters (Terasic) on Windows after auto-update

FPGA-NYC
Novice
230 Views

Hi folks,

I have been happily using Quartus Prime 21.1 Lite (Windows 10) with several Terasic boards (including DE0-Nano, Cyclone V GX Starter Kit, DE2-115) the last month or so with a new computer.

Yesterday, the computer did it's annoying "auto Microsoft update thing and reboot" - and today I have been unable to work with my boards anymore.

I tried reinstalling the drivers (DPInst.exe). I even rebooted into "allow unsigned drivers" and reinstalled them. However, nothing. I have no ability to see the boards. The Device Manager shows the Altera USB-Blaster when connected (driver date 8/16/2017, version 2.12.28.0). The does computer beeps when I insert and remove the boards.

I have tried several things:

  • Uninstalling/installing the drivers, including a reboot with unsigned drivers allowed
  • Different USB cables
  • Different USB ports on the computer, with and without a hub

But none of this works - none of these things see the board:

  • jtagconfig
  • quartus_pgm --auto
  • Quartus GUI using Quartus Programmer or Signal Tap UI
  • The Terasic "Control Panel" for the board
  • Running all the above as administrator instead of my regular user

My windows version is now 10.0.19044 Build 19044, HAL is 10.0.19041.1503. It runs with the hypervisor because I have WSL2 enabled.

BUT: Nothing has changed, just the computer decided to self-update and reboot overnight.

Please help??

Thanks!

 

0 Kudos
2 Replies
FPGA-NYC
Novice
193 Views

Since nobody responded, here's what I did which eventually did SOMETHING:

 

1. Unplug as many USB devices as possible

2. Stop as many programs as possible in the system tray and running

3. Kill the "jtagserver" a few times from Task Manager

4. Plug in and out the FPGA board (USB Blaster)

 

Eventually the jtagconfig was able to see the board again. I have no idea which of these things worked.

YuanLi_S_Intel
Employee
182 Views

It could be. There are lots of possibility when windows is updated. Probably a restart of system could help also.


Reply