FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5241 Discussions

Quartus II 11.1 SP2 and DDR2 controller

Altera_Forum
Honored Contributor II
789 Views

I'm trying to compile the ddr2_x32_example that comes with the Cyclone IV GX devkit, and I'm having no luck. It comes up with the following error: 

 

Error (15096): Can't implement PLL "ddr2_x32:ddr2_x32_inst|ddr2_x32_controller_phy:ddr2_x32_controller_phy_inst|ddr2_x32_phy:ddr2_x32_phy_inst|ddr2_x32_phy_alt_mem_phy:ddr2_x32_phy_alt_mem_phy_inst|ddr2_x32_phy_alt_mem_phy_clk_reset:clk|ddr2_x32_phy_alt_mem_phy_pll:pll|altpll:altpll_component|altpll_mfl3:auto_generated|pll1" The software used is Quartus II 11.1 with SP2 on a 32bit XP machine. The same example compiles without errors on Quartus 2 10 but on a 64-bit linux machine. Unfortunately I have no access to a 11.1 on the same linux server. 

 

I've also tried to generate a DDR2 controller with ALTMEMPHY for the Cyclone IV GX with the Megawizard Plug-In manager, and it keeps displaying an error about not being able to synthesize a PLL for the given input/output clock combination. I have tried reference clock 100MHz and memory clock frequency 200MHz and several other combinations as well without luck. 

 

Is this a known problem with Quartus 11.1? I've had no luck in searching this forums as many results came back as 403-Forbidden (and this seem to be connected to the length of the search string).
0 Kudos
0 Replies
Reply