FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

Resetting the board

Altera_Forum
Honored Contributor II
827 Views

Hai, 

 

I am using Altera Cyclone V board https://www.altera.com/products/boards_and_kits/dev-kits/altera/kit-cyclone-v-soc.html 

 

I used the preloader generated by bsp-editor, programmed the same using HPS software to QSPI flash memory. 

 

Next to preloader I programmed the baremetal-application(LED blinking program). I programmed the same using HPS software to QSPI flash memory. 

 

After power-on reset, the execution of program is perfect, First the preloader executes and then my program executes.. 

 

But When I press, the reset buttons in the board, there is no response.  

1. When i press warm and cold reset button, the controller is hanged. 

2. When I press cpu reset button, there is no response. 

 

 

Could any one please help me to solve the issue..
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
101 Views

look, i caught by this issue before, it was some bug with the board reset mechanism that causing the system failed to boot in qspi mode!

Altera_Forum
Honored Contributor II
101 Views

 

--- Quote Start ---  

look, i caught by this issue before, it was some bug with the board reset mechanism that causing the system failed to boot in qspi mode! 

--- Quote End ---  

 

 

And how did you solve it? Or what did you do a out it? 

x
Altera_Forum
Honored Contributor II
101 Views

fastest way is use QSPI Flash Part which is < 16MB capacity.

Reply