FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5241 Discussions

Stratix 10 FPGA programming not happening in Intel® Stratix® 10 DX FPGA Development Kit

musthafavakeri
401 Views

Hi All,

I want to program Stratix 10 FPGA in Intel® Stratix® 10 DX FPGA Development Kit. Following are some settings I have given in QSF file as per the board guideline ( https://www.intel.com/content/www/us/en/programmable/documentation/cko1566842257868.html#ysj15676118... ).

#####################CONFIGURATION##########################
set_global_assignment -name STRATIXV_CONFIGURATION_SCHEME "AVST X8"
set_global_assignment -name MINIMUM_SEU_INTERVAL 10000
set_global_assignment -name ACTIVE_SERIAL_CLOCK AS_FREQ_115MHZ_IOSC

####################POWER MANAGER###########################
set_global_assignment -name USE_CONF_DONE SDM_IO16
set_global_assignment -name USE_CVP_CONFDONE SDM_IO5
set_global_assignment -name VID_OPERATION_MODE "PMBUS MASTER"
set_global_assignment -name USE_PWRMGT_SCL SDM_IO0
set_global_assignment -name USE_PWRMGT_SDA SDM_IO12
set_global_assignment -name PWRMGT_BUS_SPEED_MODE "100 KHZ"
set_global_assignment -name PWRMGT_SLAVE_DEVICE_TYPE OTHER
set_global_assignment -name PWRMGT_SLAVE_DEVICE0_ADDRESS 60
set_global_assignment -name PWRMGT_SLAVE_DEVICE1_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE2_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE3_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE4_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE5_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE6_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE7_ADDRESS 00
set_global_assignment -name PWRMGT_VOLTAGE_OUTPUT_FORMAT "DIRECT FORMAT"
set_global_assignment -name PWRMGT_DIRECT_FORMAT_COEFFICIENT_M 1
set_global_assignment -name PWRMGT_DIRECT_FORMAT_COEFFICIENT_R 3
set_global_assignment -name PWRMGT_TRANSLATED_VOLTAGE_VALUE_UNIT VOLTS
set_global_assignment -name PWRMGT_PAGE_COMMAND_ENABLE OFF

I changed 'Hardware Frequency' to 16000000 Hz and programmed. The programmed window showed programming successful. Then I did power cycle. But program_done LED is not glowing.

 

But when I created an example design for PCIe, programming is happening. Then I copied QSF of that project into my custom project. Still, the FPGA program_done LED is not glowing. Following is the concerned settings in example design QSF file.

set_global_assignment -name USE_PWRMGT_SCL SDM_IO0
set_global_assignment -name USE_PWRMGT_SDA SDM_IO12
set_global_assignment -name VID_OPERATION_MODE "PMBUS MASTER"
set_global_assignment -name PWRMGT_BUS_SPEED_MODE "400 KHZ"
set_global_assignment -name PWRMGT_SLAVE_DEVICE_TYPE OTHER
set_global_assignment -name PWRMGT_SLAVE_DEVICE0_ADDRESS 60
set_global_assignment -name PWRMGT_SLAVE_DEVICE1_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE2_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE3_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE4_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE5_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE6_ADDRESS 00
set_global_assignment -name PWRMGT_SLAVE_DEVICE7_ADDRESS 00
set_global_assignment -name PWRMGT_PAGE_COMMAND_ENABLE OFF
set_global_assignment -name PWRMGT_VOLTAGE_OUTPUT_FORMAT "DIRECT FORMAT"
set_global_assignment -name PWRMGT_TRANSLATED_VOLTAGE_VALUE_UNIT VOLTS
set_global_assignment -name STRATIXV_CONFIGURATION_SCHEME "AVST X8"
set_global_assignment -name MINIMUM_SEU_INTERVAL 10000
set_global_assignment -name USE_CONF_DONE SDM_IO16
set_global_assignment -name ACTIVE_SERIAL_CLOCK AS_FREQ_115MHZ_IOSC
set_global_assignment -name ERROR_CHECK_FREQUENCY_DIVISOR 1
set_global_assignment -name PWRMGT_DIRECT_FORMAT_COEFFICIENT_M 1
set_global_assignment -name PWRMGT_DIRECT_FORMAT_COEFFICIENT_R 3

Can anyone help out as I have been working on this issue for the last 4 days.

Thanks in advance...

0 Kudos
4 Replies
YuanLi_S_Intel
Employee
388 Views

By right if configuration is successful. The design should be programmed into it. Can i check the following with you?


1) What is the bitstream used to program the FPGA?

2) Is your output pointing correctly to the LED on the board?


musthafavakeri
385 Views

Hi @YuanLi_S_Intel ,

1) am using POF to program the FPGA through AVSTx8 interface

2) set_global_assignment -name USE_CONF_DONE SDM_IO16 is pointing to the fpga_config_done LED on board.

 

Thanks

YuanLi_S_Intel
Employee
374 Views

Oh, the LED you meant is actually the LED connecting to CONF_DONE. This means that configuration is not successful. Do you have any error message? Can share me the error message obtained from Quartus Programmer?


eolse
Beginner
91 Views

I am having a similar issue.  I can't program the Stratix DX development board.  It fails at about 6%.

 

I've updated the power management and VID according to the notes for supporting the emperion power management chips.

 

It looks like my PMBus addresses are wrong.  Here is the message:

 

Error(18950): Device has stopped receiving configuration data
Error(18948): Error message received from device: External hardware access error. (Subcode 0x0032, Info 0x00200008, Location 0x00001800)
Error(22248): Detected a PMBUS error during configuration. Potential errors: VID setting is incorrect in the Intel Quartus Prime project. The target device fails to communicate to a smart regulator or PMBUS master on a board.
Error(209012): Operation failed

 

Can anybody help me with programming this device   Please!

Reply