FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5202 Discussions

System Console connection problem with DE0-NANO-SOC kit

Altera_Forum
Honored Contributor II
897 Views

Hi, 

I am beginner with FPGA. 

I started with DE0-NANO-SOC kit and GHRD example supplied (DE0_NANO_SOC_GHRD) with the kit using Quartus 17.0 Lite edition. 

I am trying with System console to get hand on debugging. The device got found. 

But with system console, there is no connection listed under "device > (link) > JTAG". 

And upon executing tcl command: "get_Service_path master", it returns nothing. 

I tried to reinstall JTAG driver but no light. 

So if anybody can guide me here, what is wrong with system console connection? 

 

Thanks.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
106 Views

https://alteraforum.com/forum/attachment.php?attachmentid=15792&stc=1 I got it in working state. 

It was my mistake. I was trying to run without loading the relevant .sof into the fpga. 

 

Now I am facing problem with nios2-terminal. 

it recognizes the connection as shown in attached image but then it does not respond at all. 

Any clue ?
Altera_Forum
Honored Contributor II
106 Views

The last query about NIOS2 terminal is also resolved. 

It was due to modified tcl script "ghrd_sc_script.tcl" which I run in the console. 

Using native command (without using the tcl script) in system console, I can see the characters in the nios2 terminal screen sent by system console using JTAGUART. 

 

As data can be sent by writing that data to the JTAGUART base address in system console's tcl script, 

is it possible to send data over JTAG UART using verilog or vhdl (without system console) ? 

In other words, how can JTAG UART base address be accessed in HDL approach ? 

 

Thanks.
Reply