FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5154 Discussions

Terrasic DE2 USB OTG Demo appllication = "No Device connected"

Altera_Forum
Honored Contributor II
823 Views

Hello Everybody, 

 

I am trying to get the USB demo " DE2_115_USB_DEVICE" for the Terrasic DE2 running.. 

 

From the FPGA side I see nothing irregular: The Console window in Eclipse reports that the USB OTG is alive but it also says that the Host Pc Is not responding. 

 

From the PC side, I have the x64 driver in the "WLH" directory installed that came with the DE2. Cypress tools distribute a less recent version (tried this driver as well). My OS is Win7. 

 

Windows displays "Terrasic Ezo USB" in the device manager and reports a digital signature missing. I did disable driver signing this did not help. I can start and stop the device driver in the windows device manager. 

 

When i start the USB Control EZO demo application in the demo_batch directory, the app says "No Device Connected".  

 

Does anybody have any clues to activate the connection between the demo app an the DE2 ? 

 

(The "USB tool" reports "Device connected", but with black exclamation mark symbol, bDeviceClass = 0xFF, bDeviceSubClass=0xFF, bDeviceProtocol=0xFF, bMaxPacketSize=0x64, idVendor=0x09FB,idProduct=0xDE2) 

 

Any help is welcome, 

Johi. 

 

Update: 

I tested on a very old Xp 32bit PC. ith this PC the application works = driver installs without any problems, demo app runs.  

 

Or the driver is not compatible with Win7 64 bit or the application or both are not. Does anybody has DE2 USB running on Win7 ?
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
97 Views

 

 

the culprit was disabling of driver signing. 

 

temporary method: 

 

 

1. During booting your PC/Laptop, press "F8" key continously to access the "Advanced Boot Options" 

 

 

2. Use the "Down" arrow key to scroll down to “Disable Driver Signature Enforcement” 

 

 

3. Press "Enter" to choose. 

 

 

4. It will automatically reboot disabling the enforcement accordingly, as shown below:- 

 

 

 

 

 

permanent method: 

 

 

5. start  

 

 

6. type cmd (look for CMD program, do not hit enter) 

 

 

7. right click on cmd menu + run as admin 

 

 

8. bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS 

bcdedit -set TESTSIGNING ON 

Reply