FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5152 Discussions

Tri-state Conduit bridge signals are not matching with the generic tri-state controller

PShetty
Novice
1,087 Views

Hi,

we are using tri-state conduit component to interface to the FIDO/Ethernet switch in Arria 10 SoC. But Generic ti-state controller master port-tcm signals and tri-state conduit bridge slave port -tcs signals are not matching and Qsys system connection is providing the errors. Please see the attached figures where you can see the differences and Qsys errors. Tri-state bridge IP has only request and grant signals in tcs port.it doesnt have data_in, data_out and other signals.

Please let us know why this is happening.

 

Thank you

 

0 Kudos
3 Replies
Nathan_R_Intel
Employee
174 Views

Hie,

 

I don't have details on your full QSYS design, hence I believe you have identified the problem which is the conduit component used does not have an interface that  matches the Generic Tristate Controller.  If your Quartus version don't have a tri-state conduit component that matches, then you will need to build the bridge yourself. Do let me know you Quartus version, so I can check and advice accordingly. 

 

Regards,

Nathan

PShetty
Novice
174 Views

Hi Nathan,

Thank you for the reply. quartus version is Quartus Prime Pro 18.0 .

I have solved the issue by using Synch all option in system Info tab in Qsys .

Nathan_R_Intel
Employee
174 Views

This is good news. ​

Reply