FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

Why can't I modify the sysfs

RSarw
Beginner
1,923 Views

Hi

 

I was going through a tutorial on a DE10-Nano on how to make custom overlays, and I seem to have hit a bit of a puzzle.

https://rocketboards.org/foswiki/Documentation/HOWTOCreateADeviceTree

 

At one stage, it requires me to create a directory and update values in sysfs.

sudo mkdir /sys/kernel/config/device-tree/overlays/my-cv-fpga-overlay sudo echo my_cv_fpga_overlay.dtb > /sys/kernel/config/device-tree/overlays/my-cv-fpga-overlay/path

Problem is I cannot seem to do so. the command returns "Operation not permitted" error message.

I tried the LDXE linux image from terasic and also a rootfs/kernel that I made based on ubuntu base and kernel 4.9...lsti

https://github.com/rsarwar87/altera-soc-rootfs

 

Presumably it is some kernel configuration that I need to turn on maybe to allow modification of sysfs? I was wondering if anyone could kindly shed some light on this puzzle.

 

Thanks

RD

 

0 Kudos
1 Solution
RSarw
Beginner
839 Views

Hi Anand

 

Thank you for your reply. Unfortunately logging in as root did not help.

 

however, I remounted the configfs with the following code and was able to edit it like normal.

sudo mount -t configfs none /config

 

Br

R

View solution in original post

2 Replies
AnandRaj_S_Intel
Employee
839 Views

Hi,

 

Can you run the command in root privilege and without sudo.

like :root@socfpga:~# mkdir /sys/kernel/config/device-tree/overlays/my-cv-fpga-overlay 

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance.

 

Best Regards,

Anand Raj Shankar

(This message was posted on behalf of Intel Corporation)

 

RSarw
Beginner
840 Views

Hi Anand

 

Thank you for your reply. Unfortunately logging in as root did not help.

 

however, I remounted the configfs with the following code and was able to edit it like normal.

sudo mount -t configfs none /config

 

Br

R

Reply