FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5203 Discussions

aocl-clang exists but is not working!

SPere43
Beginner
434 Views

 

Hello guys.

I'm tried run one simple example(boardtest) on opencl.

I followed all the indications that were recommended, but when im tried apply command:

 

aoc device/boardtest.cl --sw-dimm-partition -o bin/boardtest.aocx

Capturar77.JPGThe console return one error: "aocl-clang exists but is not working!"

I'm working in ubuntu.

 

0 Kudos
3 Replies
MEIYAN_L_Intel
Employee
303 Views

Hi,

May I know the information as below:

  1. Device used (OPN number for the device)
  2. OpenCL SDk version and edition
  3. Ubuntu version

Thanks

 

SPere43
Beginner
303 Views
MEIYAN_L_Intel
Employee
303 Views

Hi,

 

According to https://www.terasic.com.tw/cgi-bin/page/archive.pl?Language=English&No=836&PartNo=4, the DE1-SoC device with BSP provided by Terasic is only supported until Altera SDK OpenCL 16.0.

 

For your information, OpenCL SDK v16.1 is not supported with Ubuntu v18.04. For more information, you may refer to the link below:

https://www.intel.com/content/dam/altera-www/global/en_US/others/download/os-support/readme-qp161.tx...

 

Thanks

Reply