Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
807 Views

dhcp response for multiple ethernet port application

Hi, there: 

 

 

I try to build a project with Ethernet daughter card and Altera Startix III DE3 board. I hope both Ethernet ports on the daughter card can communicate with the host PC simultaneously via Telnet. Now, two Ethernet ports on one Ethernet daughter card has been assigned with individual MAC address and static IP address. And I expect the DHCP can initialize both Ethernet interfaces. However, only one port has been initialized. You can see the details from following running result. I carried out some debug, and I found that both Ethernet has sent out it own DHCP request. But the DHCP server only response one request. Therefore, only one Ethernet port get initialized. I am very curious that why the DHCP server can only response these request once. Is there additional setting I need to implement on the DHCP request package? Anyone can give me some suggestion? Thanks.  

 

 

 

 

prep_tse_mac 0 

Your Ethernet MAC address is 00:07:ed:12:8f:ff 

prep_tse_mac 1 

Your Ethernet MAC address is 00:07:ed:12:0f:8f 

prepped 2 interfaces, initializing... 

[tse_mac_init iface=0] 

INFO : TSE MAC 0 found at address 0x11045000 

INFO : TSE MAC 1 found at address 0x11046000 

INFO : PHY Marvell 88E1111 found at PHY address 0x12 of MAC Group[0] 

INFO : PHY[0.0] - Automatically mapped to tse_mac_device[0] 

INFO : PHY[0.0] - Restart Auto-Negotiation, checking PHY link... 

INFO : PHY[0.0] - Auto-Negotiation PASSED 

INFO : PHY Marvell 88E1111 found at PHY address 0x12 of MAC Group[1] 

INFO : PHY[1.0] - Automatically mapped to tse_mac_device[1] 

INFO : PHY[1.0] - Restart Auto-Negotiation, checking PHY link... 

INFO : PHY[1.0] - Auto-Negotiation PASSED 

INFO : PHY[1.0] - Checking link... 

INFO : PHY[1.0] - Link established 

INFO : PHY[1.0] - Speed = 100, Duplex = Full 

TSEMAC SW reset bit never cleared! 

OK, x=10002, CMD_CONFIG=0x00002000 

MARVELL : Mode changed to GMII to copper mode 

MARVELL : Disable RGMII Timing Control 

MARVELL : PHY reset 

 

 

MAC post-initialization: CMD_CONFIG=0x04000203 

[tse_sgdma_read_init] RX descriptor chain desc (1 depth) created 

[tse_mac_init iface=1] 

INFO : PHY[0.0] - Checking link... 

INFO : PHY[0.0] - Link established 

INFO : PHY[0.0] - Speed = 100, Duplex = Full 

TSEMAC SW reset bit never cleared! 

OK, x=10002, CMD_CONFIG=0x00002000 

MARVELL : Mode changed to GMII to copper mode 

MARVELL : Disable RGMII Timing Control 

MARVELL : PHY reset 

 

 

MAC post-initialization: CMD_CONFIG=0x04000203 

[tse_sgdma_read_init] RX descriptor chain desc (1 depth) created 

mctest init called 

IP address of et1 : 192.168.3.234 

Created "Inet main" task (Prio: 2) 

Created "clock tick" task (Prio: 3) 

Acquired IP address via DHCP client for interface: et2 

IP address : 192.168.3.155 

Subnet Mask: 255.255.255.0 

Gateway : 192.168.3.1 

 

 

Simple Socket Server starting up 

[sss_task] Simple Socket Server listening on port 30 

Created "simple socket server" task (Prio: 4)
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
70 Views

Any response?

Altera_Forum
Honored Contributor I
70 Views

 

--- Quote Start ---  

Any response? 

--- Quote End ---  

 

 

I have some problem. 

 

board with CYCIII + 2 PHY KSZ9021GQ. 

 

Log start: 

 

InterNiche Portable TCP/IP, v3.1  

 

Copyright 1996-2008 by InterNiche Technologies. All rights reserved.  

prep_tse_mac 0 

Your Ethernet MAC address is 11:22:33:44:55:66 

Static IP Address is 192.168.3.250 

prepped 1 interface, initializing... 

[tse_mac_init] 

INFO : TSE MAC 0 found at address 0x04002000 

INFO : PHY Micrel KSZ9021GQ found at PHY address 0x1f of MAC Group[0] 

INFO : PHY[0.0] - Automatically mapped to tse_mac_device[0] 

INFO : PHY[0.0] - Restart Auto-Negotiation, checking PHY link... 

INFO : PHY[0.0] - Auto-Negotiation PASSED 

INFO : PHY[0.0] - Checking link... 

INFO : PHY[0.0] - Link established 

INFO : PHY[0.0] - Speed = 100, Duplex = Full 

TSEMAC SW reset bit never cleared! 

OK, x=10002, CMD_CONFIG=0x00002000 

 

MAC post-initialization: CMD_CONFIG=0x04000200 

[tse_sgdma_read_init] RX descriptor chain desc (1 depth) created 

mctest init called 

IP address of et1 : 192.168.3.250 

Created "Inet main" task (Prio: 2) 

Created "clock tick" task (Prio: 3) 

Created "web server" task (Prio: 4) 

 

Web Server starting up
Reply