FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5276 Discussions

how to: make de1soc_lxde_1604 headless/fpga independent?

Altera_Forum
Honored Contributor II
863 Views

Good day. 

 

I am trying to get acquainted with DE1-SoC. What i want to get is headless ubuntu with ability to program fpga. Also for convenience purposes i'd like to use fpga-independent kernel not to change MSEL setup for "boot" and "runtime". 

 

In this thread, i'd like to ask for help with kernel compilation. 

 

Unfortunately, i have little experience with kernel. So i decided to start with de1soc_lxde_1604 image. 

 

I tried quick and dirty approach: set MSEL to HPS (b'01010) and try to boot the board, which failed: u-boot tried to upload .rbf to fpga (with failure message), then booted kernel: 

 

Hit any key to stop autoboot: 0 reading u-boot.scr 200 bytes read in 5 ms (39.1 KiB/s)# # Executing script at 02000000 reading soc_system.rbf 7007184 bytes read in 709 ms (9.4 MiB/s) altera_load: Failed with error code -4# # Starting application at 0x3FF795A4 ...# # Application terminated, rc = 0x0 reading zImage 5538512 bytes read in 563 ms (9.4 MiB/s) reading socfpga.dtb 31245 bytes read in 9 ms (3.3 MiB/s)# # Flattened Device Tree blob at 00000100 Booting using the fdt blob at 0x00000100 reserving fdt memory region: addr=0 size=1000 Loading Device Tree to 03ff5000, end 03fffa0c ... OK Starting kernel ...  

 

and then silence. i assume, that kernel is waiting for (at least) video device in fpga to respond which will never happen. 

 

I suppose, that my next step is recompile kernel without any fpga devices. Here is kernel config from de1soc_lxde_1604 image: 

 

https://drive.google.com/file/d/0bzcyt6ufmahraxzsm0doskzvb0vpmg9hmu1tm0hjr3hzcku4/view 

 

what should i disable to make kernel fpga-independent?:)
0 Kudos
0 Replies
Reply