Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ukuma8
Beginner
424 Views

no nios ii target connection.

eclipse is not detecting any target connection and i downloaded .sof file in FPGA. i pressed several times refersh connections but it is not detecting. in my design niosii,clk with 24mhz,on chip mem,jtag uart and pio.iam using quartus ii 13.1 ver in windows 8,cyclone iii fpga and USB blaster ii. please help..

0 Kudos
15 Replies
AnandRaj_S_Intel
Employee
134 Views

 Hi Uday,

 

Refresh connections after selecting the checkbox "Ignore mismatched system ID" and "Ignore mismatched system timestamp.

 

under Run->run configuration->Nios ii harware->new_configuration->target connection tab-> and select Ignore mismatched system ID" and "Ignore mismatched system timestamp.

 

Regards

Anan

ukuma8
Beginner
134 Views

Hi anand,

 

thanku for ur reply.

 

i had tried by ignoring the mismatched system id and timestap still not detecting any target connection.please help...

AnandRaj_S_Intel
Employee
134 Views

Hi,

 

Maybe .sof file not loaded or tool, before concluding

Can you try using the example project?

 

Regards

Anand

ukuma8
Beginner
134 Views

thanku for u reply.

 

 

yes we followed example project and .sof file was loaded. I verified this by writing vhdl code (GPIO toggle with input clk 24mhz) in portmap file(top level entity) and compiled and loaded .sof file in FPGA it shows 100%. please help..

AnandRaj_S_Intel
Employee
134 Views

​Try using different Quartus version.

 

Have you used example project???

ukuma8
Beginner
134 Views

please tell me quartus versions which supports cyclone iii family

AnandRaj_S_Intel
Employee
134 Views

Cyclone iii family is supported from Quartus 10 till Quartus 13.1.

​Please check below link

https://www.intel.com/content/www/us/en/programmable/downloads/download-center.html

ukuma8
Beginner
134 Views

thanku for ur reply.

 

i followed tutorials (introduction to qsys,my first nios tutorial etc.) Can u give any sample example project for cyclone iii which supports quartus 13.1?

please help..

AnandRaj_S_Intel
Employee
134 Views

ukuma8
Beginner
134 Views

custom board

AnandRaj_S_Intel
Employee
134 Views

​Okay,

 

Can you confirm if your usb blaster and usb cable are working fine with help of some other board??

 

If USB blaster are working fine. than problem is related to the power.

 

Check VCCINT, VCCIO, and VCCA pins if it is meeting it's POR requirements.

Also check the pull up / pull down resistors on configuration sides. 

 

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/cyc3/cyc3_ciii51010.pdf

 

Regards

Anand

 

 

ukuma8
Beginner
134 Views

thank u for ur reply.

 

i thought that .sof file was loaded 100% into fpga board means that USB Blaster -ii emulator works fine.

ukuma8
Beginner
134 Views

and also the USB Blater ii emulator supports our fpga cyclone iii(EP3C80U484I7)?

AnandRaj_S_Intel
Employee
134 Views

​Recreate the eclipse project with correct sopcinfo and check.

ukuma8
Beginner
134 Views

thanku for ur reply.

 

finally after doing above posibility iam going to install low ver Quartus ii (ver 12.1) with usb blaster ii emulator.

Reply