FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5230 Discussions

tPad, DE2-115: ControlPanel will not connect ....

Altera_Forum
Honored Contributor II
1,083 Views

I got my tPad dev kit today and now I'm trying to enter this new field of technology. 

 

* I'm working under Windows 7/64 Bit. 

* As other users I had problems with the USB Blaster drivers, but I managed to install them. The device is now shown in the device manager of Windows 7 

* I installed the free web Edition 11.1sp1 (32 bit) 

 

Then I startet the control panel (64 bit version) and all I got is: Please make sure that Quartus is installed ... 

 

Any idea, how to get further on. Do i have to install Windows 7/32 Bit ?
0 Kudos
4 Replies
Altera_Forum
Honored Contributor II
145 Views

Ok, I have installed a new fresh Windows 7/32 bits and its always the same - on both installations: 32bit or 64bit. 

 

-> The 32bit ControlPanel (from the DE2-115 DVD) has missing dll's. I had to copy all files of the ControlPanel to the Quartus directory to have it start at least - but even then I get the error mentioned below. 

 

-> ControlPanel always tells me: "Please make sure that Quartus is installed" 

 

-> then I tried the tpad demonstrations (by executing batch files) and most of the stuff is not working. The only demonstration, which works is tPad_Camera. 

 

All other demos are aborting - mostly with the same error: command not known: nios2-donload and nios2-terminal. These errors happened in a GCC3 Altera Nios2 Command Shell, Versin 11.1sp1, Built Thu Nov 4 .... 

 

When I start the Nios Comand Shell from the Windows menu I get a different bash (GCC4 named) and there the commands nios2-download and nios2-terminal are known.
Altera_Forum
Honored Contributor II
145 Views

I have updated to the free web Edition 11.1sp2 (32 bit) and still problems .... 

 

All demonstrations batch files are failing, when the following sequence are within the batch file: 

 

@ "%QUARTUS_ROOTDIR%\bin\cygwin\bin\bash.exe" --rcfile ".\DE2_115_SD_Card_bashrc" 

 

this leads to a shell not finding the needed tools or to be more precise. Within the executed bashrc files there is a statement like 

 

. "$QUARTUS_ROOTDIR/sopc_builder/bin/nios_bash" 

 

starting a non-full working shell. 

 

Nice hardware, but now I am working more than one day to repair the software and to find out, where the errors are.
Altera_Forum
Honored Contributor II
145 Views

Send a help request directly to Terasic. 

 

Its possible that their control panel is checking for a specific version of Quartus. 

 

Cheers, 

Dave
Altera_Forum
Honored Contributor II
145 Views

Yes, I did this - but the answer is:  

 

"We have tested on running the control panel by using different Quartus II version, and the tests all succeeded." 

 

Other solutions I've found in the Internet (after doing lots of search in this area): copy all the stuff to the bin directory of Quartus and manually copy the sof file to the board. Then the control panel indeed works as expected - this solution was also mentioned by the support.
Reply