Community
cancel
Showing results for 
Search instead for 
Did you mean: 

How to set up OpenSUSE 11.2 for Nios II Linux

How to set up OpenSUSE 11.2 for Nios II Linux



Test Hardware:

Computer: Lenovo T400

Disk: SATA

Test Software:

ACDS 9.0 SP2 (Quartus 9.0 SP2, NIOS2 EDS 9.0 SP2)

Quartus 9.0 supports Red Hat Linux 4/5, CentOS 4/5 and SUSE 10 officially.

Previous BIOS setting:

SATA: Compatibility mode

Grahpics: Discrete video card

I tried CentOS 5.3 and 5.4. But CentOS 5.3 and 5.4 both have problem in starting X Server and have poor disk performance. They both took me more than 70 minutes to extract Quartus 9.0 from DVD disk to hard disk. They both took me more than 70 minutes to install Quartus 9.0 from hard disk. So I give up CentOS 5.3 and 5.4. (It was said that X server could start successfully by replacing /etc/X11/xorg.conf with xorg.conf.backup. I did not verify it. It was said that SATA in AHCI mode has better disk performance. I did not verify it too. )

I tried Fedora 12 too. But Quartus installation script failed to find some utility, such as 'compare'. I have checked the files and they are there. I tried to execute them. Fedora reported the following problem.

   [hankfu@localhost quartus]$ /home/hankfu/quartus/quartus/compare

   bash: /home/hankfu/quartus/quartus/compare: /lib/ld-linux.so.2: bad ELF interpreter: No such file or director

It may be caused by different version of share library used by Quartus 9.0 and Fedora 12. So Fedora 12 does not support Quartus 9.0.

I tried Ubuntu and had problems too. But I forgot the detail information.

I tried SUSE Linux Enterprise 10 SP3 and run Quartus and NIOS2-IDE successfully. But I could not find valid Yum repositories to install git and other tools those are necessary to compile Linux kernel for NIOS2. So I do not use it too.

Current BIOS setting:

SATA: AHCI mode

Graphics: Discrete video card

I tried OpenSUSE 11.2 and run Quartus 9.0, NIOS2-IDE 9.0 and NIOS2 Linux development tools successfully. I allocated 35GB hard disk space to Linux system. Linux Swap partition takes 2GB. Linux system (root file system) takes 8GB. Home directory takes 25GB. I installed Quartus and NIOS2EDS in home directory. Quartus 9.0 SP2 takes about 8.5GB. IP 9.0 SP2 takes 500MB. nios2eds 9.0 SP2 takes 2.4GB. 

Quartus installation script did not set up environment variables for us. So we had to set it in '.bashrc' file manually. I add following environment variables in '.bashrc' file in my home directory. You have to replace '/home/hankfu/altera90' with your Altera directory.

###====.bashrc begin ====


QUARTUS_ROOTDIR=/home/hankfu/altera90/quartus

export QUARTUS_ROOTDIR


QUARTUS=/home/hankfu/altera90/quartus

export QUARTUS


NIOS2EDS=/home/hankfu/altera90/nios2eds

export NIOS2EDS


SOPC_KIT_NIOS2=/home/hankfu/altera90/nios2eds

export SOPC_KIT_NIOS2


NIOS2LINUX=/home/hankfu/nios2-linux

export NIOS2LINUX


PATH=$QUARTUS/bin:$QUARTUS/linux:$QUARTUS/sopc_builder/bin:$NIOS2EDS/bin:$NIOS2EDS/bin/nios2-gnutools/H-i686-pc-linux-gnu/bin:$NIOS2LINUX/toolchain-mmu/x86-linux2/bin:/usr/bin:$PATH


export PATH


###====.bashrc end ====

Then we can launch Quartus and NIOS2-IDE in command shell. Quartus scripts use 'csh'. So please make sure 'csh' could be found in your system. Please pay attention to special character if you copy files from Windows. I wasted a lot of time because of dos character created by Windows application.

Disk performance improves a lot after SATA disk works in AHCI mode. It could achieve about 18MBps in AHCI mode when copying file in hard disk. It could only achieve about 10MBps in Compatibility mode.

NIOS2 Linux development tools need git, make, gcc, ncurses-devel, bison, byacc, flex, gawk, gettext, ccache, zlib-devel, gtk2-devel, lzo-devel, pax-utils. You'd better select 'Base Development' packages,'C/C++ Development' packages,'Linux Kernel Development' packages during installation process. Then git, make, gcc, ncurses-devel, bison, flex, gawk, gettext, zlib-devel, gtk2-devel, lzo-devel are included automatically. You should add ccache manually. You can add these packages by 'Install Softare' of OpenSUSE11.2 if you do not add them during installation process. pax-utils and byacc are not included in OpenSUSE11.2 DVD disc. Please download them and use 'rpm' to install it.  


Link to download pax-utils:

http://download.opensuse.org/distrib...-44.3.i586.rpm

http://download.opensuse.org/distrib...4.3.x86_64.rpm                


Link to download byacc:

andreas/openSUSE 11.1/i586/byacc-1.9-40.1.i586.rpm ftp5.gwdg.de/pub/opensuse/repositories/home:/burn...

andreas/openSUSE 11.1/x86 64/byacc-1.9-40.1.x86 64.rpm ftp5.gwdg.de/pub/opensuse/repositories/home:/... 


Then you can follow NIOS2 Linux instruction from NiosWiki. NIOS2 Linux takes 5.9GB disk space.

OpenSUSE11.2 desktop has problem in booting from my hard disk sometimes. But OpenSUSE11.2 failsafe image works well. OpenSUSE disables telnet service too. We can use SSH to use remote OpenSUSE computer only.

SUSE Linux Enterprise 10 SP3 and OpenSUSE11.2 both include NTFS driver and add Windows partitions automatically. You can copy files between Windows and Linux partition as root user. So it is more easy to use than CentOS 5.3 and CentOS 5.4. 


Version history
Revision #:
1 of 1
Last update:
‎06-27-2019 04:52 PM
Updated by:
 
Contributors