Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20593 Discussions

Arc A770 with Milestone XProtect doesn't show videos

Hyeongjin
Beginner
1,907 Views

Hi, Guys

 

Today I bought Arc A770 GPU, and installed in my PC.

 

My main software for Arc A770 is Milestone XProtect that is a software for video surveillance.

XProtect supports quick-sync and nvdec.

 

task manager shows that decoding works well... and i can check frame rates in milestone.

but no video is showing.

Hyeongjin_0-1673853022022.png

There's supposed to be vidoes, not black screen.

 

If I plug monitor to iGPU port on motherboard, I can see videos.

If I change GPU to nvidia, I can see too.

 

Only Arc A770 GPU doesn't show.

 

I have a similar experience with nvidia gpu. it was because of driver.

can you check this?

 

I know arc gpu has great power in decoding much more than nvidia.

I'd like to use arc if I can.

 

please fix this.

 

0 Kudos
15 Replies
Andres_Intel
Employee
1,879 Views

Hello Hyeongjin,



Thank you for posting on the Intel®️ communities.  


I am sorry to hear that you are having performance issues with your Intel® Arc™ A770 Graphics (16GB), to have a better understanding please answer the following questions:



You can find the steps on the link: https://www.intel.com/content/www/us/en/support/articles/000057926/memory-and-storage.html



Regards,  


Andres P. 

Intel Customer Support Technician


0 Kudos
Hyeongjin
Beginner
1,830 Views

Hi Andres

 

nvidia GPUs I have tested are T600, T400, T1000, Geforce 3090, P2200, and etc.

all of them worked well.

 

I posted ssu results.

 

 

Best Regards,

Hyeongin

0 Kudos
Hyeongjin
Beginner
1,864 Views

Hi Andres

 

the Driver version I have tested were 101.4304 and 101.4032, the latest stable and the latest beta.

with these versions I couldn't see videos.

 

today I installed 101.3959 driver wishing luck.

and it works.

 

it's very funny.

 

if you have a chance, please check what's different between them.

0 Kudos
Hyeongjin
Beginner
1,859 Views

Dear Andres

 

I have one more question about ARC Pro.

 

like radeon pro and quadro, is there edid emulator function with Arc Pro?

 

Thanks

Hyeongjin

0 Kudos
Andres_Intel
Employee
1,838 Views

Hello Hyeongjin,



Thank you for your response.


Happy to hear that your system is working with driver 31.0.101.3959, to provide you with accurate information and check the difference between them I will investigate.



Regards,  


Andres P. 

Intel Customer Support Technician


0 Kudos
NicolaiM
Beginner
1,781 Views

Milestone System XProtect will have full support for Intel Arc cards later in 2023:

 

Supported and recommended configuration of graphics cards can be found at the article called: 

Using hardware-acceleration for video decoding in XProtect

https://supportcommunity.milestonesys.com/s/article/using-hardware-acceleration-for-video-decoding-in-XProtect?language=en_US

 

Best Regards
Nicolai

0 Kudos
Andres_Intel
Employee
1,756 Views

Hello Hyeongjin, 



Thank you for all the information a comments provided.


We still investigating this issue, please answer the following questions to continue with it:


  • Provide repro steps including how to do it without having to acquire only cameras compatible that you find in the document below:

https://www.psn-web.net/ssbu-t/Support/extsoft_Global.pdf


@NicolaiM we appreciate the information provide it has been useful for us.



Regards,  


Andres P. 

Intel Customer Support Technician


0 Kudos
Hyeongjin
Beginner
1,743 Views

Hi Andres

 

At first, I couldn't understand why you had mentioned panasonic cameras.

after reading my article, I found out.

 

panasonic cameras in my screenshots are just examples.

you don't have to get panasonic camera, any ip camera does the same.

 

the cameras I tested use H.264 codec, I haven't test H.265 codec yet.

if the ip camera you have use H.264 codec, you can see what i saw in milestone xprotect vms.

 

Thanks

Hyeongjin.

0 Kudos
Andres_Intel
Employee
1,730 Views

Hello Hyeongjin,



Thank you for the information provided, it has been really helpful. 


We will continue with the investigation, with the latest details you provided, now we have a better understanding.



Regards,  


Andres P. 

Intel Customer Support Technician


0 Kudos
Andres_Intel
Employee
1,671 Views

Hello Hyeongjin, 



We still trying to replicate the issue and we will provide you with the updates as soon as possible. Thank you for all the information provided before it has been really helpful.



Regards,  


Andres P. 

Intel Customer Support Technician


0 Kudos
Andres_Intel
Employee
1,640 Views

Hello Hyeongjin,



We have been testing video playback with different codecs and still can't see the issue, we recommend reporting it to the app developer for debugging on their side first.


We will continue trying to replicate the issue and provide you with more updates as well, once you have a response from them let us know.



Regards,  


Andres P. 

Intel Customer Support Technician


0 Kudos
Hyeongjin
Beginner
1,627 Views

Hi Andres

 

I should have told you more.

I've tested this configuration:

   - Use Arc GPU as a primary GPU

   - Install the latest Driver 4091 build

   - Use CPU Decoding for video decoding

   - RUN Milestone XProtect SmartClient 2022R3

 

enabling GPU decoding doesn't effect on video live or playback either.

even on CPU Decoding, it doesn't work.

 

I think decoding works well. it doesn't matter.

displaying video portion doesn't.

 

and 

from the beginning I reported this issue to milestone systems.

they said that even they support quick-sync, their official comment is "we don't support ARC standalone GPU officially yet, but we support quick-sync"

 

this link is a guy's article who have the very same issue that I have.

https://supportcommunity.milestonesys.com/s/question/0D53X0000BiaodaSQA/xprotect-smart-client-2022-r3-build-67-cannot-display-any-cameras-on-live-or-playback-tab-when-using-an-intel-arc-a770-gpu-kb-49923-any-beta-or-unofficial-support?language=en_US

 

0 Kudos
NicolaiM
Beginner
1,608 Views

Hi Hyeongjin

 

Can you try to downgrade the ARC driver to 31.0.1011.3959 ?

According to my tests

  • 31.0.101.4091 Effected - video does not display the smart client
  • 31.0.101.4032 Effected - video does not display the smart client
  • 31.0.101.3959 Video display in the smart client

Best Regards

Nicolai

0 Kudos
Hyeongjin
Beginner
1,607 Views

Hi Nicolai

 

I know 31.0.101.3959 solve this problem.

I've already tested and in the article I mentioned, I told the guy to try that version.

yes that is me.

 

my purpose is

   it used to be ok in 3959.

   but versions after that have problem.

   Please consider this.

 

furthermore, 3959 version was unstable to me.

if I have been leaving my pc for a long time like more than 8 hours

my screen sometimes changes into noise screen. I can't read anything while dragging windows

so I don't prefer that version.

 

wishing fixes

Hyeongjin

 

 

0 Kudos
Andres_Intel
Employee
1,550 Views

Hello Hyeongjin,



As mentioned previously we have been working to reproduce this issue, but we have been unable to replicate it.


We completely understand that you already contacted Milestone Systems and that they said that they don't support ARC standalone GPU officially yet, but we recommend contacting them to report the issue, check if the software is fully compatible with the graphics, and look for further assistance.


Now we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored.



Best regards, 


Andres P.  

Intel Customer Support Technician


0 Kudos
Reply