Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20966 Discussions

Black screen / DisplayPort No Signal bug with latest Intel DCH drivers on Iris Xe

sodaboy581
Beginner
2,647 Views

This is just a bug report, as I've already solved my issue by downgrading.

 

This bug has been confirmed with both DCH driver 30.0.101.1404 as well as DCH driver 30.0.101.1340.

 

I'm using an Intel 11th Gen NUC with an Intel i5-1135g7 processor on Windows 11.  This processor has Intel Iris Xe Graphics.  I've got it connected to an ASUS VG32AQL1A monitor through DisplayPort and running at 2560x1440 144hz with Adaptive Sync enabled.

 

Basically, what happens is on Windows startup, the display will sometimes go into black screen or NO SIGNAL.  It's not all the time, and you can simply restart the computer to roll the dice again.

 

When it comes up normally, it's fine. At least, until you either attempt to change the refresh rate or you launch a full screen game and come out of it...  then it rolls the dice again.

 

I can force a NO SIGNAL by going into Windows Display settings, after it comes up normally, and toggling back and forth between 120hz and 144hz.  It can go to NO SIGNAL on either hz.  I've seen it NO SIGNAL when I went to 120hz and I've also seen it NO SIGNAL when I went to 144hz.  So, I can force it to happen in a matter of seconds, easily under a minute.

 

Again, this only happens (so far), on the latest drivers. 30.0.101.1404 and 30.0.101.1340 confirmed.

 

When installing Windows 11, it installs a version 27.20.100.8935 (either through the installer or Windows Update, not sure which).  This version does not experience this behavior and does not have issues with switching resolutions or frame rates.  Even Adaptive Sync works fine.  It does have some bug with Launchbox playing videos with VLC, but that's another story.

 

I've also tested 27.20.100.9466 and it does not have the bug.  (Still has the Launchbox VLC bug, though.  :P)

 

Finally, I settled on 30.0.100.9955, which does not have the NO SIGNAL bug and also has the Launchbox VLC bug fixed.  Yay!  So, I'm going to stay at 30.0.100.9955 for now.

 

I hope that the graphics driver developers find this message, can reproduce the bug, and create a solution going forward.  If not, I'll have to run 30.0.100.9955 forever!  Haha.

 

When the newer versions cause a DisplayPort NO SIGNAL bug, I either have to reboot by powering off the NUC by hand, or just RDP into the NUC and restart it.

 

Funny thing about that, though.  When a NO SIGNAL occurs and I RDP into the NUC, the lock screen will suddenly appear on the NUC monitor, even though it had no signal before.  If you try to unlock the NUC when the lock screen occurs, YOU WILL IMMEDIATELY GO BACK INTO NO SIGNAL.

 

Again, this only on the latest drivers. 30.0.101.1404 and 30.0.101.1340.

 

I did not test 30.0.101.1191 or 30.0.101.1069, so can't confirm if they are bugged either, since they came after 30.0.100.9955 which is running GREAT so far.  Maybe if I get bored, I'll try those two out.

 

Anyway, thanks for reading and hope it gets solved!

 

Good luck, devs!

0 Kudos
2 Replies
Gn0ver
Beginner
2,433 Views

Just wanted to add something to this report as the issue is still ongoing.

I'm using an MSI GS76 11UH laptop with an Intel i7 11800H which has an Intel UHD Graphics Xe 32EUs on board. I have the same issues as mentioned above everytime the Intel support assistent notifies me about a new Intel Graphics driver being available. I update to the driver and then I loose connection to the (integrated) display.

 

I have even tried the latest 31.0.101.3413/31.0.101.2111 which initially appears to be working, but after a few reboots I get the no signal issues both on the Thunderbolt connected displays as well as the integrated display. Connecting to HDMI always helps me out, but that port is hardwired to the Nvidia RTX 3080 GPU.

 

Fortunately, when I revert to the WHQL supplied version by windows (30.0.101.1029), all issues seem to be resolved. The downside however is that it seems that some customers (like me) are stuck on a certain version of the intel driver and will not be able to upgrade without this issue being addressed.

Feel free to DM me, if I need to provide additional information on this matter!

Regards!

0 Kudos
Rawi
Beginner
2,188 Views

Same issue on my side - MSI GS66 with i9-12900H.
I can only use MSI-blessed Intel GPU driver which is a year old (27.01.2022) 30.0.101.1368.
Intel Driver Support assistant is offering 31.0.101.3959 (8.12.2022)
Whenever I install Generic DCH Intel driver I'm getting black screens exactly as described above - built in screen is disabled and only connecting external monitor to NVidia GPU works.
I've tried reinstalling intel and nvidia drivers using DDU with Safe mode and it is always like this.
I don't know about other laptop manufacturers but it looks like MSI laptops work only on MSI-blessed drivers that are not maintained.

0 Kudos
Reply