Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17628 Discussions

Bug: D3D11 crashes on Intel Iris Xe when drawing antialiased lines to a multisampled render target.

philipguin
Beginner
1,530 Views

Hi there,

We're getting this crash on many machines (maybe all) running Intel Iris Xe Graphics. I managed to narrow down the problem to the conditions in the title (MSAA render target + antialiased lines enabled), but there could very well be other state involved. I attached everything the sticky thread suggested (i.e. the docx and generated files), as well as a very stripped down version of our code that replicates the issue. You can just run the compiled binary to replicate the crash on affected hardware, or you can open the project in Visual Studio 2013+ to debug, change configuration, etc. Do note that you may need some .NET runtime DLLs to run the binary. More details are included in the docx.

This user on stackoverflow seems to have encountered a similar problem, among several others: https://stackoverflow.com/questions/68156508/intel-iris-xe-graphics-crashing-system-what-might-be-mo...

We tried to make things as easy as possible for you guys to replicate the issue, so a quick fix would be greatly appreciated. A large number of users with new laptops are affected by this crash, rendering much of our cabinet-rendering software unusable unless the user knows to disable the Iris Xe display adapter under Device Manager. Obviously less than ideal!

Thanks and godspeed!

Labels (1)
0 Kudos
7 Replies
AndrewG_Intel
Moderator
1,510 Views

Hello @philipguin

Thank you for posting on the Intel® communities and for the reports.


Based on the Intel® SSU report, it seems that the system here used as a reference is running graphics driver 27.20.100.9365* which seems to be the customized driver provided by DELL*. Just to make sure, have you tested with the latest generic Intel® Graphics DCH Driver version 30.0.100.9805?

Note: In case you haven't tried this driver yet, we recommend performing a Clean Installation of Intel® Graphics Drivers in Windows using the latest generic driver. In case you already tested that driver, please kindly let us know. If you handle a list of other driver versions tested, please provide us with the details.


Also, we noticed on the Intel® SSU report that the Windows® 10 Build is 19042. Have you tested on the latest build 19043?


Best regards,

Andrew G.

Intel Customer Support Technician


AndrewG_Intel
Moderator
1,490 Views

Hello philipguin

We are checking this thread and we would like to know if you were able to review our previous post and if you need further assistance. Please do not hesitate to contact us back if you have additional inquiries.


Best regards,

Andrew G.

Intel Customer Support Technician


AndrewG_Intel
Moderator
1,458 Views

Hello philipguin

We have not heard back from you so we will proceed to close this thread now. If you need any additional information, please submit a new question as this thread will no longer be monitored.


Best regards,

Andrew G.

Intel Customer Support Technician


philipguin
Beginner
1,428 Views

Sorry, I've lost access to the laptop I was testing on and was hoping to reacquire it, but have been unable to. However, asking our users to update the graphics driver hasn't changed the issue. Once I have access to the laptop, I can open another thread. If you would consider going ahead and testing this on your end, it would be greatly appreciated.

Dave-gamedebug
Employee
1,352 Views

Hi Philip,

 

Thanks for the notification.  We were able to see the issue and development is working on a solution.

They are using the sample app to verify the fix.

 

thanks

Dave

philipguin
Beginner
542 Views

Hey, were you guys able to get this fix in? If so, what build?

 

We're currently seeing another issue reminiscent of this, but working on obtaining a machine to repro. May submit separate bug report.

 

Thanks,

Philip

Esteban_Intel
Moderator
507 Views

Hi @philipguin,

 

Since the case related to this thread was closed, can you please re-post your question in a new thread so that we can track it appropriately?

 

Reply