Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20950 Discussions

Can't get refresh >30Hz at 4k with Arc A750 (but the same KVM & display do 4k60 with Iris Xe)

JasonR
Beginner
2,001 Views

Hi Intel Support!  I'm picking up from earlier this year, now that I have more time to try things out. 

From earlier, please reference:  https://community.intel.com/t5/Intel-ARC-Graphics/Can-t-get-refresh-gt-30Hz-at-4k-with-Arc-A750-but-the-same-KVM/m-p/1569045#M12060

Please find my SSU log attached.  I've updated the driver earlier this evening, but that didn't solve anything.  Any refresh rates I try beyond 30Hz do blink for a moment, but they're very unstable and mostly give black screens.  I let them timeout and return to 30Hz.

Thanks!

 

 

 

 

0 Kudos
18 Replies
RamyerM_Intel
Moderator
1,884 Views

Hello JasonR, 


Thank you for posting in the communities. Upon seeing the previous thread I can see that you have already tried several troubleshooting steps and that you already used the latest driver. As such, I will proceed in coordinating this with our team and promise to get back to you as soon as possible. 


Ramyer M.

Intel Customer Support Technician 


0 Kudos
MUC
Valued Contributor II
1,859 Views

MUC_0-1716849042457.png

 

Is that roughly correct?

 

  1. Please check whether there is a firmware update for the TV.
  2. The troubleshooting instructions from the switch manufacturer are in the appendix.
  3. How long are the cables you use? A passive HDMI 2.0 copper cable should be no longer than 25 ft (7 meters). If possible, it should be a certified so-called “Premium High Speed HDMI Cable”.
  4. To check the Extended Display Identification Data (EDID), please create a Report for Intel Graphics Drivers on the PC with the Intel Arc A750 and attach it here.

 

0 Kudos
JasonR
Beginner
1,831 Views

Yeah, that drawing is very good indeed!

I think the EDID is ok.  I'm getting options at Windows's System | Display | Advanced display to run 60 Hz, 59.94 Hz, 58 Hz (custom timing), or 50 Hz, as well as 30 Hz and slower.  The problem's that the display is unstable above 30 Hz.

The TESmart PDF is very much appreciated, but TESmart didn't put much there.  The last page of the PDF acknowledges difficulties at fast refresh rates, and sorta throws up its hands.

The HDMI cable from the KVM to the TV has to be good - I just flipped over to the Laptop.  Windows reports I'm running 58 Hz, and it looks great.

Which means...  signs point to the HDMI cable from the A750 to the KVM.  That cable's from Monoprice - it is indeed marked Premium High Speed HDMI Cable.  It's 8 feet long, give or take, and marked 34AWG.  I think it's this: https://www.monoprice.com/product?p_id=24187

I just swapped it out for a much heavier 10 foot HDMI cable - also Monoprice, also Premium High Speed HDMI Cable, but this one's 28AWG.  It also does not work - so perhaps it's not the cable after all.

 

 

 

 

 

 

0 Kudos
JasonR
Beginner
1,826 Views

(Oh - and I did just update the TV firmware.  Still can't get stable at higher refresh rates.)

0 Kudos
MUC
Valued Contributor II
1,786 Views

TESmart writes in several places:

 

"With EDID emulators in each input port, keep PCs always having correct display information, prevent display settings from changing while switching input ports."

"With EDID emulators in each input port, the accuracy of the display information of PCs will be secured"

 

The EDID transmitted to the Intel Arc A750 demands a preferred use of 4K @ 30 Hz:

 

MUC_0-1716922671792.png

 

Video timing according to the Consumer Technology Association standard (CTA-861, VIC = 1) @ 297 MHz TMDS. This is still within the bandwidth of HDMI 1.4 (9 Gbps) and is therefore stable.

 

The EDID also contains:

 

MUC_1-1716922714448.png

 

Interoperability with a TV is best when the CTA standard is followed.

I suspect that the driver is trying to send the signal using Coordinated Video Timing - Reduced Blanking (CVT-RB) version 2.

 

To see where the above data comes from, please do the following:

 

  1. Please create a Report for Intel Graphics Drivers with the laptop and attach it.
  2. Please connect the Intel Arc A750 directly to the TV and create a Report for Intel Graphics Drivers and attach it as well.

 

0 Kudos
MUC
Valued Contributor II
1,711 Views

I can establish a signal with CTA video timing on my Intel Iris Xe (31.0.101.5522) using the EDID in question with 60 Hz selected. So I understand the behavior of your laptop.

 

I have now looked at an EDID of a Vizio TV from 2019. The preferred resolution of 4K @ 30 Hz is also there. However, the 58 Hz CVT-RB v2 parameters are not. These seem to be added by the TESmart device, but unlike your laptop, they are not compatible with the signal path of your Arc A750 graphics card.

 

Please try the following:

  • Download Custom Resolution Utility (CRU) to the PC with the Arc A750
  • Run CRU.exe
  • Make sure the active EDID is that of the TV. If necessary, select from the drop down menu.
  • Delete the CVT-RB v2 entry with 58 Hz.
  • Close CRU with OK and restart the computer.

 

MUC_0-1717105214574.png

 

If that works, it is probably due to the HDMI port on the Arc A750. There are manufacturers on the market that use a PCON chip on the Printed Circuit Board for this. What brand is your graphics card?

 

0 Kudos
JasonR
Beginner
1,641 Views

Delete the CVT-RB v2 entry with 58 Hz.

I'd rather not give up that 58Hz CVT-RB v2 timing...

  1. That same timing does work when the laptop uses it
  2. That same timing does work when the Arc A750 is connected directly to the TV (I just proved this tonight while getting the EDIDs)
  3. When the Arc A750 is connected thru the KVM, it's not just 58 Hz that fails; the out-of-the-box standard 60Hz refresh rate also fails.

Why am I so attached?  That timing is a workaround for a bug in the TV firmware which broke 4:4:4 sampling.  Plus, I don't think getting rid of the mere option for 58Hz would fix the also-broken 60Hz case.

 


To see where the above data comes from, please do the following:

  1. Please create a Report for Intel Graphics Drivers with the laptop and attach it.
  2. Please connect the Intel Arc A750 directly to the TV and create a Report for Intel Graphics Drivers and attach it as well.

I've attached the Report for Intel Graphics Drivers for both the laptop and the Arc A750 direct to TV.

 


What brand is your graphics card?

It's the Intel-branded card.

 

As an aside, I thought more about the HDMI cables from your previous questions.  Even tho there should be enough bandwidth, I wonder if it's a problem with timing margins from card to KVM or KVM to TV (the second one's less likely given that I can get the laptop to do it thru the KVM.)

So I've got some 48Gbps cables on order from Monoprice - will share what those do.

0 Kudos
MUC
Valued Contributor II
1,602 Views

HDMI cables are often the cause of the behavior described. It is therefore always a good idea to check.

 

From the data you have attached, I can see the following differences:

 

MUC_3-1717191123964.png

 

The connection type does not necessarily mean anything. Chips on the respective circuit boards are often the cause. What is interesting, however, is that the Iris Xe video timing parameters for 58 Hz correspond to the CVT-RB version 1 standard. Since the display identification for the Arc A750 remains the same after being connected directly to the TV (M437-G0), the driver also uses the same EDID from the Windows registry as before, CVT-RB v2. I therefore agree with your conclusion that the problem is not due to the video timing.

 

If you want to check it yourself, I can recommend the following resources:

Raw EDID Decoding
Video Timings Calculator

 

To "clean up" you can run the following from the CRU download:

MUC_2-1717190852799.png

This will delete all display EDIDs from the Windows registry. On reboot the connected devices will be recreated.

 

If the display device can handle it, the idea of ​​using CVT-RB for transmission is basically correct in a difficult cable situation (old, long, laid in the wall and therefore subject to interference), as the required bandwidth will drop.

4K @ 60 Hz 4:4:4 CTA-861 = 18 Gbps (594 MHz, HDMI 2.0 MAX)
4K @ 60 Hz 4:4:4 CVT-RB v1 = 16.16 Gbps (533.28 MHz)
4K @ 60 Hz 4:4:4 CVT-RB v2 = 15.84 Gbps (522.62 MHz)


The reason the CTA video timing seems a bit wasteful is that during the blanking periods audio is transmitted, which can be quite demanding in consumer electronics over HDMI, e.g. Dolby Metadata-enhanced Audio Transmission (MAT). If you don't need audio, there's nothing wrong with using CVT-RB if the TV can handle it.

0 Kudos
JasonR
Beginner
1,465 Views

Thanks!  I need to digest what you've shared a little better.  But in the meantime, I did replace both HDMI cables (Arc to KVM, KVM to TV) with shiny new 10-foot 48Gbps cables... and it didn't help a bit.

0 Kudos
RamyerM_Intel
Moderator
1,288 Views

Hello JasonR, 


Thank you for being active in this thread. I noticed you are engaging with MUC as well. I am just checking in, how is your display performance so far?


Ramyer M. 

Intel Customer Support Technician


0 Kudos
JasonR
Beginner
1,273 Views
Hi Ramyer! Thanks for asking!

Alas, so far nothing is resolved. Even with nice new 48Gbps HDMI cables, I can’t get 4k60 from the Arc thru the KVM to the TV, but I can get 4k60 from the Xe laptop thru the KVM to the TV.
0 Kudos
RamyerM_Intel
Moderator
1,236 Views

Hello JasonR, 


I'm sorry to hear about that. As that is the case, let me coordinate this with our team and I promise to get back to you as soon as possible. 


Ramyer M. 

Intel Customer Support Technician


0 Kudos
RamyerM_Intel
Moderator
955 Views

Hello JasonR, 


After consulting with our team, I would like to inform you that there seems to be a potential compatibility issue with your current setup. As a further troubleshooting step, we suggest connecting the Arc graphics card directly to the television to determine if any issues occur when adjusting the refresh rate.


Additionally, checking this article for reference could prove beneficial to your concern  Display Goes Black When the Intel® Arc™ A750 Graphics Are Connected to a KVM Switch through DisplayPort.


Should you have further questions, feel free to let us know.


Ramyer M.

Intel Customer Support Technician


0 Kudos
JasonR
Beginner
749 Views

Hi Ramyer!

"potential compatibility issue" appears to be correct, but not a terribly satisfying answer:

  • A750 to TV works at 4k60
  • Xe laptop to KVM to TV works at 4k60
  • A750 to KVM to TV does not work (4k60 is offered as an option, but blinks in and out of black screen)

All the parts of the system work, but the whole does not?

And I appreciate the reference, but it doesn't seem to say anything besides "yeah, sometimes stuff doesn't work"

 

0 Kudos
RamyerM_Intel
Moderator
830 Views

Hello JasonR, 


I am just checking in if you have further questions. Feel free to let me know. I will be waiting for your reply. 


Ramyer M.

Intel Customer Support Technician


0 Kudos
RamyerM_Intel
Moderator
532 Views

Hello JasonR, 


I apologize if my initial post does not satisfy your inquiry. I have coordinate this case with our team and we want to let you know that based on testing results this is likely a compatibility issue, however we cannot guarantee functionality with every single adapters, converter or KVM available in the market. As that is the case, we want to ask, have you tried connecting only the Intel A750 at 4k@60hz to the KVM to see if it produces the same issue?  Additionally, testing with a different KVM will bring us closer to confirming the initial conclusion.


I will be waiting for your reply. 


Ramyer M.

Intel Customer Support Technician



0 Kudos
RamyerM_Intel
Moderator
351 Views

Hello JasonR, 


I am just looking for an update regarding the information we requested. Kindly please let me know about this information so we can identify the next steps that needs to be taken to solve this issue. 


Ramyer M. 

Intel Customer Support Technician


0 Kudos
AlfredoS_Intel
Moderator
251 Views

Hi Jasonr, 


We need to close this thread since we have not gotten a response from you: maybe because you are busy or preoccupied at the moment. We know that this is important for you to get it resolved and it is also equally important for us to give you the right solution; as much as we would like to assist you, we need to close it to attend to other customers. 


We hope for your consideration and understanding on this one.


If you need any additional information, please submit a new question as this thread will no longer being monitored.


Thank you for contacting Intel® and have a great week!



Best Regards,

Alfred S

Intel Customer Support Technician


0 Kudos
Reply