Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20864 Discussions

Command Center shows resolution supported but can't select

Andrew-UK
Beginner
1,558 Views

Update: I have discovered the lower resolution problem only happens when my secondary monitor (Benq GL2450) is turned on. If I turn this monitor off my 4K Philips monitor resolution jumps up to the desired 3840x2160. BUT, both monitors work at the same time at the max resolution on the SSD with the old windows image on it, so this is not a fix, but another data point. The Benq uses 1920x1080 Max resolution. It is normally connected to the Lenovo dock via HDMI but I tried DVI-to-DisplayPort as a test and the problem still exists.

 

Setup

  • Lenovo T14 Laptop
    • Windows 10
  • Lenovo Thunderbolt Dock
  • Philips BDM4037U 40" 4K Monitor
  • DisplayPort 1.2 Monitor-to-Dock
  • USB-C Dock-to-Laptop

Command Center shows this monitor supports 3840x2160.

AndrewUK_0-1649883998902.jpeg

But Command Center won't let me go higher than 1920x1080

AndrewUK_1-1649884042650.png

Neither will Windows

AndrewUK_2-1649884076422.png

I have tried Intel UHD driver 30.0.101.1122 & 30.0.101.1660. I have tried the official Philips monitor driver and the Generic PNP Monitor driver in Windows.

This is Windows 10 Enterprise 21H1 19043.1645.

If I swap this SSD out for another one running Win 10 LTSM 1809 with UHD driver 30.0.101.1122 and Generic PNP Monitor driver 10.0.17763.771 then Windows lets me select the 3840x2160 resolution without needing to use Command Center.

0 Kudos
1 Reply
Reply