Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ETad
Beginner
1,179 Views

Display Scaling problems in Intel HD Graphics Control Panel

Hello.

Recently, I've bought a new ASUS TP500L Laptop, which comes with Intel(R) HD Graphics Family. It is running Windows 8.1 64-bit.

I found that in all videogames including Team Fortress 2 and Need For Speed Undercover, as long as the in-game resolution is not set to 1366*768, there are black borders around the edge of the screen.

I've attempted to solve this problem by right clicking on desktop, to bring me to Intel(R) HD Graphics Control Panel. but under Scaling in Display Options, I do not have any other choice other than "Maintain Display Scaling", which cannot be un-checked, as shown in the screenshot below.

Is there anyway I can stretch my display to fullscreen when using non native resolutions?

Here is an attached DxDiag.txt from my laptop.

Tags (1)
0 Kudos
2 Replies
Allan_J_Intel1
Employee
119 Views

Thanks for joining the Graphics community.

Scaling options issues have been under investigation through our engineering department.

Please check the following thread for some assistance:

Allan.

JEFFREY_F_Intel
Employee
119 Views

Please checkout newest driver posted for Haswell/Broadwell product generations (Intel HD Graphics 4200/4400/4600/5000 + Iris 5100 and Iris Pro 5200 + Intel HD Graphics 5300, 5500, 6000, Iris 6100, Iris Pro 6200):

/message/310103# 310103 - NEW- Intel® Iris™, Iris™ Pro, and HD Graphics Driver update posted for Haswell and Broadwell version 15.36.21.4222

You can set your preferred scaling option for desktop modes here - now the scaling preference is independent of current resolution and is "sticky" (retained when resolution change occurs). In addition, you can try checking the box selecting "Override Application Scaling" checkbox to force scaling of games to match your preferred scaling option (e.g. either full screen or maintain aspect ratio depending on your preference)

Reply