Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17794 Discussions

Feature level 12_0 randomly missing from my DirectX 12!

liptonice95
Beginner
508 Views

Have a very strange issue. I was able to play Assassin's Creed Valhalla without any issue for years until I uninstalled it. The game has a directx feature level requirement of 12_0. However, when i recently reinstalled and tried to run the game, it gave me the error message "GPU does not support DX12". 

All my drivers and windows updates are up to date. When i ran a dxdiag check, it gave me a Direct3D error message "DxDiag has detected that there might have been a problem accessing Direct3D the last time this program was used. Would you like to bypass Direct3D this time?" 

I rmb pressing "Yes", after which the diagnostic notes simply showed "no problems found", but the feature level 12_0 is now missing.  

I'm using an Intel® Core™ i5-4690K CPU @ 3.50GHz, and NVIDIA GeForce RTX 2060. Really appreciate any help!

 

Labels (1)
0 Kudos
1 Reply
Alberto_R_Intel
Moderator
480 Views

liptonice95, Thank you for posting in the Intel® Communities Support.


Just to let you know, the Intel® Core™ i5-4690K processor is under the status of Discontinued / End Of Interactive Support, as you can confirm in the following link:

https://ark.intel.com/content/www/us/en/ark/products/80811/intel-core-i5-4690k-processor-6m-cache-up...


So, even though Intel® technical support will no longer be provided for this kind of products, still, as an option you may want to try our Discontinued Products Community to get recommendations from fellow community members:

https://community.intel.com/t5/tag/Discontinued%20Products/tg-p/tag-id/919?profile.language=en


Or you may also find the Discontinued Products Website helpful to address your request:

https://www.intel.com/content/www/us/en/support/discontinued-products.html


Regards,

Albert R.


Intel Customer Support Technician


Reply