Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
244 Views

Fps locked to 60 in fullscreen but unlocked in windowed mode

Jump to solution

I've played Valorant with all settings turned off and the FPS always locks to 60 when I'm playing in fullscreen, but unlocked in window mode (which still feels like 60 because Windows also renders in the background).

I've also tried tinkering with the Intel HD Graphics settings but no hits so far. I really want to play in full performance and it is only achievable in fullscreen.

Also other things that I noticed is this only occures in DirectX/D3D based games. I tried to play Stepmania 5 in fulscreen with OpenGL rendering mode and the FPS hovers around 300-600fps. So this should be a rendering issue.

All my system informations needed already attached. The TL:DR version is I'm using Dell Latitude E7270 with external monitor attached. I was intended to play only using only that external monitor.

Best regards,

Jarvis

0 Kudos

Accepted Solutions
Highlighted
Novice
149 Views

Hello, Maria R.,

I've found a workaround for this issue.

  1.  Find the .exe file of any game that has this issue. Make sure it's the .exe that actually runs on the process when the game starts. Not the launcher, etc. If you're not sure about this, check at the Task Manager when the game is running and find the game .exe from there by going to Task Manager > 'Details' tab > Right click on the .exe that runs on the game > Click 'Properties'
  2. Click 'Compatibility' tab.
  3. Under 'Settings' section, check the box that says 'Disable fullscreen optimization'.
  4. Click 'OK' to save changes.

Please do note that this is a workaround. I will mark this answer as accepted until there is a driver update or an official fix for this issue.

Best regards,

Jarvis

View solution in original post

0 Kudos
10 Replies
Highlighted
Moderator
223 Views

Hello bdp_,


Thank you for posting on the Intel* Community.


We would like to try to replicate this behavior in our labs. Please provide the below infromation:


  • Can you please provide screenshots or a video of the issue and more detailed steps to reproduce it (resolution used, versions,etc)?
  • Are you using straight connection HDMI* to HDMI*?
  • Just to confirm is the issue only on the external display?
  • Also, please provide the tool you're using to monitor the FPS on both games.
  • Provide us with the settings you are using on the games. (screenshots)


This is just to have more clear steps and avoid any misunderstanding.


Best regards, 

Maria R.  

Intel Customer Support Technician 


0 Kudos
Highlighted
Novice
211 Views

Hello Maria R.

Regarding to your questions:

1. This issue did not happened before I do a DirectX update that I did using the Web installer directly from Microsoft (which I downloaded from here. ). I did the update because Stepmania 5 (specifically, the StepP1 mod which you can download here) won't run. After the update, all DirectX-based games are locked to 60 fps.

2. Yes, I do use direct HDMI to HDMI connection

3. and No, this issue also happens with the built-in display.

4 and 5. I tried 3 games: Valorant, Stepmania 5 (StepP1), and Osu. All games updated to the latest version. For FPS monitoring, I only used what the game provides.

Here are the settings:

a. Valorant: All settings turned to the lowest possible,  including resolution (which the lowest possible resolution is 1024x768). Make sure the display mode is fullscreen. fps locked to 60 when fullscreenfps locked to 60 when fullscreensettings-1settings-1settings-2settings-2

b. Stepmania 5 (StepP1) Here are all the settings:

2020-09-17_195333.jpg2020-09-17_195338.jpg2020-09-17_195346.jpg2020-09-17_195350.jpg2020-09-17_195444.jpg

Notice on the first 4 screenshots, the FPS managed to hover around 200, but the renderer is OpenGL. When switch the renderer to DirectX and restarted the game, the FPS locks to 60. The stats also shows what renderer that I used.

 

3. Osu

I tried two different settings in Osu: the first setting I tried is to switch the frame limiter to Unlimited (gameplay). The expected behavior is I will get uncapped frame rate during gameplay. But in practice, I got locked to the refresh rate of my monitor. (I played on 1080p fullscreen)

screenshot001.jpgscreenshot004.jpg

 

The next settings in switching the frame limiter to Optimal. With this setting, I managed to capped it all the way up to 480FPS. Since the setting is labeled inside 'renderer', I assume that the game knows which renderer runs the best in the system with this setting, and goes with the better one; which may confirmed my assumption that I made with StepP1.

screenshot002.jpgscreenshot003.jpg

 

If there is any other info that I have to obtain, please let me know. But overall, I think I provided enough information to do the bug reproduction. You can also try different games that uses DirectX as well, it will yield the same result.

Best regards,

 

Jarvis

Tags (1)
0 Kudos
Highlighted
Moderator
198 Views

Hello bdp_,


The information you provided was amazing! Thank you.


I will look into this and post back on this thread as soon as I have more information to share.


Best regards,

Maria R. 

Intel Customer Support Technician



0 Kudos
Highlighted
Moderator
188 Views

Hello bdp_,

 

Please try the below steps:

 

Try to modify Vsync using the Intel Graphics Command Center:

 

  1. Scan for the games or manually add them to the Library.
  2. Select under 'Custom Settings Optimizations' the 'Vertical Sync' and changed it to 'Always off'
  3. Test the games.

 

Please, let me know the outcome.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 

 

 

0 Kudos
Highlighted
Novice
155 Views

Hello Maria R.,

I've tried turning off Vsync from IGCC, no changes.

Best regards, 

Jarvis

0 Kudos
Highlighted
Novice
150 Views

Hello, Maria R.,

I've found a workaround for this issue.

  1.  Find the .exe file of any game that has this issue. Make sure it's the .exe that actually runs on the process when the game starts. Not the launcher, etc. If you're not sure about this, check at the Task Manager when the game is running and find the game .exe from there by going to Task Manager > 'Details' tab > Right click on the .exe that runs on the game > Click 'Properties'
  2. Click 'Compatibility' tab.
  3. Under 'Settings' section, check the box that says 'Disable fullscreen optimization'.
  4. Click 'OK' to save changes.

Please do note that this is a workaround. I will mark this answer as accepted until there is a driver update or an official fix for this issue.

Best regards,

Jarvis

View solution in original post

0 Kudos
Highlighted
Moderator
107 Views

Hello bdp_,


Thank you for taking the time to share this fix, and hopefully, it may help other community members experiencing similar behavior.


In the meantime, I'll try to work on this with the new steps you provided.


Best regards,

Maria R.

Intel Customer Support Technician



0 Kudos
Highlighted
Moderator
94 Views

Hello bdp_,

 

Thank you for patiently waiting.

 

We were unable to replicate your issue in our labs. We tried with all settings turned to the lowest possible, resolution tested both highest: 2560 x1440 and Lowest: 1024x768 at Fullscreen. We tried several settings and we were able to play at more than 60fps.

 

We have to say that we updated everything in our system. We used the latest graphics driver available and the latest Windows* build.

 

According to the reports you're using the latest driver from Dell*, version 26.20.100.8142. But, you are using the Windows 10 version 1903 (build 18362) and the latest version available is the version 2004 (build 19041), we think that the issue might be with your operating system. So the next step we will recommend is to complete the Windows* updates. For further instructions on this, please contact Microsoft*.

 

If the issue persists, please attach a new DxDiag report with the most updated Windows* version.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 

 

0 Kudos
Highlighted
Moderator
67 Views

Hello bdp_,


Were you able to check the previous post? 


Let me know if you need more assistance. 


Best regards, 

Maria R.  

Intel Customer Support Technician 


0 Kudos
Highlighted
Moderator
49 Views

Hello bdp_,


We have not heard back from you, so we will close this thread.


Please keep in mind that we have seen some users reporting the same behavior and was solved using the latest Windows* version, this may be a compatibility issue with the Windows* build you're using. We highly recommend addressing this issue to the game developer since it is not related to Intel* graphics drivers.


We also want to thank you for sharing your workaround that can be useful for other community members.


If you need any additional information, please submit a new question as this thread will no longer being monitored.


Best regards, 

Maria R.  

Intel Customer Support Technician 


0 Kudos