Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
18272 Discussions

GPU Clock Stuck discrete nvidia + intel igpu

tbkizle
Beginner
512 Views

Hello, so as the title says I am using a nvidia gtx 760 as my display and in bios I have multi gpu enabled. I have used this setup in the past on an older system and do now on this newer system so I can have the encoding power of the igpu since my 760 is old and doesn't support newer video formats. Also since my 760 is old now it also won't allow me to play dx12 games, so recently I have noticed I tried to launch a dx12 game using the UHD 770 in my core i5-12600k, however the gpu clock does NOT go above 300MHz despite the GPU Load being pegged at 100%(understandably since 300MHz is not fast at all). Task manager says I am using driver 31.0.101.3413 w/driver date of 8/19/2022. This is latest driver from https://www.intel.com/content/www/us/en/download/19344/intel-graphics-windows-dch-drivers.html as of when I am making this post. I was using drivers supplied by MSI as I am using a MSI PRO-Z690-A-DDR4 motherboard but windows update keeps "updating" with a different version one something like 30.0.101.13xx I don't remember the exact version atm.

Labels (2)
0 Kudos
5 Replies
Duxy
Novice
486 Views

To prevent the windows updating to older drivers check out this link found in another post on this forum.

"Show or hide updates" utility Fixing Automatic Installation of a Problematic Update in Windows 10 V...

I have windows pro and can disable windows driver updating with a group policy setting. That is another way to avoid driver reverting.

 

Also try driver 30.0.1.1994.

I have also problems with igpu clock with newer drivers on MSI motherboard, only mine gets stuck at max clock 1300MHz.

This does not happen with the 30.0.1.1994 driver.

 

link to the driver: Intel® Graphics – Windows* DCH Drivers

 

Greetings,

Duxy.

tbkizle
Beginner
457 Views

I am currently trying disabling driver update with system properties > device installation settings > No. And that seems to be working though wont install other device drivers. I might change to how you suggested, but for now I don't want to have to keep going through this process of uninstalling and reinstalling drivers and restarting, thank you!

 

Also for me I am not sure what exactly fixed it but after changing that setting I installed 30.0.101.1404 from MSI and disabled screensaver and display turn off in power settings(thought it might be a power management issue with the display turning off/sleep) and it seems to be working fine. I think I have tried this driver from MSI before and with screensaver & display turn off in power settings it had the issue I need to reverify though.

 

I might try 30.0.1.1994 after as well thanks!

tbkizle
Beginner
373 Views

so far I have only been able to test that:

30.0.101.1404 from MSI: Works

31.0.101.3302 from Windows update (but oddly can't find in windows update catalog): Works

(ref https://www.catalog.update.microsoft.com/Search.aspx?q=UHD%20Graphics%20770

https://www.catalog.update.microsoft.com/Search.aspx?q=31.0.101.3302)

31.0.101.3413 from Intel (as mentioned before does not work)

 

Assuming the one from windows update is generic from Intel(despite this version not being listed https://www.intel.com/content/www/us/en/download/19344/intel-graphics-windows-dch-drivers.html or in...) It would be safe to assume something between 31.0.101.3302 and 31.0.101.3413 in the generic Intel driver is causing this issue. Wish I could narrow it down more.

 

 

tbkizle
Beginner
358 Views

ok I thought 31.0.101.3302 was working but it bugged today. It seemed to work for the longest time today I did update my realtec audio drivers and I have not restarted yet, I wonder if it is related.

tbkizle
Beginner
348 Views

I ran IPDT64 - Revision: 4.1.7.39 and it passed.

 

Driver 31.0.101.3430 does not work.

With this driver I have attached a IETU log(while using 31.0.101.3430) while playing a 4k video in chrome with windows set to use the igpu for chrome the gpu usage varies up to 71% according to gpuz and from what I can tell in windows task manager. Also in task manager the "video decode 1" averages ~40% while youtube player reports ~10% dropped frames. (not only when video first is loading but throughout)

 

With working driver from msi 30.0.101.1404. I can play 8k youtube video(not just 4k) with only 11 dropped frames out of 5837.

 

I just uninstalled and installed 30.0.101.1404 and then tested the 8k video, then about 15 min later windows installed 31.0.101.3616(date of 9/2/2022) which also doesn't seem to be listed https://www.intel.com/content/www/us/en/download/19344/intel-graphics-windows-dch-drivers.html or windows update catalog. This whole OEMs have their versions and their number might not match with intel generic driver versions and windows update versions either, kind of a bit of a mess intel....

Reply