Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20942 Discussions

I can't use exclusive full screen when play roblox with vulkan in uhd770

fang1
Beginner
3,176 Views

when i press F11 or Alt+enter when use vulkan,  roblox just run at Chromeless Window。but i can use exclusive full screen when use d3D11or10.

i use i5-12500 uhd770 31.0.101.4669 win10 

0 Kudos
9 Replies
IsaacQ_Intel
Employee
3,162 Views

Hello @fang1

 

Thank you for posting on the Intel️® communities. We would be more than glad to help you with your issue.

 

In order to have a better understanding of your issue, please provide me with the following:

 

1.      Have you contacted Roblox for support?

2.      Does this issue happen on another Graphics driver or and external GPU?

3.      Could you explain the "Chrome less Window" mode in more detail? How does it differ from regular fullscreen or windowed modes?

4.      Have you observed any differences in how Roblox behaves when switching display modes between Vulkan and DirectX 11/10?

5.      Have you experimented with adjusting in-game graphics settings related to fullscreen mode, resolution, or display settings? Did any changes have an impact on the issue?

6.      Have you tried switching between different graphics APIs in the game settings? If so, did you notice any change in how fullscreen is handled?

7.      Provide screenshots of the issue, and please download and scan your system using our tool, Intel® System Support Utility so we can help check your system info first. Once finished downloading, open the tool, click on scan 'Everything', click next, then save the system information to a .txt file. Please provide the .txt file.

This document will be necessary to check your entire system, in order to find possible errors or incompatibilities.


 

Best regards,

Isaac Q. 

Intel Customer Support Technician


0 Kudos
fang1
Beginner
3,137 Views

1. I contacted Roblox for support.Not solved

2. This issue happen on All versions of the driver for uhd770. It also happen in  win10. This issue won't happen in 

NVIDIA 2060 GPU and amd Gpu(6600xt)
3。Chrome less Window=FramelessWindow,The game  you’re running will look like it’s running in fullscreen mode since it’s covering your entire screen, but it’s actually a borderless window. When you’re running a game or app in fullscreen mode, it covers the entirety of your display. The whole focus is on the game, image, or program. You won’t be distracted by other apps or by the taskbar.Fullscreen mode is usually the default display mode for most games that you play on your PC, Mac, Android, or iOS device. However, switching between tasks isn’t as quick and smooth since the computer prioritizes whatever is in fullscreen mode.
4.roblox have to roboot to switching display modes between Vulkan and DirectX 11/10.
           when i use Direct3D 11/10. press alt+enter will enter fullscreen mode
           when i use vulkan or openGL .press alt+enter will enter FramelessWindow.
5. i tryied to change ingame graphics settings. Nothing changs. the issue still exists
6.when i use Direct3D 11/10. press alt+enter will enter fullscreen mode
   when i use vulkan or openGL .press alt+enter will enter FramelessWindow.
7. i think i discribe the issue clearly so There's no need to  Provide screenshots.Also it will be difficult to discribe issue by screenshots.
 8. i will sent system information  as .txt
0 Kudos
IsaacQ_Intel
Employee
3,116 Views

Hello @fang1

 

Thank you for your reply.

 

Thank you for sharing all the information. We'll use this to conduct further research and provide you with the right solution or helpful information.


While testing on my laptop with Iris Xe Graphics, I tried Shift + F11 and it entered fullscreen mode. We'll continue to investigate to see if we can assist you. Could you please provide a screenshot as well? This will give us a clearer understanding of the issue alongside your description.

 

We will contact you back as soon as we have more details.


 

Best regards,

Isaac Q. 

Intel Customer Support Technician


0 Kudos
fang1
Beginner
3,093 Views

shift+F11 does't work .actually it just entered FramelessWindow

I think FramelessWindow and fullscreen doesn't look different in screenshots 。But  fullscreen will have better performance。

  I can‘t use other gpu enter FramelessWindow with vulkan。No matter i press F11 or Alt+Enter ,it entered fullscreen

  I can‘t use uhd770 enter fullscreen with vulkan.No matter i press F11 or Alt+Enter ,it entered FramelessWindow

I think maybe i can provide video to discribe the issue。But the video is allways bigger than 71mb. And it has exceeded this limit.

0 Kudos
IsaacQ_Intel
Employee
3,107 Views

Hello @fang1

 

Thank you for your patience.

 

Our team is currently working on replicating the issue in the lab. This process may take some time, so we appreciate your patience. Once we have the results, we will promptly get in touch with you.

 

Best regards,

Isaac Q. 

Intel Customer Support Technician


0 Kudos
IsaacQ_Intel
Employee
3,071 Views

Hello @fang1

 

Thank you for your reply.

 

If I understood well, the issue is only with Vulcan when using UHD graphics, otherwise, you got Fullscreen mode. That means that when you use an external GPU and Vulkan you get Fullscreen?


Could you kindly provide us with the details of your process for switching the API? This information will assist us in attempting to replicate the issue accurately.


Certainly, your input is crucial for us to effectively replicate the problem. Additionally, if you could supply a concise video demonstrating the issue, it would greatly enhance our comprehension of the situation. Your cooperation is greatly appreciated.

 

Best regards,

Isaac Q. 

Intel Customer Support Technician


0 Kudos
fang1
Beginner
3,052 Views

i think i may know why issue will happen to my uhd770.

If you see nvidia Control Panel setting,there is a Vulkan/OpenGL present method.

   if i use Prefer native, the issue won't happen to nvidia GPU

   if i use Prefer layered on DXGI Swapchain ,the same issue will happen to my nvidia GPU

can you tell me how can i use "Prefer native" instead of “Prefer layered on DXGI Swapchain” in my intel uhd graphics 770?

 

0 Kudos
IsaacQ_Intel
Employee
3,045 Views

Hello @fang1

 

Thank you for your reply.

 

Understood, the issue on Nvidia only occurs when using the use Prefer layered.


Not sure how to choose “Prefer native” instead of “Prefer layered on DXGI Swapchain”, as you said this is a feature of the Nvidia Control panel., We will investigate further to see if we can understand how to help you with that. Have you tried Arc control? Is our Graphics control panel, maybe you can change that option there.


Also, as we said before, could you kindly provide us with the details of your process for switching the API? This information will assist us in attempting to replicate the issue accurately.


And, if you could supply a concise video demonstrating the issue, it would greatly enhance our comprehension of the situation. Your cooperation is greatly appreciated.


As we said, we are performing the lab to try to replicate the issue, but since we don’t have all the information we haven’t finished, please provide us with that.

 

Best regards,

Isaac Q. 

Intel Customer Support Technician


0 Kudos
IsaacQ_Intel
Employee
3,019 Views

Hello @fang1

 

We appreciate your patience.


After carefully analyzing the lab results, we have the following findings:


Regrettably, we were unable to reproduce the reported issue despite exhaustive testing with both Vulkan and Direct X 10/11 APIs. Full-screen mode worked without any problems.


Given this situation, our best suggestion is to contact the original equipment manufacturer (OEM), specifically the Roblox developer, for further assistance in resolving this issue.


This discussion thread will now be closed, and please note that it will no longer be actively monitored by Intel. Thank you for your understanding.

 

Best regards,

Isaac Q. 

Intel Customer Support Technician


0 Kudos
Reply