Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
18291 Discussions

I7-12700H graphics brightness not working on Legion 5i

Hammer_0101
Beginner
250 Views
I've a Legion 5i gen 7 ( i7-12700H with rtx3060 ) laptop. I'm facing some brightness issue on my laptop. When I use igpu-only or igpu-Habrid mode ( only integrated gpu ) the brightness is not working. It is working on hybrid or dgpu mode. This happens when I switch to igpu mode. I think there might be bug/issue on iris xe display driver. Is there anyone facing same issue? How to fix it?
0 Kudos
8 Replies
Jean_Intel
Moderator
217 Views

Hello Hammer_0101,

 

Thank you for posting on the Intel️® communities. I am sorry to hear that you are experiencing issues

 

In order to have a better understanding of your issue, please provide me with the following:


  • When did the issue start?
  • Does the issue occur when using an external monitor?
  • Is  Display Power Saving enabled on your system?
  • Have you disabled auto brightness?

 

Based on your issue, I would recommend performing a clean installation of the graphics driver. Corrupted files from previous installations of drivers can linger on a system which can cause driver updates to not work as expected. I want to recommend you test our generic driver 31.0.101.3790. Installing this Intel generic graphics driver will overwrite any customized driver from your Computer Manufacturer. Intel’s generic graphics drivers are intended for testing.

 

It also would be ideal if you complete all necessary Windows updates.

 

Best regards,

Jean O. 

Intel Customer Support Technician


Hammer_0101
Beginner
211 Views
Hi sir,
Thank you for your response.

This issue I noticed 2-3 days after setting up my laptop which is only in igpu-mode (only integrated gpu). It is not working on internal display not external. Actually I did not connect external display yet. Power saving mode is off.

I recently found out that when I'm in hybrid mode then brightness works perfectly fine. But when I switch to igpu mode and restart the laptop then it's stop working but if I shutdown and then boot up then it works fine also in igpu-mode. I think problem occurs when I reboot system.

I perfomed clean driver install to latest drivers.
n_scott_pearson
Super User Retired Employee
208 Views
When you say 'latest', you mean the latest from your laptop vendor, right? You should not be installing any drivers from the Intel site without first discussing this with your laptop vendor to ensure there are no customizations being partially/fully eliminated by doing so.
...S
Hammer_0101
Beginner
204 Views
Hi sir

I mentioned lenovo technical support this issue and whatever drivers they gave me to install I installed it.
Jean_Intel
Moderator
180 Views

Hello Hammer_0101,


I appreciate your response.


I understand that you already contacted Lenovo for support. I would like to confirm if there is anything else that we can do for you. 


Best regards,

Jean O. 

Intel Customer Support Technician


Hammer_0101
Beginner
171 Views
Hi sir,

I register complaint their and yesterday legion ultimate support contaced me and said you can use your laptop on hybrid mode thats what we recommend our users. Brightness is not controlled by gpu instead it's controlled by cpu so, Thats how it work.

So basically they said their is no permanant solution to this just use on hybrid mode.

I also send them a video of how it's stop working.

https://drive.google.com/file/d/1HsIoP8xMl6KVYHa9tYNmPc00KPW-D8i_/view?usp=drivesdk
Jean_Intel
Moderator
154 Views

Hello Hammer_0101,,

 

Since you have followed our troubleshooting steps and the issue persists. We advise you to continue with the support through the Lenovo support channel you are using. It is important to mention that the brightness feature is an Original Equipment Manufacturer (OEM) feature. It is implemented to the embedded monitor, and since it is a hybrid graphics system, Lenovo would have a more clear idea about how your system works.

 

Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding. 

 

Best regards,

Jean O. 

Intel Customer Support Technician

 

Bill_Mars
Beginner
148 Views

Hey Hammer;

You've been 4 days and still no results?

First things first... I went shopping and found your laptop.

It is NOT "just an integrated GPU"

If you bought the 'RTX3060' it is an NVIDIA® GeForce® RTX™ 3060 Laptop GPU..

 

Now just between you and me; Intel does NOT support Nvidia... or Lenovo.

 

If you have  Nvidia Geforce 3060 you need to go to Nvidia and get that set up and cofigured with them. Lenovo won't do this, neither will Intel. They are not paying their customer support staff to do this. So you won't get answers from them.

 

In the old days all we had was Windows settings. Now we have  computer settings, windows settings and graphics card settings to deal with. And if you're on a desktop and bought a gaming monitor you also have the monitors settings to deal with.

 

As overwhelming as it seems to calibrate and configure all this... it's easy.

 

But first get proprietary drivers installeed so get to Nvidia first.

 

If that works for ya I'm happy. It usually does sinve Nvidia has been hand in hand with windows for more than 2 deccades and they do configure well with each other.

 

But if it doesn't and you feel like bitch-slapping someone...

 

Hang on a sec. and go get the intel Graphics Command Center from downloads.

 

Forget customer support and tech support for now. It seems they dont even know about it.

 

After instll and reboot load the graphics command center.

Click on 'display'

And right in the middle of the screen you will see 

General, Color, and Information.

 

Just click on "color" and you will be one happy boy.

 

All the settings you need right there... one click.    

 

Just don't forget to hit that great big blue box under it that says "save custom".

 

 

Reply