Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
18284 Discussions

Insane stuttering in fortnite performance mode

Harryincorrect
New Contributor I
5,929 Views

So I have an intel iris xe laptop with 8gb ram and an ssd. When I first got the laptop, I was able to get 120 fps straight on performance mode. After a while, I decided to play in dx12 with 70 fps straight. Kinda got bored of the fps and changed back to performance mode. Weridly, the game starts stuttering all of a sudden. If I point the camera to the ground, the stuttering completely stops and I see my fps go to whopping 200s. On bringing it slowly to a normal view, the fps starts drastically going up and down with the horrible stuttering at it's best. In any case, it doesn't occur in dx12 (the stuttering). Maybe it's a rendering issue with the driver?

 

Here are some videos of other people testing the game out:

a) https://www.youtube.com/watch?v=zb7dRvTiurU dx12. It's stuttering because graphics are at high

b)https://www.youtube.com/watch?v=cX9UTBmuUns No stutters here and you can see the fps at 100.

c)https://www.youtube.com/watch?v=CruS9jsDSpo&t=32s Fps goes up and then BOOM it goes down. See what I mean?

d) https://www.youtube.com/watch?v=6s35M6rNII8 last one.

Labels (1)
0 Kudos
42 Replies
David_G_Intel
Moderator
3,912 Views

Hello @Harryincorrect


Thank you for posting on the Intel️® communities. Please share with us the following information:

  • Intel® System Support Utility (Intel® SSU) results 
  • When did this issue start?
  • Were able to play normally before?
  • Does this only happen with Fortnite?


Regards, 

David G 

Intel Customer Support Technician 


Harryincorrect
New Contributor I
3,901 Views

Here goes:

1) the ssu 

2) The issue started after reverting to performance mode after using dx12. 

3) I was able to play with a constant 100+fps with absolutely not stuttering before.

4) Yeah, performance mode is a specific mode for Fortnite only.

David_G_Intel
Moderator
3,891 Views

Thank you for the report, it seems that you're not using the latest driver available. For testing, you can complete a Clean installation of the latest Intel generic driver:

You can also update the BIOS but it's better to contact the OEM to confirm if this is recommended and the steps to do so. Let us know the outcome.


Regards, 

David G 

Intel Customer Support Technician 


Harryincorrect
New Contributor I
3,881 Views

Just installed the new driver but it performs just like the old driver sadly. Also, I  use the default hp driver installer app so it gets me all my bios updates.

David_G_Intel
Moderator
3,875 Views

Thank you for the update, please try the following:

  • Check the power plan settings.
    • Press Windows + R.
    • In the Run window, type powercfg.cpl and press OK.
    • Under Choose or customize a power plan, the currently selected power plan is displayed (set to Balanced by default). To the right of the current power plan, select the option for Change plan settings.
    • Click Change advanced power settings.
    • Scroll down, find Processor power management and expand it.
    • Expand Maximum processor state.
    • Double-click On battery and set the value to 100, then do the same for Plugged in.
    • Click Apply, then click OK to exit.
  • Turn off the Windows Game Bar and Game DVR.
    • Press Windows + S.
    • In the Windows search box type Game bar settings and press Enter.
    • Under Control how Game Bar opens and recognizes your game turn off the option for Record game clips, screenshots and broadcast using Game bar. 
    • From the left had menu, directly below Game Bar, select Game DVR.
    • Turn off the Record in the background while I’m playing a game setting.
  • Use the Intel® Processor Graphics settings recommended on Gameplay - Intel for each game.

Finally, your current BIOS is F.16, the latest BIOS as per OEM website is F.18:

It's also recommended to get this updated because BIOS updates most of the time include fixes for your system but you need to check with HP for BIOS update steps.


Regards, 

David G 

Intel Customer Support Technician 



Harryincorrect
New Contributor I
3,868 Views

So I did all that you told but still the game doesn't work in performance mode.

1) The maximum processor state was already set to 100 (both)

2) Turning off game recording and game bar didn't help.

3) The website says to change my rendering mode to dx11 which is full of crashes. Besides, what I want is to fix the performance rendering mode.

4) Updated my bios right now and sadly, it didn't work.

Xillvion
New Contributor I
3,846 Views

I'm also experiencing this problem as well on my Intel Iris Xe Graphics powered Acer Aspire laptop with the i5-1135G7 Processor, the framerate fluctuates a lot if I go to a area with lots of buildings and when there's lots of action going on.

DirectX 12 makes things smoother but causes random hitches/stutters and also increased input latency. Recorded the problem with DirectX 11 Performance mode here:

https://www.youtube.com/watch?v=y0sfco_xC0w

And yes, I clean installed Windows 11 and the Intel graphics driver.

Harryincorrect
New Contributor I
3,798 Views

Same. Performance mode was pretty good at the beginning but now it's the same thing in that video. Random hitches and stutters. Right now, the best thing to do is wait for the devs and play in dx12. If you've noticed, bringing the camera's focus to the ground can stop the hitches, so it has to be a rendering issue .

Xillvion
New Contributor I
3,781 Views

Actually, how well does DirectX 12 work for you? The game always forget about the shader cache everytime you launch it, have a video of it happening as well here: https://youtu.be/XUS1wPFGg-E

Harryincorrect
New Contributor I
3,758 Views
David_G_Intel
Moderator
3,745 Views

Thank you for the information provided, let me investigate this request and I will post the updates on the thread.


Regards, 

David G 

Intel Customer Support Technician 


Xillvion
New Contributor I
3,730 Views

@Harryincorrect Lucky for you I guess but, there's also another problem where, if you change back to DirectX 11, change to Fullscreen not WindowedFullscreen, disable fullscreen optimizations for the Fortnite Client like in the screenshot below....Screenshot 2022-02-16 132908.png

 ...and then launch the game with the BattlEye Anti-Cheat Service, not EasyAntiCheat (it ignores the setting) , it will result in a black screen. Disabling it in any games can give you a bit of a boost in performance. Can you do that @Harryincorrect ?

Harryincorrect
New Contributor I
3,708 Views

It's always happened like that to me. I've tried getting 240 fps and the fps booster people say to disable full screen optimizations. Whenever I try it, I get the black screen. Had to reinstall fortnite then because I didn't know what triggered it.

Xillvion
New Contributor I
3,694 Views

Rather unfortunate that we, alongside others have these problems. But glad that you reported these issues before I got the laptop, though it could take a month or two for these fixes to arrive.

Anyways, I clean installed Windows 11 again due to a Windows Explorer memory leak on bootup, this time I downloaded the ZIP installer instead but no difference in terms of stability for gaming, increase in performance however seems like a placebo to me.

Harryincorrect
New Contributor I
3,680 Views

Hmm. The strange thing is that fortnite performance mode works fine the first time you get it on the graphics card. But later this problem occurs. Since it's happening to both of us and some others, it has to be a driver problem. The only way to determine this though is to install the game in the same graphics card with lower drivers. But that's impossible for me considering I'm on windows 11 and reverting to windows 10 can delete all my system files. The old drivers won't work with windows 11. I might try the same on a windows 10 laptop but the only issue is that it's an intel hd 620 so I don't know it would work like it did on the intel iris xe. If there is any intel dev trying to replicate the issue, do check with the different drivers on both windows 10 and windows 11. Hoping we'd find a fix soon.

Xillvion
New Contributor I
3,672 Views

Actually, older graphics drivers before Windows 11 got released can still be installed on the new OS, Windows Update service did that when I clean installed. But the Desktop Window Manager memory leak will occur.

Harryincorrect
New Contributor I
3,649 Views

Really? Well did it work that way?

Xillvion
New Contributor I
3,607 Views
David_G_Intel
Moderator
3,665 Views

Hello, @Harryincorrect please share the specific steps you go through to reproduce this issue in our labs.


Regards, 

David G 

Intel Customer Support Technician 


Xillvion
New Contributor I
3,641 Views

I can help, launch the game, change the rendering mode in the game settings to Performance Mode (it's DirectX 11 under the hood, relaunch the game afterwards), join a game match, just look around the game world. It should be creating a shader cache but it doesn't make use of it properly.

I did noticed that if I change the rendering mode to just DirectX 11, the freezing is less noticeable but the game performance isn't very good.

Reply