Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20976 Discussions

Intel Arc A380 - No AV1 encoding unless it's the "main monitor"

Splitframe
Beginner
6,325 Views

I recently purchased an Arc A380 GPU to use it as an AV1 encoder.
Sadly the qsv_av1 encoder is not exposed unless:

  1.  A monitor is connected to the GPU
    1. That monitor is also set as the main monitor in Windows 10


This seems like a unnecessary technical limitation, since I tested the following.

I have two monitors A and B.


A is connected to the Intel A380 and is set as the main monitor in Windows.
B is connected to my other graphics card.
I can record what happens on monitor A without problems.
I can record what happens on monitor B without problems, despite it being connected to the other graphics card.

 

But if it is the other way around:
A is connected to my other graphics card and is set as the main monitor in Windows.
B is connected to the Intel A380.
I cannot record any monitor with Quicksync AV1 (or any Quicksync for that matter)

With my other GPU I can record any screen (in h264) regardless if it's connected or the main monitor, respectively.


0 Kudos
12 Replies
Hugo_Intel
Employee
6,299 Views

Hello Splitframe


Thank you for posting on the Intel Communities as well as for bringing this issue to our attention. I see there is no Av1 support when the monitor is not connected to the GPU.


I would like to gather more information on this issue to try to narrow down the cause, first I would like to know the model and firmware of the GPU to check if it might be related to a firmware issue, you can get the firmware version from the gear icon in the top left corner of Arc Control Software as for the model we would like to know the manufacturer and edition of the GPU.


In order to rule out any possible driver issue, have you tested the latest driver 31.0.101.4577 if so, does the same issue happen with older versions? If not done yet, I would suggest a clean installation using Display Driver Uninstaller.


In addition, we would like to know the encoding/recording app that you are using as well as if you have tested different apps to rule out possible app limitations. Also, at the moment the monitor is disconnected from the GPU is the GPU still ben recognized on Device Manager?


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Splitframe
Beginner
6,294 Views

Hello Hugo,

it is an ASRock A380 Low Profile the IFWI is 20.1063.1 for drivers I used both 31.0.101.4577 and  31.0.101.4578 (beta).
The behaviour was the same, the moment that the A380 was not the "main monitor" the AV1 codec ceased to be exposed.
As stated above even if the A380 is connected to a monitor it won't let me encode AV1 unless it's the main monitor.


The Windows 10 Version is 22H2 19045.3324

The software I used was the latest version of OBS Studio, Handbrake and ArcControl.
The GPU is listed in the device manager even if no monitor is connected.

I hope this helps.

0 Kudos
Splitframe
Beginner
6,247 Views

Hello Hugo,

As additional Information I also tested Windows11.

In Windows 11 the Quicksync codecs are exposed when at least one monitor is connected to the A380
it does not need to be the main monitor. When no monitor is connected the codecs vanish again.

Greetings,
Tobias

0 Kudos
Hugo_Intel
Employee
6,219 Views

Hello Splitframe


Thank you for sharing the information with us. Allow me to check this issue with our team and I will let you know once I have an update or in case I need more information I will post back.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Hugo_Intel
Employee
6,191 Views

Hello Splitframe

 

We just want to let you know that based on your feedback, we will be testing and trying to reproduce this issue, once we have more information to share we will post back. Appreciate your patience.

 

Best Regards,

 

Hugo O.

Intel Customer Support Technician.

 

0 Kudos
Hugo_Intel
Employee
6,126 Views

Hello Splitframe


We did some testing regarding this issue with Av1 encoding not working. When using Handbrake version 1.6.1 we were able to use AV1 encoding even when no monitor was connected to the GPU. In the case of OBS, we tested the OBS version 29.1.3 and we were able to select AV1 encoding but the software will only record a black screen when no monitor was connected or it will record the screen the GPU was connected to when connected to a monitor.


Based on our testing we considered this to be an issue on a per-app basis as each has its own method to query the graphics encoding capabilities. It would be better that you check this with the app developer since there might be potential limitations from their side.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Hugo_Intel
Employee
6,088 Views

Hello Splitframe


I see there are no further questions in regard to this issue related to Av1 not being available when the GPU is not connected to a monitor. As informed before it will be better to continue to check the problem with the specific app developer as there might be possible app limitations. We will now proceed to close this thread. Feel free to open a new topic if you need further assistance.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Splitframe
Beginner
6,085 Views

Please do not close this topic prematurely after only 2 days.
I will evaluate this on a fresh Win10 installation and come back to you.

0 Kudos
Hugo_Intel
Employee
6,011 Views

Hello Splitframe


I understand you needed some time to re-test this on Windows 10. Please let us know if you have any feedback or further concerns.


Best Regards,


Hugo O.

Intel Customer Support Technician


0 Kudos
Hugo_Intel
Employee
5,944 Views

Hello Splitframe


I wanted to check if you have further feedback or want to share your findings with us regarding the AV1 features on your Arc A380 GPU. Please let us know.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Hugo_Intel
Employee
5,895 Views

Hello Splitframe


As informed in our previous posts we believe this to be an app issue since every app has a different way to query for the AV1 encoder, hence, better to check with each app developer so they can assist with possible app limitations. We have not received feedback from you so far so this thread will no longer be monitored. Please open a new one if you have further questions.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Simon_Cechacek
Beginner
5,167 Views

Hello and thank you for the thread.

I want to re-open it and ask if the issue was solved and if ARC cards can now be used as encoders without  a display connected to them.

We are working in upload bandwidth limited enviroment, so we want to purchase the ARC 380 card as use it as a encoder, so we can stream AV1 to YouTube via OBS. So is that anything that works now normally? Or is there any workaround to make it work?


Also, our current machine is PCIE3 only. Will that card work as expected for AV1 encoding in PCIe Gen3 port?

Another option is to get the ARC A750 (8G) and use it as a main GPU, but there is still the limitation of PCIE Gen3 on the motherboard, so my querstion about the PCIE port extends to this GPU also.

Thank you!

0 Kudos
Reply