Community
cancel
Showing results for 
Search instead for 
Did you mean: 
94 Views

Intel HD 530 GPU - Dual Screens Flickering - Display Port

Hi,

I have the below hardware on latest drivers with UEFI bios, clean Windows 10 Professional install with latest updates as well as latest Intel chipset drivers installed.

bytewize-consulting_0-1611369588641.png

I have 2 x samsung 4K LED screens connected the the device via the 2 x onboard Display Port Adapters with brand new quality cables. I have also swapped the cables around to isolate hardware.

The screen connected the same port flickers every 30 minutes and only when using some applicaitoions, in my case RDP. The screen will flicker and sometimes go off then on again.  THis is very frustrating and i need to get this working as i havew severl maching to roll out  with the same hardware.

This appears to be a driver rleated software bug issue, please advise if there is known fix to this!

Thanks

A

0 Kudos
6 Replies
n_scott_pearson
Super User Retired Employee
75 Views

This issue - which is actually a temporary loss of communications between the iGFX engine and the downstream TV/Monitor/Receiver device - gets fixes regularly, but then it is back in later releases or with different monitors.

I have found that getting a higher-quality HDMI cable will often eliminate the problem. Try one that is HDMI 2.0 certified. Never use any cable that came with a monitor; these are almost always pure crap. My rule is to recycle them right out of the box.

...S

0 Kudos
71 Views

Hi Scott,

As per the detail in my question I used new high quality 8K certified cables before i even connected the screens and I also swapped the ports over to isolate hardware, the same issue was being experienced from the same port on the other screen eliminating any hardware connected.

Its obviously a driver related issue with using multiple high resolution screens, i need to know if there is a beta driver that addresses this.

Hoping Intel are aware of this and will address in the next driver update, this has been an issue with the HD530 GPU in the past if you search.


I hope this helps others who find this same issue.

A

 

Thanks 🙂

Tags (1)
0 Kudos
n_scott_pearson
Super User Retired Employee
66 Views

IDK when they will release fixes for any particular issue. Any foreknowledge that the ICS folks have they are not allowed to pass on. Their release notes are a pitiful mess and cover only the latest release, so looking at fix history is nigh unto impossible. People have asked for an aggregated document but it is unclear that they have one to start with.

...S

0 Kudos
Maria_R_Intel
Moderator
45 Views

Hello bytewize-consulting,


Thank you for posting on the Intel* Community.


We would like to check this, can you please provide the below details?


  • Just to confirm, is the connection DisplayPort* to DisplayPort* direct from PC to Monitors? (no adapters or dongles)


Provide the Intel® System Support Utility (Intel® SSU) 

 


 

With the external displays connected, provide the Intel* Graphics Command Center report:

 

>Go to the Intel Graphics Command Center

>Support

>System Diagnostic

>Generate report.

>Attach the report file.


Best regards,

Maria R.

Intel Customer Support Technician



0 Kudos
Maria_R_Intel
Moderator
31 Views

Hello bytewize-consulting,


Were you able to check the previous post?

 

Let me know if you need more assistance.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


0 Kudos
Maria_R_Intel
Moderator
18 Views

Hello bytewize-consulting,


We have not heard back from you, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


0 Kudos