Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
18911 Discussions

Intel UHD Graphics 630


I am using AsRock Z370 Taichi

32GB 3200mhz DDR4 Ram

Intel i5 8600K

This MOBO come with integrated graphic, which is Intel UHD Graphics 630 and the driver is installed then the screen become flickering and a lot of dots, then I will need to disable to use it normally. But his reduce the performance on certain gaming speed.

Attached are the display adapter disable and enable, and the different.

If enable I can't even see my log in screen it is only blank or flash a while and turns to blank screen. 

I had uninstalled and reinstalled with the latest driver also the same, I had even tried with the older driver which is Intel HD Graphics 630 and it is still giving the same issue.

any help is very much appreciated 

Display driver disable.jpgdisplay driver enable.jpg


0 Kudos
7 Replies
Super User

So we can have more information about your system, Download, run, and save the results of this utility as a text file:

Then ATTACH the text file using the instructions under the reply window ( Drag and drop here or browse files to attach ).



Please find the attachment for the SSU which I just run.


Super User Retired Employee

My first reaction to seeing the "snow" is that you might have a memory problem (Intel HD Graphics uses a portion of your DRAM as its VRAM). I question the practice of using highly-overclocked XMP memory like the 3200MHz DIMMs that you have; your processor is only validated for up to 2666MHz DIMMs.

You are running a fairly old version of the Intel HD Graphics driver. Look on the ASRock site for a newer version of the driver.

You can also consider trying Intel's new HD Graphics driver releases, which support the overinstall of vendor-specific driver releases without losing the vendor-specific customizations included. This capability was introduced in version, but the current release is There is also a Beta version: that you could try.

Hope this helps,


All driver i had tested already. But i never trieed that one you mentioned which is the 2666mhz dimms.

Does it mean my i5 8600k only can support max 2666mhz ram? Not the 3200mhz ram?

I had tried to change the DRAM mhz to 2400 and it still giving the snowing effect on the screen once I enabled the display adapter. I do not want to buy any GPU for the time being for now. I wish to use the integrated Intel UHD Graphics 630. 


Please help

Super User Retired Employee

No, I am not saying that the DRAM running at 3200MHz isn't going to work, just that it is overclocking the memory buses and this can lead to problems. If you locked it at a lower XMP setting set and it still has the issue, we have to focus next on the driver.

As I said earlier, you are running on a fairly old build of the driver. Your vendor has a newer version (here: that you should try first.

If that doesn't solve it, you can try one of the new drivers from Intel that supports the retention of vendor driver customizations. Latest is v27.20.100.8476, which is available here:, There is also a fresh Beta driver, v27.20.100.8581, available here:

Hope this helps,


Yes I had tried all sort of the suggestion you mentioned before i post up my question.

I had tried all newest driver and older driver also had tried the Asrock newest driver too. All give me the same issue. Had also tried to lower mhz for the ram also giving the same error.

I search all internet and cannot find any solution at all.