Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
101 Views

Intel graphic command center not working after I upgraded windows build 10.0.19041

Hello there at Intel 🙂

After I upgraded my windows 10 to version 

2004
OS Build 10.0.19041

the resolution on my BenQ BL3200 went down to 1920 x 1080 from my usual 2560x1440.  (That has happened before and I was always able to make my resolution on my Intel HD Graphics control Panel and switch to it again.)  But now my Intel HD Graphics control panel stopped working too, so I switch to  the new one Intel Graphic Command Center, but That is not working either to put my display back to 2560x1440.  I also set up Intel Driver and Support Assistant. and it says everything is ok .  But still my Intel® HD Graphics 4600 is not able to go to my higher resolution.  

I send herewith the reports from the Intel Driver& Support Assistant  sorry for the snapshots but the assistant make the report in html but you don´t support that in attached files 🙂

Is there a way of getting my loved 2560x1440 resolution back ?

Best regards 

Geir Thorsteinsson Reykjavik Iceland

0 Kudos
8 Replies
Highlighted
83 Views

Geir1, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance, we just wanted to confirm a few details about your system:

What is the model of the motherboard?

What is the model of the Intel® Processor?

If this is a laptop, what is the model of it?

Is this a new computer?

Did you make any recent hardware/software changes besides the Windows* update?

"Was always able to make the resolution on the Intel® HD Graphics Control Panel", that means the resolution 2560x1440, was a custom resolution?


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


0 Kudos
Highlighted
Beginner
81 Views

Hi there Alberto R,

 

Thank you for your answer.  I put the answers to your questions below.

Best regards and hope for solution 😊

Geir

Motherboard:  
Gigabyte Technology Co., Ltd. Z87X-D3H
System Manufacturer Gigabyte Technology Co., Ltd.
System Model Z87X-D3H
System Type Desktop
Motherboard Manufacturer Gigabyte Technology Co., Ltd.
Motherboard Product Z87X-D3H-CF
Version To be filled by O.E.M.
BIOS Version BIOS Date: 05/16/13 21:44:26 Ver: 04.06.05
Date 5/16/2013
SMBIOS Version 2.7
Intel Processor:  
Intel® Core™ i7-4770 CPU @ 3.40GHz
Device Details
Manufacturer GenuineIntel
Description Intel64 Family 6 Model 60 Stepping 3
Architecture x64
# of Cores 4
# of Threads 2
Processor Base Frequency 3401 MHz
Current Voltage 1.6
Level 2 Cache 1024 Kb
Level 3 Cache 8192 Kb
Processor Id 0x306C3
Revision 15363
Availability Running at full power
Not a laptop Home computer
Not a new computer I think it is 5 or 6 years old
No I did not make any other hardware changes only updated my windows.
No I remember when I bought my 32inch BenQ display a few years back I had to make changes in the graphics to get 2560x1440 and always since in every big update from Windows, I have had to make these changes, make a custom resolution and switch to that resolution.  It has always worked until my Intel HD Graphics Control stopped working after the upgrade to Windows 2004 OS build 10.0.19041 few days back. So I got Intel Graphics command Center and that is not working either to get my custom resolution to  2560x1440.  The GCC does not show any resoulution possibilities but seems to make my 2560x1440 form me but then it is not awailable to use. 
0 Kudos
Highlighted
61 Views

Geir1, You are very welcome, thank you very much for providing that information.


Just to let you know, the Intel® Graphics Command Center was designed to work with 6th Generation Intel® Processors or later, in this case, you are using a 4th Generation Intel® Processor so you will need to use the Intel® Graphics Control Panel.


We recommend to install the graphics driver provided by the manufacturer of the computer/board, since that driver was customized by them work with your specific platform.

Please uninstall the Intel® Graphics Command Center and install Gigabyte's Graphics driver version 1‎5.40.16.64.4364 that should include the Intel® Graphics Control Panel:

https://www.gigabyte.com/Motherboard/GA-Z87X-D3H-rev-1x/support#support-dl-driver-vga


If the problem persists after that, then install Intel® Generic Graphics driver version 15.40.46.5144 that contains the Intel® Graphics Control Panel as well and let us know the results:

https://downloadcenter.intel.com/download/29804/Intel-Graphics-Driver-for-Windows-15-40-?product=814...


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


0 Kudos
Highlighted
Beginner
60 Views

Thanks, 

Will do as prescribed and report 🙂

Geir

 

0 Kudos
Highlighted
Beginner
47 Views

Hello again,

Changed my driver as seen in the inteldriverfromGigabyte.png and then I tried to start the IntelHDGraphics Control Panel but it just came on the screen and then dissapeared and did not open, so I'm still stuck with my 1920x1080. 🙂 I did several shutdowns and restarts to be sure.

Please what next ?

Best regards, Geir

0 Kudos
Highlighted
Super User
30 Views

Hi @Geir1 ,

1. Please download and install Intel Graphics Control Panel (IGCP) from the Microsoft Store clicking on this link. 

2. I've just installed the IGCP on my NUC, updated to Windows 2004 and the IGCP is fully functional. See the attached image.

Leon

 

0 Kudos
Highlighted
Beginner
19 Views

Hi Leon,

Thanks for your input. but I have allreadey tried to install the IGCP and it did not funktion with my 4th generation of Intel which I have.  but thanks.

Geir

0 Kudos
Highlighted
Beginner
14 Views

Hi Leon

Tried again but in vain 🙂

thanks, Geir

0 Kudos