Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20751 Discussions

Iris Xe Graphic Driver for Hogwart Legacy(game)

Nannoi
Novice
3,331 Views

I have problem with playing Hogwart legacy. My laptop is using 12th Gen Intel(R) Core(TM) i7-12700H 2.30 GHz ,Ram 16.0 GB with Ires Xe graphic driver. I have just installed the game yesterday and it was totally fine and smooth but today I played it again, but characters' hair and the trees are not rendered well, they are lagging and pixelate even I set up the lowest performance setting. Do you have any recommendations to fix this issue? 

 

this is what I played yesterdaythis is what I played yesterdayand what happened todayand what happened todaymy laptop specificationmy laptop specificationgraphic drivergraphic driver

0 Kudos
1 Solution
Nannoi
Novice
3,215 Views

I can fix it now, I just read the player's comment that has the same spec as mine, he recommended deleting all the shader files in Hogwarts legacy folder in the program data location. Whatever the reason it works now!!!

 

As far as I read those comments it seems this issue happened only to Intel Iris Xe, 12th Gen, Core i7,16 GB. Even Core i5 or 11th Gen still can run this game properly. Hope all this information can help you to find the reason behind this problem.

 

Thank you for your support. You are the only technical service platform that help me and solve my problem willingly.

😍

View solution in original post

0 Kudos
9 Replies
Jean_Intel
Employee
3,300 Views

Hello Nannoi,

 

Thank you for posting on the Intel️® communities. We would be more than glad to help you.

 

To better assist you, please provide us with the following information:

  • Do you recall any hardware or software changes before the issue occurred?
  • Is this issue related to a game stage?
  • What is the game distribution service? ( Blizzard, Epic, Origin, Steam, Xbox, Ubisoft connect)
  • We want to further investigate this matter. We may need to have more details about your system configuration, create a report using the Intel® System Support Utility (Intel®️ SSU) 
    • Download the Intel SSU
    • Open the application and click "Scan" to see the system and device information. By default, Intel®️ SSU will take you to the "Summary View."
    • Click the menu where it says: "Summary" to change it to "Detailed View."To save your scan: click on "Next"; then "Save."

 

Best regards

Jean O. 

Intel Customer Support Technician


0 Kudos
Nannoi
Novice
3,293 Views

1. Do you recall any hardware or software changes before the issue occurred?

The only thing that I did is updating the graphic driver because the old version didn't support the games. After I installed it, I open the game it's totally fine and smooth, no rendering problem and I played for more than 2 hours. I'm not sure about updating Windows, since sometimes I just click shutdown and install automatically.

 

2. Is this issue related to a game stage?

I'm not sure what the game stage means but this problem occurred during the whole stages of the game.

 

3. What is the game distribution service? ( Blizzard, Epic, Origin, Steam, Xbox, Ubisoft connect)

I installed it via Epic services and I ask them about this, they just sent me a link to go to the developer's website to ask them directly.

 

0 Kudos
Nannoi
Novice
3,289 Views

And this is more details about my system configuration.

0 Kudos
Jean_Intel
Employee
3,257 Views

Hello Nannoi,

 

Thank you for the information provided.

 

Try performing a clean driver installation, installing our latest production driver, 31.0.101.4314. Performing a clean install of the software/drivers for any hardware can help to fix specific issues that can be associated so any additional software that might be causing malfunction. It is important to mention that there are e two different types of drivers, generics provided by Intel and Equipment Manufacturer drivers, that are customized to work with each specific system. Intel Generic drivers should be used for testing purposes.

 

Also, if it is possible, try using another monitor/TV display and check if the issue persists on an external device.

 

About the game stages, we asked this to confirm if the issue is present on a determined location, characters, or game mission.

 

Best regards

Jean O.

Intel Customer Support Technician

0 Kudos
Nannoi
Novice
3,248 Views

I tried a clean driver installation 31.0.101.4314, but it still give me the same result. By the way, sometimes I click the setting menu in the game and back to the game again there are a few small black screens. And the light seems exposed when I enter the game, and back to normal after I return from the setting menu in the game. 

 

I will try with another display and I will update you again.

 

 

 

When I enter the gameWhen I enter the gameIn cutsceneIn cutsceneafter I click setting menuafter I click setting menu

 

 

0 Kudos
Jean_Intel
Employee
3,238 Views

Hello Nannoi,

 

Thanks for the information provided.

 

We understand that the issue persists after performing a clean driver installation, and you'll need some time to try an external display. We will wait for you to try another display to confirm if the issue occurs.

 

Also, it would be important for you to try and update the monitor's firmware. Based on the Huawei website for your model, the latest version available is the HUAWEI_MateBook_16s_Monitor_ 22.3.1.3. Try installing this firmware and let us know if the issue is still present.

 

Best regards

Jean O.

Intel Customer Support Technician


0 Kudos
Nannoi
Novice
3,230 Views

 

Thank you for your response, I try to install the monitor's firmware and when I open the game the hair and trees were still not rendered well multiple black screens occurred after I entered the game and the movement of the characters didn't run smoothly as it was.

 

IMG_20230516_234643[506].jpg

0 Kudos
Nannoi
Novice
3,216 Views

I can fix it now, I just read the player's comment that has the same spec as mine, he recommended deleting all the shader files in Hogwarts legacy folder in the program data location. Whatever the reason it works now!!!

 

As far as I read those comments it seems this issue happened only to Intel Iris Xe, 12th Gen, Core i7,16 GB. Even Core i5 or 11th Gen still can run this game properly. Hope all this information can help you to find the reason behind this problem.

 

Thank you for your support. You are the only technical service platform that help me and solve my problem willingly.

😍

0 Kudos
Jean_Intel
Employee
3,175 Views

Hello Nannoi,

 

Thanks for the information provided.

 

We are glad to know you found a solution, thank you for taking the time to share this fix, and hopefully, it may help other community members experiencing similar behavior. Since the thread is now solved, we will proceed to close it. Please keep in mind that this thread will no longer be monitored by Intel.

 

We are always pleased for helping the community solve the issues they face.

 

Best regards

Jean O.

Intel Customer Support Technician


0 Kudos
Reply