Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
11,848 Views

On Win 10 "Scale Full Screen" option doesn't remains selected

Hello,

same driver and same hardware (I attach my SSU result). On a Win7 image we select "Scale Full Screen" on Intel HD graphics config tool, we launch our 4:3 aspect ratio soft and it works perfectly, scaling to full screen ok. We stop and launch again our soft and perfect, we reboot and launch again and perfect.

On a Win10 image we select "Scale Full Screen" on Intel HD graphics config tool, we launch our 4:3 soft and it appears small and centered. However we can then go to Intel HD graphics config tool and select "Scale Full Screen" again, and it woks perfectly, fully scaled! But after closing our soft and new launch, it appears small and centered again, every new launch is small and centered, and of course we can't not change settings after every launch or reboot.

It seems that driver, and only on Win10, doesn't stores that the "Scale Full Screen" option has been selected.

I also remember on old driver versions an "Override Application Settings" option, where is it? However on same driver version, but on Win7, this option is also missing but it keeps the "Scale full screen" option properly selected...

It's quite urgent as we would like to use this motherboard as our main commercial hardware for POS, Digital Signage and gambling machine. We have no problems with Win7 but we would like to use Win10 for lower License costs. The only thing wrong for us is this Scale problem.

Thank you.

Tags (2)
0 Kudos
26 Replies
Highlighted
Community Manager
1,492 Views

Hello dev00cat,

Thank you for reaching the Intel Communities. I understand you would like to have this system working as desired in terms of scaling.

We can certainly troubleshoot this scenario to look for a possible solution.

In this case, I would like you to remove the driver, restart the system and install the current driver once again, by doing this, we can remove any possible corrupted file from the driver installation folder.

These are the steps to be followed to remove the driver:

-Access the device manager (you can use windows start search to find it)

 

-Look for Display adapters double click on it

 

-Right-click on your Intel® HD Graphics and hit properties

 

-Go to driver tab and hit uninstall

 

-Select "Delete the driver software for this device"

Then reboot the system, and install this driver: https://downloadcenter.intel.com/downloads/eula/26813/Intel-Graphics-Driver-for-Windows-15-33-?httpD... Intel® Graphics Driver for Windows* [15.33]

If you face troubles while installing it, follow these steps to get it installed:

1. Extract the .zip file downloaded

2. Access the device manager and look for display adapters (double-click on it, you should be able to see an Intel(R) HD Graphics adapter or Microsoft Basic Display Adapter")

3. Right-click and select update driver for Intel HD Graphics

4. Select "Browse my computer for driver software"

5. Select "Let me pick from a list of device drivers on my computer"

6. Click on "Have Disk" and find the extracted folder of the driver downloaded

7. Go to "Graphics" folder within driver folder and select the **igdlh64.inf** file and hit open then ok

8. Select Intel HD Graphics XXX under "model" and hit next

 

If the problem persists, please test your system with an older driver: https://downloadcenter.intel.com/downloads/eula/25977/Intel-Graphics-Driver-for-Windows-15-33-?httpD... Intel® Graphics Driver for Windows* [15.33]

 

Thanks,

 

Esteban C
0 Kudos
Highlighted
Beginner
1,492 Views

Hello,

I've tried reinstalling both drivers (first link was wrong, a 32bit version but I found 64bit version of this driver, no problem). Problem persists, same behaviour.

I attach some pictures of the process:

1. I select "Maintain Display Scaling" and Apply. The screen scales Ok.

2. I launch my 4:3 (640x480) app. It appears centered ans small, not scaled to full screen.

3. I stop my app and I check again Intel HD settings. Now "Maintain Display Scaling" option is not selected, but "Centered Image" instead.

It seems like my App is overriding the Intel HD settings. But on all this drivers the old option "Override Application Settings" is missing.

Thank you.

0 Kudos
Highlighted
Community Manager
1,492 Views

Thank you for reporting back, dev00cat

I was wondering, do you have scaling options on the monitor's menu? This is to set up the monitor to 4:3 or different scaling options and check how the image is reproduced.

 

Regards,

 

Esteban C
0 Kudos
Highlighted
Beginner
1,492 Views

Hi Esteban,

if you want to see how monitor reproduces 4:3 at full screen, you only need to check the '1.jpg' picture I attached on my previuos answer. Monitor, after applying "Scale Full Screen" on Intel HD Settings for 640x480 resolution, it reproduces at full screen perfectly, no black borders, all ok.

But after doing this, when I launch my App (wich uses 640x480 resolution), on picture 2.jpg you can see the black borders appears.

It's just this, it's not a Monitor problem at all: same monitor, same hardware, on Win 7 I never have black borders with my App. I do exactly the same on Win 10 and I have this issues, so it's obviously a problem with your drivers for Win 10. Scale Full Screen option on Win 10 drivers get lost!

Thank you.

0 Kudos
Highlighted
Community Manager
1,492 Views

Thank you for reporting back, dev00cat

 

 

Is there a possibility of me getting the software used to test the system's behavior on my side?

 

 

 

Regards,

 

Esteban C
0 Kudos
Highlighted
Beginner
1,492 Views

Ok,

I will prepare you a slim, standalone version of our soft, just to reproduce this issue.

Thank you.

0 Kudos
Highlighted
Community Manager
1,492 Views

That would be great, thank you. dev00cat

 

Regards,

 

Esteban C
0 Kudos
Highlighted
Beginner
1,492 Views

Hi Esteban,

I attach a very lightweight test app for you (and screenshot). It just changes resolution to 640x480 as we do in our production soft.

You will see that after launching the app, your desktop appears at 640x480 but small and centered. You can then click OK to continue at 640x480 or Cancel to restore original resolution.

If you click OK, then go to Intel HD Settings and select "Scale to Full Screen" option, it scales ok, perfect! you have the desktop at 640x80 and Full Screen.

But then you launch again the test app, and it again appears small and centered. If you go to Intel HD Settings again you will see that "Scale Full Screen" option is not selected anymore, it gets lost! Here is the problem, driver seems to not stores that I selected this option in advance. Or my test app is allways overriding driver settings.

This test app is developed with Visual Studio 2010 SP1, it's possible you need to install the C++ redistributable package:

https://www.microsoft.com/en-us/download/details.aspx?id=8328 https://www.microsoft.com/en-us/download/details.aspx?id=8328

And after preparing all this stuff, I see that you can simulate the same behaviour by going to "Compatibility" settings of any app (right click and Properties), and select "Run in 640x480 resolution". You will see your app small and centered.

Thank you.

0 Kudos
Highlighted
Community Manager
1,492 Views

That is terrific, thank you for the willingness to work with this matter, dev00cat

Let me get a system similar to yours so I can proceed with the tests and then report back to you.

 

Regards,

 

Esteban C
0 Kudos
Highlighted
Community Manager
1,492 Views

dev00cat

After doing the respective tests I found the following results:

What I did:

1. Run the app

 

2. Screen will appear as centered

 

3. Go to the control panel and select scale to full screen

 

4. Restart the system and get regular resolution

 

5. Start the app again and get centered again

 

 

Hardware Used (the same graphics driver is used for this graphics adapter so it should not make a difference):

 

System: Lenovo x230 Tablet

 

CPU model: Intel® Core™ i7-3520M Processor

 

RAM Part Number: 6GB

 

Monitor Brand and Model: Built-in

Software:

 

OS: Windows 10* 64-bit Build 15063

 

Gfx driver version(s): 10.18.10.4653

 

Tested App(s) version: Provided by you

The outcome:

Yes, the problem was present, however, I found this workaround:

  • If the option "Scale to Full Screen" is enabled before the app "IntelSFS.exe" is run
  • The screen goes to fullscreen right away

Please let me know if it is ok for you to use the scale to full-screen option while having the "standard" resolution of your system.

This worked for me several times, please let me know how it goes.

 

Regards,

 

Esteban C
0 Kudos
Highlighted
Beginner
1,492 Views

Hello Esteban,

first of all thank you for your tests!

Next, when we talk about "Scale to Full Screen" option, in fact is "Maintain Display Scaling" isn't it. We use to have spanish language Windows systems, but today I checked this option on an english system and I could see the option name is "Mantain Display Scaling". Just to clear it.

Your workaround is not working on my systems:

- If the option "Scale to Full Screen" is enabled before the app "IntelSFS.exe" is run

-The screen goes to fullscreen right away

I enable "Maintain Display Scaling" while in standard resolution and I launch my app... small and centered always. However, on Intel HD Graphics possible resolutions to configure the "Maintain Display Scaling" option, I don't have 640x480, so I set the option to all other possible ones. In any case, it's the same I do on my Windows 7 systems (I neither have 640x480), same driver and same hardware, but on win7 everything works ok, scaling to full screen, keeping this option selected after restarts, etc. So I still think your win10 driver or win10 itself is doing something wrong here.

And anyway, this is a software for POS and Digital Signage systems, we don't have any user intervention, so although if your workaround would have worked for us, we would still need a command line option or something similar to automatically set the "Maintain Display Scaling" prior to launch our App.

Anyway as I told, your workaround doesn't work for us, may be it only happens on our graphic card model, or on win 10 Enterprise edition (you have my SSU result).

Thank you.

0 Kudos
Highlighted
Community Manager
1,492 Views

Hello dev00cat

Thank you for the answer provided.

The workaround used was with "Scale to Fullscreen" and it worked the way you said here:

 

"- If the option "Scale to Full Screen" is enabled before the app "IntelSFS.exe" is run

-The screen goes to fullscreen right away"

 

The Scale to Fullscreen and Maintain Display Scaling are different options, we want to use Scale to Fullscreen.

Let me check if something related to the default options related to scaling can be done, I will contact you back as soon as possible.

 

Regards,

 

Esteban C
0 Kudos
Highlighted
Beginner
1,492 Views

Ok,

but I don't have any "Scale Full Screen" option, I only have "Center Image" and "Maintain Display Scaling", sorry for this confusion.

Anyway as I told you, I have exactly the same options on win7 and win10, but on win7 (same drivers and same hardware) I select "Maintain Display Scaling", launch the app and everything works fine, scaling to full screen, etc. I do exactly the same on win10 and I have small and centered image.

0 Kudos
Highlighted
Beginner
1,492 Views

Hi Esteban,

it's two weeks now waiting for your answer. Ara you working on it or there is no solution for this issue?

Thank you.

0 Kudos
Highlighted
Moderator
1,492 Views

Hello dev00cat,

Apologize for the delay in our reply. I'm picking this one now if you don't mind.

Can you share the affected application with me? I've been trying to reproduce this with some older games running with 4:3 resolutions @ Full Screen but so far I have not observed this particular behavior.

Best Regards,

Ronald M.

0 Kudos
Highlighted
Beginner
1,492 Views

dev00cat, I understand your frustration.

I got an ASUS T100TAL tablet that I want to use as an retro Windows gaming PC and attach it to either my big monitor or my TV.

I've got it all set up and ready to go, when I was met with scaling problems.

First, let me just say that I only have problems with scaling when I output to HDMI. On my built-in display, the scaling is OK, the same goes for WiDi, if I connect my tablet to my TV that way.

But, built-in display and WiDi were the only options I was using when setting up the thing, as I did not have micro-HDMI to HDMI cable.

The tablet is 99 % ready to be my retro gaming PC, 1 % missing was connecting it to big screen via HDMI.

Imagine my disappointment when I got the cable and found out I can only get itsy bitsy picture on my big screen... totally not what I was going for. I'm better off playing on the built-in display. WiDi is out of the question, since it has ~1 second lag - unplayable.

OK, enough ranting and story telling. Let me tell you my specs and my findings:

My ASUS T100 has an Intel Atom Z3735G with Integrated Intel® HD Graphics.

I have decided to install Windows 10 on it, specifically Version 1607 (Anniversary Update) - 32-bit. It came with Windows 8.1 license, but since Microsoft was giving away Windows 10 for free to machines with these older licenses, I went with Windows 10.

I have tried the following drivers:

- from ASUS web support page, driver package for SOC (includes Graphics drivers) for Windows 8.1 - Version: 10.18.10.3643

- from ASUS web support page, driver package for SOC (includes Graphics drivers) for Windows 10 - Version: 10.18.10.4252

- and also directly from Intel - Version: 15.33.45.4653 (Latest)

All drivers behave exactly the same.

When I install them I connect my tablet via HDMI and set to display only on HDMI. I don't need to extend my desktop, nor do I need to clone it - both of the things I also tried when troubleshooting, but none helped.

If I open Intel Graphics Control Panel when my picture is only on my HDMI device (doesn't matter if it's my monitor or my TV - everything is the same), by default the resolution is set to the native resolution of my big displays - both have 1920 by 1080 at 60 Hz and scaling is set to "Center Image".

For the native resolution scaling setting doesn't matter, of course, but I have tried setting it to "Maintain Display Scaling" and when I run my games, the picture is centered and tiny. I only have these two options - "Center Image" and "Maintain Display Scaling" - same as you.

When I use my built-in display I get more scaling options - "Maintain Display Scaling", "Maintain Aspect Ratio" and "Scale Full Screen" - the "Center Image" is then missing. For what is worth, this should never even have been an option - what is it even good for and why is it the default?!

Anyway, if I set a lower resolution on my HDMI display, the default scaling setting is again "Center Image". If I switch back to some resolution where I have already previously changed scaling to "Maintain Display Scaling", this is forgotten and is again set to "Center Image".

Another interesting thing is - if I look at my monitor's OSD this is what I find: When scaling "Center Image" is selected - no matter what resolution I set in the Intel Graphics Control Panel, monitor says it is 1920x1080@60Hz. Makes sense. However, if I set scaling to "Maintain Display Scaling", my monitor's OSD says the set resolution is the one I set in the Intel Graphics Control Panel.

Then I did a test. I ran a game at 1024x768 and my monitor said it was at 1920x1080@60Hz (it's always this in games - sadly; as this is the root of my problem). Then I set my Windows to 1024x768 and set scaling to "Maintain Display Scaling" and my monitor reported 1024x768. I was really hoping that when I ran my 1024x768 game that it would remain that way, but no, the Graphics driver clearly decides that it will do the "Center Image" scaling, because I again get a tiny picture and my monitor reports 1920x1080@60Hz!

I think that the driver is set to default to "Center Image" every time a resolution change happens. Why it happens even if Windows is set to the same resolution as the games I run, I don't know, but it happens every time I run any of my games and so they get the "Center Image" scaling.

If I then press CTRL+ALT+F11 and select "Maintain Display Scaling", this only has an effect on Windows Desktop, because as soon as I switch back to my games, it goes to "Center Image" again.

When I tried extending my desktop, games never went full screen on my HDMI display, always on the built-in display; that's why that didn't fix the problem.

When I tried cloning my desktop, games had "Maintain Display Scaling" on the built-in display and "Center Image" on HDMI display.

To elimitate the fault being my monitor or my TV, I tested my work laptop with them. It has an i7-5600U with Intel® HD Graphics 5500 and Windows 10 Enterprise 1703. It works as one would expect and has always all of the scaling options available, no matter if on built-in display, WiDi or HDMI.

The "Maintain Display Scaling" and "Maintain Aspect Ratio" work the same - you get the picture as big as the screen is - it only has black bars left and right, when the resolution is 4:3 as the screen is 16:9 - that's what I want with my tablet! The "Scale Full Screen" works as it should - the picture being stretched so it fills the wholse screen.

The "Center Image" options is what I always get with games on my tablet and should not exist if you ask me.

I have also tried to fix my problem with changes to Windows Registry. I changed all of the values with HDMI in the name one by one from 0 to 1 or vice-versa in "HKLM\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000". No luck.

Then I also tried changing the value for Scaling in "HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration\MONITOR_SUBKEY\00\00\" to 3 and 4.

Nothing helps - what's worse - nothing I do or change has any effect whatsoever on how games are displayed on HDMI display connected to my tablet.

I will install Windows 8.1 and hopefully that will fix the problem. If not... countless hours have been spent for nothing and for what... a default in a driver that would not have been a problem if the default was the more logical option (in my opinion).

EDIT: Update - with Windows 8.1 everything is the same. I tried Linux though. Namely ZorinOS 12. It runs my Windows games with Wine perfectly, switches to the resolution that the game sets, stretches to the whole screen, respects aspect ratio... everything. Kind of funny that one has to run Linux for Windows games to work properly. Clearly, this is a software issue... sadly I don't believe Intel will ever fix this, because we're talking about low end hardware that is also relatively old now... so, yeah...

0 Kudos
Highlighted
Beginner
1,492 Views

Hi Ronald,

you already have my test App at 13-nov-2017 post, also some screeenshots and many information about this issue. Just move to the page 1 of this thread.

Anyway I think it's clear enough now, your Windows 10 driver (Windows 7/8 is ok) doesn't stores the configuration selected on Intel HD Settings Panel, as "Maintain Display Scaling" is lost after every resolution change.

I don't know if it happens to all Intel HD cards or only on the one integrated on Intel Celeron J1900 CPU (use this hardware if you really want to test and solve it), but it just happens always, and sincerelly we need a solution before the end of the year, or we will definitely discard this motherboard/cpu to our POS and Digital Signage systems.

Thank you.

0 Kudos
Highlighted
Beginner
1,492 Views

FWIW, I have solved my problem. This fix works only on Windows 8.1 though.

Here's what I have to do for it to work:

- Set resolution to the first one that is lower than native (in my case 1920x1080) and has "Maintain Display Scaling" available. In my case that is 1360x768.

- Run any game and the resolution will be changed so no hardware scaling is needed and the picture will be fullscreen.

- In my case with my LG TV, I had to set my HDMI input to "PC", or it would overscan and I would lose some picture on the edges.

Sadly, this doesn't work on Windows 10. And there just seems to be no way of getting it to work if I use my TV's native 1920x1080 resolution, even though I select "Maintain Display Scaling"...

I could not test with Windows 7, because my tablet supports only UEFI 32-bit and 32-bit Windows 7 doesn't support UEFI...

So, dev00cat, you mentioned that you'd prefer Windows 10 because of license fees - is Windows 8.1 a possibility for you?

0 Kudos
Highlighted
Beginner
1,492 Views

Hi paranoidroid and thanks for your help.

Yes, my company would like Win10 because of license fees, otherwise we could continue with Win7. Win8.1 has same terms as Win7, but Win10 (volume licensing) has many benefits.

0 Kudos