Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17564 Discussions

UHD 750 Artifacts

ThatITGuy
Novice
544 Views

Upgraded a machine from a 10700K to a 11700K and updated the drivers.  However the user is reporting artifacting in different things.  I have only seen it reproduced on Facebook, but they say it is happening on other sites and apps as well.  On facebook when you hover over the like button and the emote faces appear, they flash and have pixelated squares moving around.

0 Kudos
1 Solution
ThatITGuy
Novice
518 Views

So, problem is resolved.  I had previously download the latest intel graphics driver but it still had the artifact issue.  I downloaded the DDU (Display Driver Uninstaller) from guru 3D https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

I restarted in safe mode and ran DDU to remove all intel drivers and disabled windows update from automatically installing drivers (an option in DDU) 

 

I then rebooted once complete with my network disconnected, I logged in and installed the new drivers.  rebooted and plugged the network back in (I did not trust Windows update would not install a driver).

 

After the drivers were freshly installed everything works fine, no more artifacts.

View solution in original post

3 Replies
ThatITGuy
Novice
519 Views

So, problem is resolved.  I had previously download the latest intel graphics driver but it still had the artifact issue.  I downloaded the DDU (Display Driver Uninstaller) from guru 3D https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

I restarted in safe mode and ran DDU to remove all intel drivers and disabled windows update from automatically installing drivers (an option in DDU) 

 

I then rebooted once complete with my network disconnected, I logged in and installed the new drivers.  rebooted and plugged the network back in (I did not trust Windows update would not install a driver).

 

After the drivers were freshly installed everything works fine, no more artifacts.

ThatITGuy
Novice
491 Views

So a few reboots later and the Artifacts have returned.

Mike13
Beginner
460 Views

Same issue here. I have the latest BIOS. I can disable the UHD 750 graphics as a temporary solution and the artifacts are removed. I can also update to the latest Intel drivers but a few restarts later I believe I am reverted and the artifacts are back. Another issue is the Citrix Workspace app where it does not function properly. I can click a button and only see that it has been updated by minimizing and maximizing the app. I have tried Windows 7 Compatibility mode as suggested for a WhatsApp issue in another thread.

Reply