Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,639 Views

When is there going to be an update for intel HD 3000 graphics for windows 10?

i have a hp pavillion g6 laptop with intel hd 3000 graphic card.... after the windows 10 update, hardy any game will work. it especially gives the error with minecraft 1.8.8 that i do not have opengl. however when i had windows 7 minecraft 1.8.3 worked perfectly fine but when i also tried this on my new windows 10, it does not work. after a lot of research, i have seen in most places it says that intel has not provided any support for this graphic card.... i dont have money to buy a new laptop . so is intel going to fix this ? or are they going to just ignore their customers and leave this

0 Kudos
3 Replies
Highlighted
Novice
18 Views

Yeah mate im having the same problem with my Intel Hd 4000 graphics and windows 10 , everytime i try to play Arma 3 i get errors , its getting frustrating now.

0 Kudos
Highlighted
Beginner
18 Views

Same question? After upgrading to Windows 10, can no longer access Open GL. Worked fine under Windows 7.

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.

This can usually be fixed by updating the video card drivers.

--- BEGIN ERROR REPORT 7fe0271 --------

 

Generated 7/4/16 10:49 PM

-- System Details --

 

Details:

 

Minecraft Version: 1.5.2

 

Operating System: Windows 10 (x86) version 10.0

 

Java Version: 1.8.0_91, Oracle Corporation

 

Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation

 

Memory: 776272600 bytes (740 MB) / 1037959168 bytes (989 MB) up to 1037959168 bytes (989 MB)

 

JVM Flags: 3 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xms1024m -Xmx1024m

 

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

 

Suspicious classes: FML and Forge are installed

 

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

 

FML:

 

LWJGL: 2.9.0

 

OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.

 

Is Modded: Definitely; Client brand changed to 'fml,forge'

 

Type: Client (map_client.txt)

 

Texture Pack: Default

 

Profiler Position: N/A (disabled)

 

Vec3 Pool Size: ~~ERROR~~ NullPointerException: null[failed to get system properties (java.lang.RuntimeException: No OpenGL context found in the current thread.)]

org.lwjgl.LWJGLException: Pixel format not accelerated

 

at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)

 

at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)

 

at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:244)

 

at org.lwjgl.opengl.Display.createWindow(Display.java:306)

 

at org.lwjgl.opengl.Display.create(Display.java:848)

 

at org.lwjgl.opengl.Display.create(Display.java:757)

 

at org.lwjgl.opengl.Display.create(Display.java:739)

 

at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:398)

 

at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)

 

at net.minecraft.client.Minecraft.run(Minecraft.java:733)

 

at java.lang.Thread.run(Unknown Source)

 

--- END ERROR REPORT 700808eb ----------
0 Kudos
Highlighted
Super User
18 Views

Intel HD 3000 graphics are not supported on Windows 10:

http://www.intel.com/content/www/us/en/support/graphics-drivers/000005526.html Supported Operating Systems for Intel® Graphics Products

As far as I know, Intel will not be supplying updated drivers for HD3000 graphics.

You can use the Microsoft Windows 10 generic driver, or you can roll back to Windows 7, or (if your system permits) purchase an add-on graphics card that is compatible with your motherboard.

Doc

Doc (not an Intel employee or contractor)
0 Kudos