Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
6,598 Views

Windows 8.1 and Intel HD 4000: No Advanced mode!

I recently updated to Windows 8.1 on a Dell XPS 27 One with a Intel HD 4000 graphics card.

Now when I open the "Intel HD Graphics Control Panel" for my second monitor (a Dell U2713hm Digital display) I can no longer use advanced settings. I receive this message:

"This display does not support any of the advanced settings."

The display does DID support them before and should now. I need to set a custom/higher resolution, but can't.

Anyone have any idea how I can get the Advanced settings to return???

Regards,

John

0 Kudos
15 Replies
Highlighted
Valued Contributor III
555 Views

At this moment the driver being used is an inbox driver that is provided with that operating system release which may have limited options.

A driver for this platform will be available in downloadcenter once its properly validated, however we may not provide an estimated time for this to happen.

Highlighted
Beginner
555 Views

Will wait for the official release of Windows's 8.1 then. Thanks for the update. Stops me wasting time looking for a solution.

Cheers

John

0 Kudos
Highlighted
Beginner
555 Views

I have the HD 4000 in my VAIO laptop. I had a similar problem when I upgraded to Windows 8.1

I was unable to use my external monitor at all.

What worked for me was the driver that I found http://forum.notebookreview.com/gaming-software-graphics-cards/723551-newest-intel-hd-drivers-9-18-1... here and the install method that I found http://answers.microsoft.com/en-us/windows/forum/windows_8-hardware/after-updating-intel-hd-graphics... here

I now have a fully functional HD 4000 on my Windows 8.1 Sony Vaio.

Hope this helps.

P.S. - I registered on this forum just to answer this question because I was fighting with the same problem for a few hours this morning and know how frustrating it can be when something should just work, but doesn't.

Best - Charlie

0 Kudos
Highlighted
Employee
555 Views

@jghowell are you trying to set the display to a non-standard or unsupported mode?

0 Kudos
Highlighted
Beginner
555 Views

The second monitor (Dell U2713hm Digital display) has a native resolution of 2560 x 1440.

However, it defaults to 1920 x 1080 via HDMI as a second monitor for the Dell XPS 27 all in one (not sure why, but Dell told me to use advanced mode to get it to work originally).

 

So I need advanced mode to set a "Custom" resolution. Advanced allowed me to set the display to the native resolution (2560 x 1440) using the previous driver before I upgraded to 8.1. Now I can't access advanced mode at all.

Not sure if that means that the display resolution is "Non-standard" or "Unsupported"? The second monitor is certainly meant to operate at the higher resolution...

 

John

0 Kudos
Highlighted
Beginner
555 Views

HI Diego_Intel,

It't been a long time since the Windows 8.1 Preview, and now Microsoft have given an official release date of 18 October for Windows 8.1 hitting the real, non-preview world.

1. Is there a beta driver I can download tha will provide me with advanced settings (I assume you guys have got to be working on something?)

2. Is there an official estimate or firm release date for a new stable driver?

3. Is there any other driver I can use instead? Perhaps for another of your cards that may work?

I really need to get my second monitor working at the correct resolution (makes my graphic design work painful otherwise). My next step is getting the Graphics Card replaced completely by using one from another manufacturer if you can't help (if that's even possible with my Dell machine). As you can imagine, I'd prefer not to have to do so!

Please let me know if 1, 2 or 3 are possibilities.

Thanks,

John

0 Kudos
Highlighted
Beginner
555 Views

Hi 13 Charlie,

 

Just noticed that I never thanked you for your reply. Thanks! Unfortunately, it didn't work for me on my Desktop Dell, but I appreciate the effort it took to sign up and respond. This type of behavior makes the Internet a nice place to visit. 🙂

Cheers,

John

0 Kudos
Highlighted
Valued Contributor III
555 Views

At this moment there is no estimated time for the official driver to be released, a new revision of the beta driver may be released before an official driver is posted.

If you have any feedback about the beta driver for Microsoft* Windows* 8.1 you may post this information on this specific site:

0 Kudos
Highlighted
Beginner
555 Views

After updating to window 8.1 I found myself having the same issue: No advanced mode in the 8.1 driver. I rely in my Dell U2711 heavily, so I was not amused. I have an MSI notebook with an NVidia 670M and an Intel HD4000. I have connected a Dell U2711 on the HDMI port. In the MSI, the HDMI port is connected to the Intel HD4000 (unlike some Asus models). This is how I got it to work:

First of all: make sure you have a good cable, it must support dual link, in doubt just buy a new HDMI 1.4+ cable. Some advice here: Do not be fooled by people who try to sell expensive HDMI cables. These cables do not provide any additional quality in the sense of image quality. HDMI is a digital signal, so it works, or not.

Second (I do not know if this is required, but I think it is): Install the correct monitor driver. Windows is usually happy with the standard PnP driver. First get the driver from the manufacturer, then go to the Device Manager (Win+X), find your external monitor. If required, choose: "Update driver".

Step 1: Run "CustomModeApp". Just push Win+R and enter: CustomModeApp, press OK.

Step 2. Create your resolution (here are the settings for my Dell U2711 on 2560x1440) and click Add:

Step 3. Check if your monitor driver allow this resolution (probably not...):

Right click on your desktop, choose "Screen resolution".

Select your external display, by clicking on it, then click "Advanced settings".

Go to tab "Monitor" and uncheck "Hide modes that this monitor cannot display".

Like this:

Click OK.

Step 4. Select the correct resolution.

Right click on your desktop and choose: "Graphic Properties..."

The new resolution is listed. Choose it:

Click apply. You're done. If nothing happens after clicking apply, (in my case) your monitor driver still does not allow this setting.

Good luck!

0 Kudos
Highlighted
Beginner
555 Views

You are absolutely brilliant! That worked. I had to adjust the refresh rate down to 41 htz when creating the custom resolution (otherwise it told me the Maximum Bandwidth for my monitor had been exceeded) but other than that, it worked straight off. Have been trying to fix this for months. Thank you!

0 Kudos
Highlighted
Beginner
555 Views

Thanks! I Know how frustrating this can be.

Funny thing is, that the advanced mode worked! If I had to take a wild guess, I would say that the driver update from 8 to 8.1 wasn't really a big deal, but then Intel decided to do a UI overhaul also and that the advanced mode got bumped down in priority. Finally they ran out of time and released a driver that wasn't quite finished. But that's just mere speculation...

Anyway, i'm glad this helped you out and I hope Intel fixes this soon.

0 Kudos
Highlighted
Novice
555 Views

Dear 13Charlie,

I also have my VAIO, I will try and repot later. I hope my HD4000 can work, I need to connect to HDMI thanks

0 Kudos
Highlighted
Beginner
555 Views

I ran through these steps as described and the resolution still did not show. Could this be because I'm using a TV versus a monitor? For reference I am using a Yoga 13 with Intel Graphics 4000 and a Seiki 1080p TV. Thanks for any help.

0 Kudos
Highlighted
Employee
555 Views

Hi mattymo,

Please try installing the latest driver for your graphics controller. Here you can download it:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23639 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23639

It is important to mention that the resolutions available depend on the monitor you have so if you are trying to get a resolution and it is not available it may be because the monitor/tv may not support it.

0 Kudos
Highlighted
Community Manager
555 Views

Thank you very much!! It works! I'm using HD 4600 and Geforece 755M Optimus with Dell U2713HM monitor. Currently this is the only way can solve my problem. I'm using HDMI -> DVI-D. Helpfully this comment can help others as well

0 Kudos