Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1434 Discussions

A770 VIDEO_TDR_FAILURE BSOD

null1
Beginner
4,346 Views

Installed an A770-16GB a few days ago and I am having a bunch of crashes and studdering, mostly in game but it has happened with the game minimized too. So far I have only played World of Warships, all settings on max the studdering is random but I am mostly noticing it when zoomed in with guns going off. FPS will drop from ~110 to 30-50.

The bigger issue is BSOD which calls out stop code VIDEO_TDR_FAILURE and igdkmdnd64.sys, mem dump is also calling dxgkrnl.sys and ntoskrnl.exe. I have tried a few different drivers, lost my notes during a BSOD but 31.0.101.3959, 31.0.101.3790 and 31.0.101.3975 among others. I did do a clean install for each driver I tried.

An odd thing I spotted twice so far is with task manager showing the A770 the temperature suddenly jumps to 255c just as the system is freezing and about to go BSOD. Normally temperatures are much lower 70-80c in game and 50c while on this website.

 

 

System is a Asrock Z690 Extreme (most recent BIOS), i9 12900k (not OC), 64GB DDR4, Windows 11 22h2 (fully updated), Re-BAR enabled, 850w PSU (powering the above plus a m.2 NVME drive and x540 da2 NIC).

One thing ssu doesn't seem to capture well that isn't common is the UHD 770 is running 2x 1920x1080 screens and the A770 is running 2x 1920x1080 and 2x 2560x1080 screens. Gaming is full screen on a single 2560x1080 screen connected to the A770.

The system is about 1 year old and had a AMD 5700XT prior to installing the A770. All drivers were cleaned up and the system was stable prior to installing the A770.

0 Kudos
14 Replies
null1
Beginner
4,320 Views

I am starting to think this may be an issue with the GPU. The first day I had no crashes, 2nd day many while in game, now its crashing without anything running. GPU and power connectors have been reseated, tried many combinations of disabling virtualization settings, disabling resizable bar, underclocked system RAM, fans at full speed (dropped GPU temp 4c), disabled UHD 770 iGPU, rearranged monitors to different ports, limited GPU to 70c.

So far it is just random crashing, only pattern is graphics getting slow right before the crash if I am gaming and A770 temp being reported as 255c. I don't think 255c is real, its a sudden jump from 70-80c.

For now, ran DDU again and installed 31.0.101.4032 drivers. Short of any new ideas to test, I am going to put the A770 into an old i9 10850k system to see if the crashing follows.

0 Kudos
Suzie1818
New Contributor I
4,303 Views

I had the same issue. Totally solved by setting in the BIOS and let the PCIe interface connected to the GPU to use Gen 3 instead of Gen 4. You can try and see if this works for you. By the way, benchmark performance with Gen 3 is about 99.5% compared to the result with PCIe Gen 4, and I think the stability is way more satisfactory than the mere 0.5% drop. 

0 Kudos
null1
Beginner
4,285 Views

Thanks, I'll give gen 3 a try on the next crash.

0 Kudos
null1
Beginner
4,279 Views

Well, gen 3 didn't solve it. Crashed a few minutes after booting with the change.

Interestingly, 31.0.101.4032 drivers have crashed twice so far but no BSOD. The monitors go black instead. The first crash black screens and system was hung, second crash with GPU set to gen 3 screens went black and system rebooted.

0 Kudos
Suzie1818
New Contributor I
4,265 Views

Which PCIe interface did you set to use Gen 3? Usually the main PCIe slot uses the CPU PCIe. I attached a photo for your reference.

 

If that doesn't work, maybe you can consider an RMA? Maybe you got a defective card and that will need another card in order to cross check and confirm if that is the case.

0 Kudos
null1
Beginner
4,260 Views

Thanks, it is the primary PCIe slot that can go up to 5.0. I verified it was in 3.0 after it crashed with hwinfo just to rule out it not switching from 4.0 to 3.0.

 

I have put my old 5700XT back in the 12900k system and the A770 is in the old 10850k system. So far no crashes but I don't have a smoking gun that I can reproduce it on demand. The system managed to run overnight but other times crashed within minutes of booting.

 

If it doesn't crash in the 10850k with a single 1920x1080 screen then either a compatibility issue with the Asrock Z690 Extreme board or the A770 has an issue with a less common monitor setup.

 

monitors.png

0 Kudos
null1
Beginner
4,103 Views

So my old 10850k system with the A770 has been stable for a week and the 12900k system stable with the 5700xt @pcie 4.0 during the same period. I put the A770 back in the 12900k system and it has had multiple BSOD's. Aside from the different platforms for 10th and 12th gen, the mainboards are different manufacturers so comparing the two is fun. Best guess from staring at the BIOS's for a few hours is the PCIe power management settings are different between the two with the 10th gen being disabled and the 12th gen being enabled. So I am testing that now.

 

I can rule out monitor config with multiple resolutions and refresh rates and RAM.

 

0 Kudos
AnaWilliam850
New Contributor I
4,096 Views

It sounds like you are experiencing some issues with your system, specifically with your graphics card. It's possible that the card is causing the system to crash and display a BSOD with the stop code you mentioned.

There are a few things you can try to troubleshoot this issue:

  1. Check for any updates to the graphics card driver and install them if available.

  2. Make sure your system is up to date with the latest Windows updates.

  3. Check the temperature of your system and make sure it's not overheating. You can use a program like MSI Afterburner to monitor the temperature of your graphics card.

  4. Check for any loose connections in your system, especially the connections for your graphics card.

  5. Try running a memory diagnostic tool to check for any issues with your system memory.

  6. If none of these steps help, it's possible that the graphics card is faulty and may need to be replaced.

0 Kudos
null1
Beginner
4,093 Views

Thanks, already been through the list.

1. Tried multiple drivers including beta, ran DDU.

2. System is up to date.

3. Temperature is fine, lowered slightly with higher fan speeds and tried limiting GPU to a lower temp with no change.

4. Card has been reseated multiple times.

5. Memory is fine, swapped with a different system and no change.

6. Don't think it is the GPU, works fine in a 10th gen system while the 12th gen system crashes.

0 Kudos
kode54
Beginner
3,922 Views

I also experienced a VIDEO_TDR_FAILURE BSOD on my Windows 11 Pro machine. First it occurred after half an hour into a game, when it was attempting to show a fullscreen H.264 cutscene, it froze on a black picture with the HUD showing, audio played for the video, then it eventually started looping and bluescreened.

Rebooted after the memory dump, then it VIDEO_TDR_FAILURE bluescreened again trying to play the animation on the Discord client startup window, which managed to show a single frame of the VP9 animation before freezing.

Rebooted to Linux. Attempted to play some AV1 video (1920x1080@24fps) in mpv using VA-API (intel-media-driver 22.6.4 at the time) and it played fine until I stopped playback and quit mpv. Then the GPU froze, leaving a GuC froze and failed to reset type message in the journal.

Shut the machine down and powered it off for a while. Rebooted back to Linux. Now it's playing video and running games again.

 

This freezing in games cycle seems to happen every time I get deeply involved in Borderlands 3 on Windows. I have the game configured for DirectX 12, maximum settings, 75% render scale on 3840x2160@60, frame rate set to 22-62 smoothed.

System specs:

MSI B450 Tomahawk with 7C02v1I firmware installed

Ryzen 7 2700 at default clocks

some mixed RAM config of 4x8GB sticks, tested stable

1TB WD SN750 SSD (contains Windows 11 Pro)

1TB Samsung 980 Pro SSD (contains Arch Linux)

0 Kudos
Lenster45
Beginner
3,715 Views

Just had my first Video TDR Failure. A770 16GB was installed 4 days ago. I was not gaming, just looking at email.

Drivers at 4091. All ARC settings at default.

Windows 11 22H2

AZROCK Z370 Taichi. Resizable bar enabled.

8700K, 32G G.Skill DDR4 3200

Samsung 970 EVO

 

The system is 5 tears old and has been perfectly stable. Only change was to update the BIOS to get Rebar and adding the A770.

 

EDIT. One thing I forgot. Yesterday I installed the USB cable for RGB control and I installed the ARC RGB control software. Then I turned all RGB lights off. I am going to leave the RGB off but uninstall the software and remove the USB cable and see if the error occurs again.

 

Second Edit. It failed again after removing the USB and RGB software. This time just watching a video. I had enabled the ASPM support in the BIOS according to Intel's recommendation but now I disabled it.  See if it fails again. If it does, I guess I'll have to return the card.

 

0 Kudos
Lenster45
Beginner
3,631 Views

No more failures after disabling the ASPM settings in BIOS

0 Kudos
k0de54
Beginner
3,611 Views

Cool, lost my profile because I used the same email address to register for this site as with Intel Consumer site, which apparently replaced the profiles for this site, so I also lost the display name.

 

Okay, so I can't turn on or off ASPM, because my BIOS doesn't have options for that.

0 Kudos
Lenster45
Beginner
3,596 Views

Yeah I have an old board also and mine was call "PCI Express Native Control" It did reduce my idle watts to 8 but crashed when I disabled it the idle watts went back to 40.

Check your GPU watts in Hwinfo64 at idle. if its around 40 then this is not your problem.

 

Hey Intel, Since you made your forum changes over this past weekend, I can no longer login. The only way I can log in is using a onetime passcode. If I try to create a new account, it tells me the account already exists! Thanks

 

0 Kudos
Reply