Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MRiou
Beginner
2,371 Views

Aero will not connect to QGroundControl by the usb 3.0 cable

I connected a USB 3.0 cable from my laptop running win10 and QGroundControl tels me to connect my aero drone with the usb 3.0 cable that is already connected to it.

The drone is active and running as it should, i think, because it is connected to a hdmi monitor and i have access to the console, it boots fine.

As far as I know, the connector on the drone works since I was able to update with the latest .iso (1.6.1) booting directly with a usb 2.0 key and a keyboard hooked to it via a un-powered usb hub connected with a nexxtech USB3.0 OTG adapter..

Updated the Linux part, the flight controller, not sure about the bios though, lots of stuff happening I didn't catch.

I'm not versed in linux or a coder/programmer so i just followed the video instructions as best i could, that guy had an accent to cut wood with and talked fast...i might have missed a few things but overall it went fine and got to the same level as the video.

So I know it is functional.

With the drone running on its lithium battery and connected from the drone to a Alienware Laptop I tested a couple of different cables:

1- A brand new RedLink USB 3.0 A Male to Micro B male

No connection, QGroundControl asks to connect the drone, no error messages or anything that would indicate a problem, it just sits and waits. Lettering is red in the top header, not yellow as some screens i have seen on other threads.

I cannot update the firmware either since it is waiting for a connection.

2- A USB 3.0 cable from a Western Digital portable HDD. Same connectors as the redlink and with the same results, no connection, no error messages, it just waits.

Any idea where the problem might be?

0 Kudos
7 Replies
idata
Community Manager
121 Views

Hi MikeDaBoing,

 

 

Thank you for your interest in the Intel Aero drone.

 

Let me investigate and I will get back to you as soon as possible.

 

 

Regards,

 

Alexandra
idata
Community Manager
121 Views

Hi MikeDaBoing,

 

 

I also tried a USB 3.0 A Male to Micro B male cable and it worked.

 

Can you try with a different USB3.0 port? If this doesn't work, try connecting the drone to a different laptop.

 

Let me know how it goes.

 

 

Regards,

 

Alexandra

 

MRiou
Beginner
121 Views

I tried every USB ports on the laptop, no go.

I installed QGroundControl on my Pc running Win 10 64 bit with full admin rights over the network. I made sure the firewall would let QGroundControl have access to it.

Tried every usb 2.0 (8) and 3.0 ports(3), also tried different usb3.0 cables.

Same results.

what would you suggest as alternative connection options?

idata
Community Manager
121 Views

Hi MikeDaBoing,

 

 

Did you try this on a different laptop?

 

 

You can either connect to the drone's access point or access the drone over ssh.

 

You can find instructions here:

 

https://github.com/intel-aero/meta-intel-aero/wiki/08-Aero-Network-and-System-Administration

 

 

Regards,

 

Alexandra
MRiou
Beginner
121 Views

HI,

Never was able to connect over USB 2.0 or 3.0 but I did manage to connect over Wi-Fi. So the basic problem is not resolved and this is more like a workaround. i saw a few other threads that had the same issue with USB connections while working on some other problems they had.

I did try on another laptop. Even tried with a full Pc, same results.

On a side note: I did manage to connect and record a video feed from the RealSence camera but I can only connect through VLC over Wi-Fi. QGroundControl Cannot See the rtsp feed even if it is connected to the drone. Weird.

Yun_W_Intel
Employee
121 Views

You can also try a regular USB 2.0 micro cable if you're looking to just hook RTF up to a PC. To properly connect over USB 3.0, please refer to this thread

I mainly work on a Linux host machine so the RTF gets enumerated automatically as an eth dev. For Windows, you need to make sure your PC recognizes the RTF as a RDNIS device. Then you can verify that ipconfig sees a device with IP address "192.168.7.X".

idata
Community Manager
121 Views

Hi MikeDaBoing,

 

 

There may be an anti-virus or firewall blocking the connection to the Aero RTF. Please check the firewall/Anti-virus settings.

 

 

Regards,

 

Alexandra
Reply