Community
cancel
Showing results for 
Search instead for 
Did you mean: 
YMand1
Beginner
1,539 Views

Bios and FPGA unknown

I installed ubuntu on intel aero RTF. I updated the BIOS and FPGA but when I run command to update px4 firmware. I followed the instruction https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation here. I am getting following messages:-

/sys/firmware/dmi/tables/smbios_entry_point: Permission denied

/dev/mem: Permission denied

BIOS_VERSION = unknown

OS_VERSION = Ubuntu 16.04.3 LTS"

AIRMAP_VERSION = unknown

FPGA_VERSION = unknown

AeroFC firmware version = unknown

0 Kudos
6 Replies
YMand1
Beginner
94 Views

I have solved some of the problems. It is related to Linux kernel. Choose Linux 4.4.xx to log in to ubuntu.

Here are reference links:-

https://github.com/intel-aero/meta-intel-aero/issues/291 Cannot connect to flight controller and FPGA after Ubuntu installation · Issue # 291 · intel-aero/meta-intel-aero · GitHu…

https://github.com/intel-aero/packages/issues/37 AeroFC firmware version = unknown · Issue # 37 · intel-aero/packages · GitHub

I am still getting AIRMAP_version unknown.

idata
Community Manager
94 Views

Hello Yograj,

 

 

Thank you for your interest in the Intel Aero drone.

 

 

I would suggest you try reflashing the px4 firmware.

 

Reset all the parameters in QGC and reflash the px4 firmware to recover the default parameters for the px4 aeroFC.

 

 

Hope this helps.

 

Regards,

 

Octavian
idata
Community Manager
94 Views

Hello Yograj,

 

 

Do you require any more assistance with this issue?

 

 

Regards,

 

Octavian
YMand1
Beginner
94 Views

Hello Octavian,

can you provide the link for parameter setup?

I reinstall and complete system but still getting AIRMAP_VERSION = unknown

Thanks!

idata
Community Manager
94 Views

Hello Yograj,

 

 

Thank you for your reply.

 

 

You can find here the steps for the setup: https://github.com/intel-aero/meta-intel-aero/wiki/02-Initial-Setup

 

 

Although, the issue with the airmap is not uncommon. The reason being that you are running Ubuntu and the airmap isn't installed in Ubuntu but it should still work fine.

 

 

You can check the rest by running the aero-get version.py command:

You should see a message like this (or newer):

BIOS_VERSION = Aero-01.00.13 OS_VERSION = Poky Aero (Intel Aero linux distro) v1.6.0 (pyro) FPGA_VERSION = 0xc2 Aero FC Firmware Version = 1.6.5Hope this helps.

 

 

Regards,

 

Octavian
idata
Community Manager
94 Views

Hello Yograj,

 

 

Do you require any more assistance with this issue?

 

 

Regards,

 

Octavian
Reply