Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JGome26
New Contributor I
1,649 Views

Can't login to root

Jump to solution

Hello,

I recently started building ardupilot from source and I am having trouble at the last step. At the end of it I am supposed to login to root@intel-aero.local. I have tried using the default password which is nothing, and then I tried setting a password and using that and it still won't let me login to upload to the flight controller. Is there a work around to this? Thank you

0 Kudos
1 Solution
JGome26
New Contributor I
104 Views

Update: I solved the problem. I had to change a few settings in the sshd_config file found in /etc/ssh directory. Root login was prohibited so that field had to be set to yes. This is not recommended due to the security issues that may arise but this is the way to do it.

View solution in original post

4 Replies
idata
Community Manager
104 Views

Hello JorgeG,

 

 

Thank you for your interest in the Intel Aero Compute Board.

 

Could you please share the error message you are receiving and the guide you are following to accomplish this with me?

 

 

Thank you very much in advance,

 

Casandra
JGome26
New Contributor I
104 Views

So when trying to upload the ardupilot built from source which is a .px4 file, It says "Copying files to Aero board (root@intel-aero.local)" and then prompts me for my password. I tried the default password for root which is nothing, the password I set for my user at the beginning, and the default password for the access point. All these passwords are refused and after three attempts I get the message saying:

"Permission denied (publickey, password)"

"lost connection"

I have tried changing the root password and then trying to sign in with that newly changed password but nothing works. Thank you, in advance, for the help

JGome26
New Contributor I
105 Views

Update: I solved the problem. I had to change a few settings in the sshd_config file found in /etc/ssh directory. Root login was prohibited so that field had to be set to yes. This is not recommended due to the security issues that may arise but this is the way to do it.

View solution in original post

idata
Community Manager
104 Views

Hello JorgeG,

 

 

I am very happy the issue got solved!

 

Good luck with all your future projects,

 

 

Best regards,

 

Casandra
Reply