Intel® Aero Platform For UAVs
Peer-to-peer support only
Announcements
This is a peer-to-peer only forum. This forum is not monitored by Intel.

Capture from OV8858

AKomo1
Novice
1,724 Views

I'm trying to capture via 8MP camera, OV8858.

root@intel-aero:~/work# C=4 INPUT=0 MODE=PREVIEW M_F=NV21 ./capture_example --userp -d /dev/video0

Preview mode: 640x480, nv21.

m_width 640, m_height 480, m_sizeimage 462848, m_padded_width:640, bytesperline 640

Saving file: Image-video2-640x480-0.nv21

Saving file: Image-video2-640x480-1.nv21

Saving file: Image-video2-640x480-2.nv21

Saving file: Image-video2-640x480-3.nv21

Preview: Time=141.286000ms FPS=28.311368

And I can get images, but they are really dark. (see attachment, it's 'Hand'.)

I'm not sure whether it's caused by wrong configurations, or hardware defect?

Here are information related to the camera.

[get_aero_version]

BIOS_VERSION = Aero-01.00.12_Prod

OS_VERSION = v01.00.04

AIRMAP_VERSION = 1.8

FPGA_VERSION = 0xff 0xff

[dmesg]

root@intel-aero:~# dmesg | grep INT3477

[ 2.991068] ov8858 i2c-INT3477:00: gmin: initializing atomisp module subdev data.PMIC ID 1

[ 2.991123] acpi INT3477:00: Failed to find gmin variable INT3477:00_CamClk

[ 2.991281] acpi INT3477:00: Failed to find gmin variable INT3477:00_ClkSrc

[ 2.991333] acpi INT3477:00: Failed to find gmin variable INT3477:00_CsiPort

[ 2.991500] acpi INT3477:00: Failed to find gmin variable INT3477:00_CsiLanes

[ 2.991809] acpi INT3477:00: Failed to find gmin variable INT3477:00_eldo1_1p8v

[ 2.991951] acpi INT3477:00: Failed to find gmin variable INT3477:00_eldo1_sel_reg

[ 2.992093] acpi INT3477:00: Failed to find gmin variable INT3477:00_eldo1_ctrl_shift

[ 2.992234] acpi INT3477:00: Failed to find gmin variable INT3477:00_eldo2_1p8v

[ 2.992373] acpi INT3477:00: Failed to find gmin variable INT3477:00_eldo2_sel_reg

[ 2.992541] acpi INT3477:00: Failed to find gmin variable INT3477:00_eldo2_ctrl_shift

[ 3.142409] ov8858 i2c-INT3477:00: camera pdata: port: 1 lanes: 4 order: 00000002

[ 3.143938] ov8858 i2c-INT3477:00: ov8858_detect: chip_id = 0x8858

[ 3.150848] ov8858 i2c-INT3477:00: register atomisp i2c module type 1

[ 4.077699] atomisp-css2401a0_v21 0000:00:03.0: Subdev INT3477:00 successfully register

[v4l2-ctl]

root@intel-aero:~# v4l2-ctl -d /dev/video0 --all

Driver Info (not using libv4l2):

Driver name : atomisp

Card type : ATOM ISP

Bus info : PCI-3

Driver version: 0.5.1

Capabilities : 0x84200003

Video Capture

Video Output

Streaming

Extended Pix Format

Device Capabilities

Device Caps : 0x04200002</s...

10 Replies
idata
Community Manager
293 Views

Hi Aki,

 

 

Thank you for contacting us.

 

 

We are going to investigate more about your case, and we will contact you when we have updates.

 

 

Have a nice day.

 

 

Regards,

 

Leonardo R.
AKomo1
Novice
293 Views

Hi Leonardo,

Thanks for your support.

What do you get if you try those commands on your RTF?

It would be helpful to identify what's wrong with my RTF.

By the way, are there other tools or commands to gather camera, i2c bus information?

Bests,

Aki

idata
Community Manager
293 Views

Hello Aki,

 

 

I just want to let you know that we are currently investigating this issue, we will get back to you as soon as possible.

 

 

We appreciate your patience.

 

 

Best Regards,

 

Leonardo R.
AKomo1
Novice
293 Views

Hi Leonardo,

I'm just wondering that you have got any updates from your team.

I have a quick question.

Could your team re-produce my issue? Or they work fine on their RTFs.

I'm still not sure whether this issue is caused due to my environment, or happens on any RTF. So if you can upload the result what you got on your RTF w/ those commands, it would be helpful to compare them to mine.

Bests,

Aki

idata
Community Manager
293 Views

Hi Aki,

 

 

We are still working on this, we will contact you as soon as we have updates.

 

 

About your question, yes, we have gotten the same outputs using those commands.

 

 

Have a nice day.

 

 

Best Regards,

 

Leonardo R.
AKomo1
Novice
293 Views

How's going on the investigation, any updates?

It seems like harder to solve than I expected, doesn't it...

My original objective is just getting color video stream from front camera, OV8858. But as I mentioned, I couldn't get color image, instead I got dark image.

Do we have any other ways, instead of 'capture_example'? Tools, commands, or sample codes...

Thanks for your continuous support,

Aki

idata
Community Manager
293 Views

Hi Aki,

 

 

Unfortunately, we don't have updates, but I have to tell to you that we are doing our best to solve this.

 

 

At the moment, we don't have other ways to do this. We only have the capture_example.

 

 

We will contact you as soon as we have updates.

 

 

We appreciate your patience.

 

 

Regards,

 

Leonardo R.
AKomo1
Novice
293 Views

Any updates or progress?

idata
Community Manager
293 Views

Hi Aki,

We are still working on this. We know that this is very important for you, and for us too, and that's why I can tell you that we are working hard.

We hope to have updates very soon.

We really appreciate youar patience.

Best Regards,

 

Leonardo R.
DMadi
New Contributor I
293 Views

I have the same issue. If there is a solution I would like to know about it too.

Thanks.

Dan M.

Reply