Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
993 Views

Connect Intel Aero to Qgroundcontrol

Jump to solution

Hello

I am trying to connect Intel Aero Ready to Fly drone to the QGroundControl.

 

I have installed the Ubuntu on Intel Aero Drone and also execute the steps as given in the following link:

https://github.com/intel-aero/meta-intel-aero/wiki/90-%28References%29-OS-user-Installation#qgroundc...

 

For more information:

My Intel Aero drone is connected to the wifi network which is in my lab and my laptop which runs qgroundcontrol is also connected to the same wifi network. So in both the devices I have access to the internet as well.

 

But drone is not been able to qgroundcontrol.

 

Please help

 

Thanks in advance.

 

Regards

Utkarsh

0 Kudos

Accepted Solutions
Highlighted
Employee
75 Views
Hello Utkarsh, The SSH connection will work only when both the drone and the laptop are connected to a WiFi hotspot. You don't need to have the SSH connection for QGC. There are a few thing you can try. the "Waiting for vehicle connection" message appears when QGC can connect to the Aero Compute Board, but it can't connect to the Flight Controller. Could you please check if the mavlink service is running? You will need to run this command: sudo systemctl status mavlink-router Also, please make sure that FPGA and PFX firmware have been successfully flashed. You can check that with the command: sudo aero-get-version.py Another thing you can try is to check if you are booting into the right kernel. This is the command you need to run: uname -a and the output should be something like this: "Linux frelon 4.4.76-aero-1.2 # 1 SMP PREEMPT...." Thank you and best regards, Eliza

View solution in original post

0 Kudos
13 Replies
Highlighted
Employee
75 Views
Hello UGoya, Thank you for your interest in the Intel Aero Ready to Fly drone. In order to connect the drone to QGC on a laptop, you will need to have the hotspot activated on the Intel Aero drone (it is automatically activated when you power up the drone) and to connect the laptop to Aero's access point. By default, Aero's access point is called Aero-<MAC> and Wi-Fi password is 1234567890. Unfortunately, you can't connect the drone to QGC on a laptop and also have Internet connection at the same time. An option you can take into consideration is to install QGC on the drone itself, and use the laptop only when you plan to fly the drone. Thank you and best regards, Eliza
0 Kudos
Highlighted
Beginner
75 Views

Hello Eliza

 

Thank you for the response

 

So I have to connect both my laptop and drone to the Intel Aero's hotspot?

Or

I can connect my drone to any wifi network but laptop to the intel aero hotspot?

 

Regards

Utkarsh

0 Kudos
Highlighted
Employee
75 Views
Hello UGoya, Yes, you will have to connect both Aero and the laptop to Aero's access point. The second option will not work, as if you disable the hotspot on Aero, you won't be able to connect the laptop to it. Thank you and best regards, Eliza
0 Kudos
Highlighted
Beginner
75 Views

Hello Eliza

 

I have connected both my laptop and drone to the intel aero drone hotspot, but still I cannot connect to qgroundcontrol.

 

I have written my laptop IP in this file: sudo gedit /etc/mavlink-router/config.d/qgc.conf

and also in this file : sudo gedit /etc/mavlink-router/main.conf

 

when i am checking the main.conf file I found one line: Log=/var/lib/mavlink-router/

But there is no mavlink-router file in the /var/lib

So I have changed it to /etc/mavlink-router/ and then I again tried to connect my vehicle, but again I was unsuccessful.

 

So Please help, let me know where i am wrong

 

Thanks and Regards

Utkarsh

 

 

0 Kudos
Highlighted
Employee
75 Views
Hello Utkarsh, Could you please let us know what is the message you see in QGC? A screenshot will be helpful! Also, this problem might be caused by firewall stopping the connection between drone and laptop. Could you please disable it and test again? Thank you and best regards, Eliza
0 Kudos
Highlighted
Beginner
75 Views

Hello Eliza

 

My laptop is connected to this network (Intel Aero WIfi) as shown in the following screenshot:

Screenshot from 2019-03-07 14-48-18.png

My drone is connected to the intel aero hotspot as shown in the screenshot:

Screenshot from 2019-03-07 14-45-30.png

 

Also, When I try to establish ssh connection between drone and laptop than it ask for password i typed '1234567890' but it doesnot accept it. and on the link: https://github.com/intel-aero/meta-intel-aero/wiki/08-Aero-Network-and-System-Administration#network...

On the above link it says it requires no password.

 

I will also attach the screenshot of this(on laptop):

Screenshot from 2019-03-07 14-47-17.png

 

I have deactivated the firewall, and on the qgroundcontrol it is just showing waiting for vehicle connection. Screenshot:

Screenshot from 2019-03-07 15-15-00.png

 

I am totally confused, what should I do?

 

Please help

 

Thanks in advance

 

Regards

Utkarsh

0 Kudos
Highlighted
Employee
76 Views
Hello Utkarsh, The SSH connection will work only when both the drone and the laptop are connected to a WiFi hotspot. You don't need to have the SSH connection for QGC. There are a few thing you can try. the "Waiting for vehicle connection" message appears when QGC can connect to the Aero Compute Board, but it can't connect to the Flight Controller. Could you please check if the mavlink service is running? You will need to run this command: sudo systemctl status mavlink-router Also, please make sure that FPGA and PFX firmware have been successfully flashed. You can check that with the command: sudo aero-get-version.py Another thing you can try is to check if you are booting into the right kernel. This is the command you need to run: uname -a and the output should be something like this: "Linux frelon 4.4.76-aero-1.2 # 1 SMP PREEMPT...." Thank you and best regards, Eliza

View solution in original post

0 Kudos
Highlighted
Beginner
75 Views

Hello Eliza

 

I am attaching the screenshot of the results of all the commands which you have told to execute:

Screenshot from 2019-03-07 17-14-17.png

 

I think Mavlink and kernel are correct.

 

But I installed the firmware still it is showing version is unknown.

 

I have installed the firmware using the following command: cd /etc/fpga/

jam -aprogram aero-rtf-recovery.jam

 

Thanks and Regards

Utkarsh

 

 

0 Kudos
Highlighted
Employee
75 Views
Hello Utkarsh, The aero-rtf-recovery.jam should be used only under special circumstances. Could you please install aero-compute-board.jam instead? I assumed that you have tried to install PX4 for Flight Controller, right? Can you check with Ardupilot as well? At least for the moment. Here are the instructions you need to use: cd /etc/aerofc/ardupilot/ aerofc-update.sh arducopter-aerofc-v1.px4 Thank you and best regards, Eliza
0 Kudos
Highlighted
Beginner
75 Views

Hello Eliza

 

I try to run the command but now it is showing the following error:

jam -aprogram aero-compute-board.jam

Jam STAPL Player Version 2.5 (20040526)

Copyright (C) 1997-2004 Altera Corporation

 

Device #1 unable to read IDCODE

Unrecognized device

Exit code = 6... Unrecognized device

 

Previously it run perfectly, but now it is showing something like this.

 

Thanks and Regards

Utkarsh

0 Kudos
Highlighted
Employee
75 Views
Hello Utkarsh, Could you try with "sudo jam -aprogram aero-compute-board.jam"? Thank you, Eliza
0 Kudos
Highlighted
Beginner
75 Views

Hello Eliza

 

Now I am getting the aiframe versio:

BIOS_VERSION = Aero-01.00.16

OS_VERSION = Ubuntu 16.04.6 LTS"

AIRMAP_VERSION = unknown

FPGA_VERSION = 0xc2

AeroFC firmware version = 1.6.5

 

Thank you very much for the help.

 

Now I will try to connect to QGroundController.

 

Thanks and Regards

Utkarsh

0 Kudos
Highlighted
Beginner
75 Views

Hello Eliza

 

Now I have successfully connected my drone to the QGroundControl,.

 

Thank you very much for your help.

 

Thanks and Regards

Utkarsh

0 Kudos