Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JByrn2
Beginner
999 Views

Error connecting qgroundcontrol when running aero ubuntu

Hi,

I could connect and calibrate my controller when running yocto but now that I have moved to ubuntu 16.04 I am getting an error. When I try to connect qgroundcontrol on my phone (running 3.3.5) or laptop (running latest build).I get the following error:

QGroundControl was unable to retrieve the full set of parameters from the vehicle. " 

"This will cause QGroundControl to be unable to display its full user interface. "

 

"If you are using modified firmware, you may need to resolve any vehicle startup errors to resolve the issue. "

 

"If you are using standard firmware, you may need to upgrade to a newer version to resolve the issue."

I have done all the bios firmware fc and fpga updates. bios: 1.00.13, ubuntu 16.04.4 FPGA 0x2c AeroFC 1.6.5,

Is there something I am missing or is there a particular version of qgroundcontrol I should be using?

Tags (1)
0 Kudos
4 Replies
idata
Community Manager
90 Views

Hi jonathanbyrn,

 

 

Thank you for your interest in the Intel Aero drone.

 

When you're using Yocto, the drone is a DHCP server (and WiFi hotspot). So the drone knows the IP of your laptop and is able to send the MAVLink telemetry feed to the right IP. But if you're using Ubuntu, you are probably connected to the same network with variable IPs. Get your laptop IP and run on Aero:
  • sudo mkdir /etc/mavlink-router/config.d
  • create this file: sudo gedit /etc/mavlink-router/config.d/qgc.conf and fill it with:
[UdpEndpoint wifi] Mode = Normal Address = (your laptop's IP address)
  • restart the router: sudo systemctl restart mavlink-router
Also, the last stable version of QGroundcontrol is 3.3.

 

Let me know if it works.

 

 

Regards,

 

Alexandra
JByrn2
Beginner
90 Views

thank you for your prompt reply! Yes, if I manually configure it to pick up an IP address on an network but I plan on using this in a field where there is no external WiFi network.

when I turn on the drone it is initially setting up an aero wifi network so it still sets up as a hotspot. Is it possible to emulate the DHCP behaviour of the yocto setup?

The alternative is that I bring a router and a battery to power it which I would like to avoid. Any advice is greatly appreciated!

idata
Community Manager
90 Views

Hi jonathanbyrn,

 

 

During flying you can still use the drone's hotspot, but the range is going to be very limited.

 

An alternative would be to use a 915MHz telemetry transmitter/receiver.

 

 

Regards,

 

Alexandra
JByrn2
Beginner
90 Views

Thanks, okay that is good to know. I will look into using another radio.

Reply