Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
994 Views

Error /dev/sda while flashing Linux image

Hi !

I'm trying to flash the intel aero image on the RTF drone following the instructions on the intel-aero github. When I boot from the bootable USB key, it starts installing then I get the following error :

" Installing image on /dev/sda ...

Error : Error opening /dev/sda : No medium found "

Can you help me please ?!

0 Kudos
13 Replies
Highlighted
Community Manager
22 Views

Hello lliili,

 

 

 

Thank you for your interest in the Intel Aero Compute Board.

 

Can you please try to see if your Aero is detecting the USB drive and if so how the system is naming it. To do so, with the USB not connected, enter the command ls /dev and capture the output. Then connect your USB drive and enter again the command ls /dev, if the board is detecting it you should see one more result, if so, how is it called?

 

 

Let me know what output you receive.

 

 

Regards,

 

Casandra
0 Kudos
Highlighted
Beginner
22 Views

Thanks for answering,

I get 3 more devices (sdb, sdb1, sdb2) when I connect the usb drive to the hub.

When I run "fdisk -l" I get the following :

Disk /dev/sdb : 3.8 GiB ...

Device Boot ... Size Id Type

/dev/sdb1 * 1.5G 0 Empty

/dev/sdb2 16.9M ef EFI (FAT-12/16/32)

0 Kudos
Highlighted
Beginner
22 Views

I have a little update :

I ran the "cat /proc/partitions" command, and there's no sda device showing up. However, when I plug the USB key and run the same command I see the USB key as sdb (+ sdb1 & sdb2), but again the sda is not showing up.

0 Kudos
Highlighted
Community Manager
22 Views

Hello lliili,

 

 

Could you please send me a print screen of this output?

 

It would be very helpful.

 

 

Thank you very much in advance,

 

Casandra
0 Kudos
Highlighted
Beginner
22 Views

This is what I get after I press "install" in the grub menu

This is an extract from the output of the fdisk -l command :

And this is the the output for the cat /proc/partitions command :

Thanks !!

0 Kudos
Highlighted
Community Manager
22 Views

Hello lliili,

 

 

 

I have done some research and all the information I found in regards to the error message:

" Installing image on /dev/sda ...

Error : Error opening /dev/sda : No medium found " , suggests that there may be something wrong with your USB key.

Could you try creating a bootable image image with a different USB key?

 

 

Let me know if this works.

 

 

Regards,

 

Casandra
0 Kudos
Highlighted
Beginner
22 Views

I am working with a 2.0 USB OTG hub. And for now, I have tried with a 2.0 and with a 3.0 USB key; both resulting in the same error.

I will try some diiferent USB keys and I'll let you know if it worked.

Thanks again !

0 Kudos
Highlighted
Community Manager
22 Views

Hello lliili,

 

 

I would advise, using an USB 3.0 OTG you can find information on this here: /message/536901# 536901 Announcement: USB 3.0 OTG cable on click.intel.com

 

 

Let me know, how it works with a different USB key. I hope it will be successful.

 

 

Thank you,

 

Casandra
0 Kudos
Highlighted
Beginner
22 Views

Hi,

Thanks for te link, but can you please recommend me a 3.0 OTG Hub because I am using the "recommended method" ie keyboard + mouse + USB key (+HDMI).

Tnx in advance!

0 Kudos
Highlighted
Community Manager
22 Views

Hello lliili,

 

 

There are many USB hubs on the market from which to choose from, unfortunately, we cannot recommend one.

 

 

You can check the following thread to see what other users have used: https://communities.intel.com/message/449747# 449747 https://communities.intel.com/message/449747# 449747

 

 

Let me know if this helps.

 

 

Regards,

 

Casandra

 

 

 

0 Kudos
Highlighted
Community Manager
22 Views

Hello lliili,

 

 

 

Can you please tell me, if there is anything else we can assist you with?

 

Was my advise helpful?

 

 

Regards,

 

Casandra

 

0 Kudos
Highlighted
Beginner
22 Views

Hi,

I haven't received the new cables yet. I'll keep you posted as soon as i get them.

Tnx !

0 Kudos
Highlighted
Community Manager
22 Views

Hello lliili,

 

 

Thank you for your reply, I will close this thread for now.

 

Once you get the new cables, if you run into any trouble, please let us know in the community.

 

 

Thank you,

 

Casandra
0 Kudos