Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DKuro1
Beginner
1,009 Views

How to prevent the drone from connecting to its internal network ("Aero-xxxxx") on startup?

Jump to solution

Hi,

Is there any way to make the drone connect to my own network instead of "aero-xxxx" on startup?

Daniel

Tags (1)
0 Kudos
1 Solution
Octavian_C_Intel
Employee
109 Views

Hello Daniel,

 

Thank you for your interest in the Intel Aero drone.

In order to have internet access on Aero board it's possible to switch it to client mode so it connects to your Access Point instead of being an Access Point itself. We'll use the standard connman.

Here's the procedure:

  • First you need to disable AP mode which is the default one:
nmcli c down hotspot

 

Connection 'hotspot' successfully deactivated (D-Bus active path: ...

 

nmcli c modify hotspot connection.autoconnect no
  • Scan WiFi networks with nmcli dev wifi command. Example:
nmcli dev wifi  ABCD-C072-5 Infra 157 54 Mbit/s 79 *** WPA1 WPA2  MYOFFICEWLAN Infra 44 54 Mbit/s 75 *** WPA1 WPA2 802.1X  LabWLAN Infra 44 54 Mbit/s 75 *** WPA2 802.1X  AndroidHotspot Infra 44 54 Mbit/s 74 *** WPA2 802.1X  OfficeWLAN2 Infra 1 54 Mbit/s 74 *** WPA2 802.1X
  • Connect to one network by giving the desired ssid and passkey. From the example above we can connect to ABCD-C072-5 with:
nmcli dev wifi connect ABCD-C072-5 password 12mysecretpassword34

With this configuration it will try to autoconnect to this network every time you boot Intel Aero board.

You can find more information on our wiki: https://github.com/intel-aero/meta-intel-aero/wiki/08-Aero-Network-and-System-Administration# networking-internet-access 08 Aero Network and System Administration · intel-aero/meta-intel-aero Wiki · GitHub

Hope this helps.

Regards,

Octavian

View solution in original post

3 Replies
Octavian_C_Intel
Employee
110 Views

Hello Daniel,

 

Thank you for your interest in the Intel Aero drone.

In order to have internet access on Aero board it's possible to switch it to client mode so it connects to your Access Point instead of being an Access Point itself. We'll use the standard connman.

Here's the procedure:

  • First you need to disable AP mode which is the default one:
nmcli c down hotspot

 

Connection 'hotspot' successfully deactivated (D-Bus active path: ...

 

nmcli c modify hotspot connection.autoconnect no
  • Scan WiFi networks with nmcli dev wifi command. Example:
nmcli dev wifi  ABCD-C072-5 Infra 157 54 Mbit/s 79 *** WPA1 WPA2  MYOFFICEWLAN Infra 44 54 Mbit/s 75 *** WPA1 WPA2 802.1X  LabWLAN Infra 44 54 Mbit/s 75 *** WPA2 802.1X  AndroidHotspot Infra 44 54 Mbit/s 74 *** WPA2 802.1X  OfficeWLAN2 Infra 1 54 Mbit/s 74 *** WPA2 802.1X
  • Connect to one network by giving the desired ssid and passkey. From the example above we can connect to ABCD-C072-5 with:
nmcli dev wifi connect ABCD-C072-5 password 12mysecretpassword34

With this configuration it will try to autoconnect to this network every time you boot Intel Aero board.

You can find more information on our wiki: https://github.com/intel-aero/meta-intel-aero/wiki/08-Aero-Network-and-System-Administration# networking-internet-access 08 Aero Network and System Administration · intel-aero/meta-intel-aero Wiki · GitHub

Hope this helps.

Regards,

Octavian

View solution in original post

idata
Community Manager
109 Views

Hello Daniel,

 

 

Thank you for your interest in the Intel Aero compute board.

 

 

Do you require any more assistance regarding this issue?

 

 

Regards,

 

Octavian
JByrn2
Beginner
109 Views

I found that when I restarted the drone it also restarted the hotspot. I added "nmcli c down hotspot" to the file /etc/rc.local and now it is automatically picking up the wifi network.

Reply