Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
1,240 Views

Intel Aero - Mission transfer fails with QGroundControl

Hello,

I was trying to get the Intel Aero to do a follow waypoint mission created with QGroundControl. The UAV was set-up following https://github.com/intel-aero/meta-intel-aero/wiki/02-Initial-setup 02 Initial Setup · intel-aero/meta-intel-aero Wiki · GitHub , so the main computer is still running yocto. I selected px4 as the firmware for the flight controller. I am running QGroundControl version 3.3.1 on an Android phone, and I am connecting to the drone using the drone wifi access point. The error I get when I try to upload is "Mission transfer failed Error: Vehicle did not request all items from ground station MISSION_REQUEST", and the QGround control console output is "Critical: Operation timeout". I tried maybe 10-15 times and did a reboot of the drone and closed and reopened QGroundControl. Other than that I haven't had any connection problem (calibration and telemetry worked fine) and flew for about ten minutes in position mode before trying to upload waypoints. Has anyone else run into that issue? Or on the contrary got it working (maybe with a different setup)? I would appreciate any pointers to what might be going wrong and on where to look for more information.

Thanks for your help,

0 Kudos
3 Replies
Highlighted
Community Manager
43 Views

Hi Coline,

 

 

Thank you for your interest in the Intel Aero drone.

 

Try installing the Ardupilot version and let me know if it works.

 

 

Regards,

 

Alexandra
Highlighted
New Contributor I
43 Views

Thanks Alexandra for the quick reply. I flashed Ardupilot onto the flight controller and I was able to upload the waypoint mission without error, I haven't tried it yet but I will let you know how it goes.I had some issues with the compass calibration however. I tried 3 or 4 times and can't get any better than 0 for the quality. But since the drone was behaving OK in position hold with px4, it might just be a bug? I'll report back once I've flown.

 

0 Kudos
Highlighted
New Contributor I
43 Views

The weather has been consistently bad for the past two weeks so I haven't flown the waypoint mission, but the position hold is working fine

0 Kudos