Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RKura
New Contributor I
2,792 Views

Intel Aero RTF does not detect mouse/keyboard after installing Ubuntu 16.04.3 LTS

Jump to solution

I first upgraded Yochto to the latest kernel using the iso file on intel website. Then flahsed the BIOS, FPGA and FC.

 

Then I installed Ubuntu 16.04.3 LTS which went fine. I followed the steps on the wiki

https://github.com/intel-aero/meta-intel-aero/wiki/90-%28References%29-OS-user-Installation#installi...

 

After completing the installation, I was asked to restart to complete the installation.

Upon restart the keyboard and mouse connected to the OTG cable are not detected anymore so there is no way for me to interact with the RTF drone.

 

What can I do here ?

 

The drone is not connected to any Wifi after installation is complete so I cannot ssh to it either from my local laptop. Nor can I see the AERO-xxxx hotspot in the list of wifi connections on my local laptop.

So I cant really access the intel-aero shell to add the intel-aero repository.

The keyboard/mouse are only detected upon power on and if I enter the BIOS menu.

Any help is appreciated.

0 Kudos
1 Solution
98 Views
Hi RKura, Thank you for your interest in the Intel Aero drone. Other users have seen this issue when installing updates/3rd party software during the install. Could you try to re-install Ubuntu without an internet connection? Make sure not to install any updates or 3rd party software during the installation process. Regards, Alexandra

View solution in original post

14 Replies
RKura
New Contributor I
98 Views

Here is a screen shot of the USB configuration settings from BIOS menu. Does this look okay ?

RKura
New Contributor I
98 Views

The keyboard/mouse work till the time I restart the computer after the Ubuntu installation is complete. Once I do that, and right before the login screen appears the keyboard and mouse stop working. So somewhere between the restart and the coming back up is the USB OTG disabled somewhere. What can I do here to resolve this ? I cannot access the Intel-Aero at all now with this setup.

RKura
New Contributor I
98 Views

The funny thing is, when I started installing Ubuntu today the keyboard and mouse were detected just fine.

 

I was able to get to the BIOS menu, boot from usb stick and go thru the usual ubuntu install.

 

After the install completed, it asked me to restart which is normal. I was able to use the mouse to click the Restart Now button.

 

After the restart, it asked me to remove the USB media and hit Enter (which I believe is also normal for installation via USB or CD/DVD media). I did that and hit enter on my keyboard.

 

So the keyboard and mouse were detectable till then. Then the screen went blank for 2 secs and came up with the login screen to enter my password.

 

When the screen went blank, thats when the keyboard and mouse stopped working. So somehow the USB OTG connection was disabled during that time and so the keyboard and mouse connected to it were not responsive anymore. Any idea what may have happened ? I suspect some kind of ubuntu BIOS config setting for Intel Aero that I am unaware of. Or perhaps kernel incompatibility. But if you have and others may have installed the same ubuntu version on Intel Aero (after upgrading it to the latest FPGA, FC and BIOS), then why am I hitting this issue ?

99 Views
Hi RKura, Thank you for your interest in the Intel Aero drone. Other users have seen this issue when installing updates/3rd party software during the install. Could you try to re-install Ubuntu without an internet connection? Make sure not to install any updates or 3rd party software during the installation process. Regards, Alexandra

View solution in original post

RKura
New Contributor I
98 Views

i@Alexandra_Intel​  ,

That worked and I was able to maintain control of the mouse and keyboard after the restart. Thanks for the tip.

 

Now once this is done and Ubuntu is installed, I

  • Add the Intel Aero Repository
  • QGC configuration
  • Configure the RealSense R200 camera

For that, It asks me to do

cd

sudo apt-get -y install git libusb-1.0-0-dev pkg-config libgtk-3-dev libglfw3-dev cmake

git clone https://github.com/IntelRealSense/librealsense.git

cd librealsense

mkdir build && cd build

cmake ../ -DBUILD_EXAMPLES=true -DBUILD_GRAPHICAL_EXAMPLES=true

make

sudo make install

 

The apt-get and git clone commands require internet. How do I do them when I am connected to the AERO-xxxx hotspot on the intel-aero ?

RKura
New Contributor I
98 Views

@Alexandra_Intel​ 

 

I have installed ubuntu 16.04 LTS on intel-aero.

Can you tell me how I can use apt-get install to download any packages on intel-aero ? It requires internet and I am connected to the Aero hotspot on the intel-aero.

98 Views
Hi RKura, You should run the command nmcli c down hotspot , then you should be able to connect to a WiFi network as described in the link below: https://github.com/intel-aero/meta-intel-aero/wiki/08-Aero-Network-and-System-Administration#network... Regards, Alexandra
RKura
New Contributor I
98 Views

@Alexandra_Intel​ 

Thanks.

 

Should 'hotspot' be 'AERO-xxxxxxx' or just 'hotspot' in the commands ?

98 Views
Hi RKura, Just 'hotspot'. Regards, Alexandra
RKura
New Contributor I
98 Views

@Alexandra_Intel​ 

Thanks.

I did notice one strange thing.

When I have the intel-aero connected via HDMI to a monitor, then shut down the computer (not power off the drone), the next time I power it on, I do not see the AERO-xxxxx hotspot on my local laptop. What is the best way to turn off the intel-aero when it is connected via HDMI ? Should I always power it off ?

Eliza_D_Intel
Employee
98 Views
Hello RKura, For turning down the hotspot on your drone you need to use the command: nmcli c down hotspot For turning up the hotspot on your drone you need to use the command: nmcli c up hotspot Yes, if you are not using your drone continuously, it will be better to turn it off. Thank you and best regards, Eliza
RKura
New Contributor I
98 Views

@ElizaD_Intel​ 

Thanks.

So to turn the drone off, power it off using the power button on the drone. Is that right ?

Eliza_D_Intel
Employee
98 Views
Hello RKura, Yes, and you can also type in the terminal: shutdown now Thank you and best regards, Eliza
RKura
New Contributor I
98 Views

@ElizaD_Intel​ 

Thanks. I tried shutting down the computer like I would a Ubuntu desktop and I did see a few strange things after (like sometimes AERO-xxxx wont show up).

I will make sure to either power off the drone or use the shutdown now command in terminal.

Reply