Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
64 Views

JAM 2.5 Player for Max 10 FPGA (10M08SAM153) on Intel Aero Compute Board fails to program/erase

Im aware that Intel has dicontinued the Aero Compute Board but as a PhD student my research depend upon it. I have tried all possible ways to flash the  MAX 10 FPGA  on Intel Aero compute board using the default embedded JAM Player 2.5 that comes preinstalled on Intel aero-linux operating system. Im following instructions on: https://github.com/intel-aero/meta-intel-aero/wiki/02-Initial-Setup#flashing and https://github.com/intel-aero/meta-intel-aero/wiki/95-(References)-FPGA .  On booting the intel-aero-linux I ran

aero-get-version.py

Which gives me :

BIOS_VERSION = Aero-01.00.16
OS_VERSION = Poky Aero (Intel Aero linux distro) v1.6.2 (pyro)
FPGA_VERSION = 0xff
Aero FC Firmware Version = unknown

The command I am running to flash the fpga is:

#jam -aprogram /etc/fpga/aero-compute-board.jam

The jam file comes installed on the aero-linux under /etc/fpga/ directory. After the first successful attempt, every other attempt since then has failed right at the beginning and has never proceeded to flashing the CRM0. I dont know what might be the reason behind this. 

One of the error messages is:

Jam STAPL Player Version 2.5 (20040526)
Copyright (c) 1997-2004 Altera Corporation

Device #1 IDCODE is 031820DD
full-chip erasing Max 10 FPGA device(s) ...
Device programming failure
Exit code = 10...Device programming failure

I know the device doesnt have hardware continuity problem and the JTAG connection is successful as it passes the READ_USERCODE & CHECK_IDCODE actions:

$jam -acheck_idcode /etc/fpga/aero-compute-board.jam

Any help would be greatly appreciated. Thank you

0 Kudos
0 Replies